aboutsummaryrefslogtreecommitdiff
path: root/editors/hte/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-08 11:47:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-08 11:47:01 +0000
commit4957800348fcecd67da57a7465f6ee93f8fba363 (patch)
tree270802510ab8e9ce851bdba856bddf7d22f65ee9 /editors/hte/Makefile
parent3169283da15318b1ff81d1a1968cb75dd56c24cd (diff)
- Update to 2.0
Changes: * 64-bit support (hopefully buildable on all platforms now). * > 4 GiB file size support * New disassemblers for x86_64, ARM, 64bit PPC, VMX128 extensions for PE and ELF files * New x86_64 assembler * Improved ELF handling PR: 110070 Submitted by: Marcus von Appen <mva@sysfault.org> (maintainer)
Notes
Notes: svn path=/head/; revision=186887
Diffstat (limited to 'editors/hte/Makefile')
-rw-r--r--editors/hte/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/editors/hte/Makefile b/editors/hte/Makefile
index 4d675910a877..ef340b43f9be 100644
--- a/editors/hte/Makefile
+++ b/editors/hte/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hte
-PORTVERSION= 0.9.4
+PORTVERSION= 2.0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +16,7 @@ DISTNAME= ht-${PORTVERSION}
MAINTAINER= mva@sysfault.org
COMMENT= A file editor/viewer/analyzer for executables
+USE_GCC= 4.1+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -24,21 +25,12 @@ PLIST_FILES= bin/ht
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= does not build on ia64
-.endif
-
-.if ${OSVERSION} < 400000
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS=--disable-x11-textmode
.else
USE_XLIB= yes
-CPPFLAGS= -I${X11BASE}/include
-LDFLAGS= -L${X11BASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-L${X11BASE}/lib"
.endif
.if !defined(NOPORTDOCS)
@@ -52,8 +44,6 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|typedef unsigned int uint;||g' ${WRKSRC}/global.h
- @${REINPLACE_CMD} -e \
- 's|uint |UINT |g' ${WRKSRC}/htdata.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ht ${PREFIX}/bin