aboutsummaryrefslogtreecommitdiff
path: root/editors/hte
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-03-16 21:29:02 +0000
committerRene Ladan <rene@FreeBSD.org>2018-03-16 21:29:02 +0000
commitda7ccf47874f7965b9e9d6fe0292979c5c78c25e (patch)
treee710078c06d7b11026209460684086fcac20b6ce /editors/hte
parent741bfab11594a277c14f146d45bce7a80c4eb391 (diff)
downloadports-da7ccf47874f7965b9e9d6fe0292979c5c78c25e.tar.gz
ports-da7ccf47874f7965b9e9d6fe0292979c5c78c25e.zip
Notes
Diffstat (limited to 'editors/hte')
-rw-r--r--editors/hte/Makefile23
-rw-r--r--editors/hte/distinfo5
-rw-r--r--editors/hte/files/patch-htapp.cc11
3 files changed, 17 insertions, 22 deletions
diff --git a/editors/hte/Makefile b/editors/hte/Makefile
index 13f7d5425e1f..7b42fb5294f0 100644
--- a/editors/hte/Makefile
+++ b/editors/hte/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= hte
-PORTVERSION= 2.1.0
+PORTVERSION= 2.1.1.g20161206
CATEGORIES= editors
-MASTER_SITES= SF/${PORTNAME}/ht-source
-DISTNAME= ht-${PORTVERSION}
MAINTAINER= rene@FreeBSD.org
COMMENT= File editor/viewer/analyzer for executables
@@ -13,7 +11,13 @@ COMMENT= File editor/viewer/analyzer for executables
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= ncurses tar:bzip2
+BROKEN_FreeBSD_10= misgenerated yacc code
+
+USES= autoreconf compiler:c++14-lang makeinfo ncurses tar:bzip2
+USE_GITHUB= yes
+GH_ACCOUNT= sebastianbiallas
+GH_PROJECT= ht
+GH_TAGNAME= e9e63373148da5d7df397d8075740d8c096ecb1d
GNU_CONFIGURE= yes
PLIST_FILES= bin/hte
@@ -32,11 +36,12 @@ X11_USE= XORG=x11
X11_USES= localbase:ldflags
X11_CONFIGURE_ENABLE= x11-textmode
-post-patch:
- @${REINPLACE_CMD} -e 's|^CXXFLAGS=.*$$|CXXFLAGS="$$CXXFLAGS"|g ; \
- s|^CFLAGS=.*$$|CFLAGS="$$CFLAGS"|g ; \
- s|-L/usr/X11/lib -L/usr/X11R6/lib|$$LDFLAGS|g' \
- ${WRKSRC}/configure
+MAKE_JOBS_UNSAFE= yes
+
+pre-build:
+ ${MAKE} -C ${WRKSRC}/tools
+ ${MAKE} -C ${WRKSRC}/doc
+ ${MAKE} -C ${WRKSRC} htdoc.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ht ${STAGEDIR}${PREFIX}/bin/hte
diff --git a/editors/hte/distinfo b/editors/hte/distinfo
index 0a00366c6fe0..b74103ca4a6b 100644
--- a/editors/hte/distinfo
+++ b/editors/hte/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ht-2.1.0.tar.bz2) = 31f5e8e2ca7f85d40bb18ef518bf1a105a6f602918a0755bc649f3f407b75d70
-SIZE (ht-2.1.0.tar.bz2) = 884139
+TIMESTAMP = 1521235485
+SHA256 (sebastianbiallas-ht-2.1.1.g20161206-e9e63373148da5d7df397d8075740d8c096ecb1d_GH0.tar.gz) = 54f1848a180b8f4f7f9fc5a421201e25447f999680ca8f7e6fd976020c41b14d
+SIZE (sebastianbiallas-ht-2.1.1.g20161206-e9e63373148da5d7df397d8075740d8c096ecb1d_GH0.tar.gz) = 847045
diff --git a/editors/hte/files/patch-htapp.cc b/editors/hte/files/patch-htapp.cc
deleted file mode 100644
index 0b90d4ea3910..000000000000
--- a/editors/hte/files/patch-htapp.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- htapp.cc.orig 2016-07-02 07:48:11 UTC
-+++ htapp.cc
-@@ -3023,7 +3023,7 @@ static uint isqr(uint u)
- {
- uint a = 2;
- uint b = u/a;
-- while (abs(a - b) > 1) {
-+ while (abs((int)(a - b)) > 1) {
- a = (a+b)/2;
- b = u/a;
- }