aboutsummaryrefslogtreecommitdiff
path: root/editors/jed-devel/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-11-07 13:58:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-11-07 13:58:50 +0000
commit9a553d8c9b4c111361af10a7d6ded85a60b5e970 (patch)
treec69a12df3a261a6c09794120650e1e6fb5ec866c /editors/jed-devel/Makefile
parentb1b5d62a850ec38fa9ed2b979c764e58146bb444 (diff)
Notes
Diffstat (limited to 'editors/jed-devel/Makefile')
-rw-r--r--editors/jed-devel/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/editors/jed-devel/Makefile b/editors/jed-devel/Makefile
index 842c67ff1ed4..658e113c3875 100644
--- a/editors/jed-devel/Makefile
+++ b/editors/jed-devel/Makefile
@@ -26,8 +26,7 @@ DIST_SUBDIR= jed
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= JED_ROOT=${PREFIX}/lib/jed
-MAKE_ENV+= DEST_INFO_DIR=${PREFIX}/${INFO_PATH} \
- DEST_DOC_DIR=${DOCSDIR}
+MAKE_ENV+= DEST_DOC_DIR=${DOCSDIR}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PORTDOCS= *
@@ -39,7 +38,6 @@ MAKE_ENV+= JED_DOC_FILES="" \
ALL_TARGET= all getmail
MAN1= jed.1 rgrep.1
-INFO= jed
.include <bsd.port.pre.mk>
@@ -64,18 +62,10 @@ post-patch:
@${REINPLACE_CMD} -e 's,__linux__,__FreeBSD__,g' \
${WRKSRC}/src/pty.c
@${REINPLACE_CMD} -e 's,(DEST_JED_ROOT)/doc,(DEST_DOC_DIR),g' \
- -e 's,(DEST_JED_ROOT)/info,(DEST_INFO_DIR),g' \
- -e 's,\.\./info/\*,../info/jed.info ../info/jed.info-\[0-9\],' \
+ -e 's,\.\./info/\*,,' \
-e 's,^\(JED_DOC_.*FILES\) =,\1 \?=,g' \
${WRKSRC}/src/Makefile.in
-pre-configure:
-.for n in 1 2 3
- @${MV} ${WRKSRC}/info/jed.${n}in ${WRKSRC}/info/jed.info-${n}
-.endfor
- @${REINPLACE_CMD} 's|jed.\([0-9]\)in|jed.info-\1|' \
- ${WRKSRC}/info/jed.info
-
post-configure:
@${REINPLACE_CMD} -e 's,\(.usr.bin.install\) *-c,\1 -s -m 555,' \
${WRKSRC}/src/Makefile