aboutsummaryrefslogtreecommitdiff
path: root/editors/jove
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-03-04 00:03:01 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-03-04 00:03:01 +0000
commit49aeb931553b9cf17fddf9ca2304cf4fda223de0 (patch)
tree9e1daa81b862c1ddc05a8a26dda142ad27456eea /editors/jove
parent2dee12c1fe03145f084664b50827824c68349734 (diff)
downloadports-49aeb931553b9cf17fddf9ca2304cf4fda223de0.tar.gz
ports-49aeb931553b9cf17fddf9ca2304cf4fda223de0.zip
Notes
Diffstat (limited to 'editors/jove')
-rw-r--r--editors/jove/Makefile11
-rw-r--r--editors/jove/files/patch-io.c12
-rw-r--r--editors/jove/files/patch-io.h11
-rw-r--r--editors/jove/files/patch-recover.c20
-rw-r--r--editors/jove/pkg-descr7
5 files changed, 10 insertions, 51 deletions
diff --git a/editors/jove/Makefile b/editors/jove/Makefile
index 3d74291ab014..36ba7dccb455 100644
--- a/editors/jove/Makefile
+++ b/editors/jove/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jove
PORTVERSION= 4.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/moraes/jove/ \
LOCAL/simon
@@ -11,8 +11,17 @@ MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/moraes/jove/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Jonathan's Own Version of Emacs
+LICENSE= JOVE
+LICENSE_NAME= JOVE License
+LICENSE_FILE= ${WRKSRC}/README
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
USES= ncurses
MAKE_ARGS= LIBS="${LDFLAGS} -lncurses"
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+# Fix collisions with getline(3)
+ @${REINPLACE_CMD} 's|[[:<:]]getline[[:>:]]|get_line|g' ${WRKSRC}/*.c ${WRKSRC}/*.h
+
.include <bsd.port.mk>
diff --git a/editors/jove/files/patch-io.c b/editors/jove/files/patch-io.c
index 3871701844df..2017a06c133f 100644
--- a/editors/jove/files/patch-io.c
+++ b/editors/jove/files/patch-io.c
@@ -17,15 +17,3 @@
#else /* MSFILESYSTEM */
tmpfd = open(tfname, O_CREAT|O_EXCL|O_BINARY|O_RDWR, S_IWRITE|S_IREAD);
#endif /* MSFILESYSTEM */
-@@ -1240,9 +1246,9 @@ int Jr_Len; /* length of Just Read Line
-
- void
- #ifdef USE_PROTOTYPES
--getline proto((daddr addr, register char *buf))
-+get_line proto((daddr addr, register char *buf))
- #else
--getline(addr, buf)
-+get_line(addr, buf)
- daddr addr;
- register char *buf;
- #endif
diff --git a/editors/jove/files/patch-io.h b/editors/jove/files/patch-io.h
deleted file mode 100644
index 5bdd51dd6762..000000000000
--- a/editors/jove/files/patch-io.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- io.h.orig 1996-03-07 17:34:42 UTC
-+++ io.h
-@@ -37,7 +37,7 @@ extern void
- close_file proto((File *fp)),
- d_cache_init proto((void)),
- file_write proto((char *fname, bool app)),
-- getline proto((daddr addr,char *buf)),
-+ get_line proto((daddr addr,char *buf)),
- lsave proto((void)),
- putreg proto((File *fp,LinePtr line1,int char1,LinePtr line2,int char2,bool makesure)),
- read_file proto((char *file, bool is_insert)),
diff --git a/editors/jove/files/patch-recover.c b/editors/jove/files/patch-recover.c
deleted file mode 100644
index bbac5867cb5b..000000000000
--- a/editors/jove/files/patch-recover.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- recover.c.orig 1996-03-07 17:34:43 UTC
-+++ recover.c
-@@ -160,7 +160,7 @@ size_t n;
- private char *getblock proto((daddr atl));
-
- void
--getline(tl, buf)
-+get_line(tl, buf)
- daddr tl;
- char *buf;
- {
-@@ -561,7 +561,7 @@ FILE *out;
- Nchars = Nlines = 0L;
- while (--nlines >= 0) {
- addr = getaddr(ptrs_fp);
-- getline(addr, buf);
-+ get_line(addr, buf);
- Nlines += 1;
- Nchars += 1 + strlen(buf);
- fputs(buf, out);
diff --git a/editors/jove/pkg-descr b/editors/jove/pkg-descr
index 3660a58e54f2..d60454b0e82d 100644
--- a/editors/jove/pkg-descr
+++ b/editors/jove/pkg-descr
@@ -1,10 +1,3 @@
-###########################################################################
-# This program is Copyright (C) 1986, 1987, 1988 by Jonathan Payne. JOVE #
-# is provided to you without charge, and with no warranty. You may give #
-# away copies of JOVE, including sources, provided that this notice is #
-# included in all the files. #
-###########################################################################
-
Jove is a simple text editor in the spirit of GNU emacs, but somewhat
smaller and faster to start up.