aboutsummaryrefslogtreecommitdiff
path: root/editors/jucipp
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-05-17 11:43:55 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-05-17 11:43:55 +0000
commit2bb46554b357a10661f199a24b911cd56f965579 (patch)
treefa5481223eadd2c26f15bc1609b88af01ded1c70 /editors/jucipp
parent529b55ebcb037a00da1b884f6c53106beec8c6f9 (diff)
downloadports-2bb46554b357a10661f199a24b911cd56f965579.tar.gz
ports-2bb46554b357a10661f199a24b911cd56f965579.zip
editors/jucipp: add runtime dependency and TEST option
* Add runtime dependency on devel/universal-ctags as suggested by upstream * Add TEST option PR: 246464 Submitted by: info@babaei.net (maintainer)
Notes
Notes: svn path=/head/; revision=535542
Diffstat (limited to 'editors/jucipp')
-rw-r--r--editors/jucipp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/jucipp/Makefile b/editors/jucipp/Makefile
index ab7d763cb452..2e14345a6b70 100644
--- a/editors/jucipp/Makefile
+++ b/editors/jucipp/Makefile
@@ -4,6 +4,7 @@
PORTNAME= jucipp
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= info@babaei.net
@@ -16,7 +17,8 @@ BUILD_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT}
LIB_DEPENDS= libaspell.so:textproc/aspell \
libboost_filesystem.so:devel/boost-libs \
libgit2.so:devel/libgit2
-RUN_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT}
+RUN_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
+ uctags:devel/universal-ctags
USES= cmake compiler:c++14-lang desktop-file-utils gnome pkgconfig
USE_GITLAB= yes
@@ -27,6 +29,10 @@ GL_TUPLE= cppit:libclangmm:a0316826f7f0c91949c6e11376fd4e92e39a008c:libclangmm/l
USE_GNOME= gdkpixbuf2 gtkmm30 gtksourceviewmm3
INSTALLS_ICONS= yes
+OPTIONS_DEFINE= TESTS
+
+TESTS_CMAKE_BOOL= BUILD_TESTING
+
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH=${LOCALBASE}/llvm${LLVM_DEFAULT}/include \
-DCMAKE_LIBRARY_PATH=${LOCALBASE}/llvm${LLVM_DEFAULT}/lib