aboutsummaryrefslogtreecommitdiff
path: root/editors/jucipp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 18:20:17 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 18:20:17 +0000
commit4aef7c9e57c8c0c376806e8fa2568e8038a0bc8b (patch)
treeb2ed38fefb1bf9b078b15a886dddfd1073654e28 /editors/jucipp
parent9bef9f7a1b7b804110a3f3938ece35a1a599c2c5 (diff)
downloadports-4aef7c9e57c8c0c376806e8fa2568e8038a0bc8b.tar.gz
ports-4aef7c9e57c8c0c376806e8fa2568e8038a0bc8b.zip
Notes
Diffstat (limited to 'editors/jucipp')
-rw-r--r--editors/jucipp/Makefile38
-rw-r--r--editors/jucipp/distinfo7
-rw-r--r--editors/jucipp/pkg-descr16
3 files changed, 61 insertions, 0 deletions
diff --git a/editors/jucipp/Makefile b/editors/jucipp/Makefile
new file mode 100644
index 000000000000..b5a4e1bba2b1
--- /dev/null
+++ b/editors/jucipp/Makefile
@@ -0,0 +1,38 @@
+# Created by: Mohammad S. Babaei <info@babaei.net>
+# $FreeBSD$
+
+PORTNAME= jucipp
+PORTVERSION= 1.2.3
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+
+MAINTAINER= info@babaei.net
+COMMENT= Lightweight C++-IDE with support for C++11, C++14 and C++17
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libaspell.so:textproc/aspell \
+ libboost_filesystem.so:devel/boost-libs \
+ libgit2.so:devel/libgit2 \
+ libclang.so:devel/llvm40
+
+USE_GNOME= gdkpixbuf2 gtkmm30 gtksourceviewmm3
+USES= cmake:outsource desktop-file-utils ninja pkgconfig
+INSTALLS_ICONS= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= cppit
+GH_TUPLE= cppit:libclangmm:1ef0424:libclangmm/libclangmm \
+ eidheim:tiny-process-library:8025c45:tiny_process_library/tiny-process-library
+
+PLIST_FILES= bin/juci \
+ share/applications/juci.desktop \
+ share/icons/hicolor/scalable/apps/juci.svg
+
+post-patch:
+# Make sure that jucipp can find LLVM 4.0
+ @${REINPLACE_CMD} 's,[[:<:]]llvm39/\(.*\)[[:>:]],llvm40/\1,g' \
+ ${WRKSRC}/cmake_modules/FindLibClang.cmake
+
+.include <bsd.port.mk>
diff --git a/editors/jucipp/distinfo b/editors/jucipp/distinfo
new file mode 100644
index 000000000000..9a5c8d0239c4
--- /dev/null
+++ b/editors/jucipp/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1492970358
+SHA256 (cppit-jucipp-v1.2.3_GH0.tar.gz) = 18a5ceba2bf904da35e1b80eaddc31e92b0c4c01e8efd163f3d6da862b5d33fb
+SIZE (cppit-jucipp-v1.2.3_GH0.tar.gz) = 354568
+SHA256 (cppit-libclangmm-1ef0424_GH0.tar.gz) = 207638f46986ae61c060f35095b31a7c0f6771ca24495ad0bfbb02918f76ea5c
+SIZE (cppit-libclangmm-1ef0424_GH0.tar.gz) = 13817
+SHA256 (eidheim-tiny-process-library-8025c45_GH0.tar.gz) = d1ddc974e4047c1c9af9fed21cfaec730a215e3f7a7d74bcd943dd0e6a3eb475
+SIZE (eidheim-tiny-process-library-8025c45_GH0.tar.gz) = 8032
diff --git a/editors/jucipp/pkg-descr b/editors/jucipp/pkg-descr
new file mode 100644
index 000000000000..03f8600b6bce
--- /dev/null
+++ b/editors/jucipp/pkg-descr
@@ -0,0 +1,16 @@
+juCI++, is a platform independent and lightweight C++ IDE designed towards
+libclang with speed, stability, and ease of use in mind.
+
+It supports syntax highlighting for more than 100 different file types.
+Furthermore, it supports CMake and Meson as build systems. juCI++ implements
+Git support through libgit2. It provides debug integration, both local and
+remote through lldb.
+
+Other supported featured are: fast C++ autocompletion, tooltips showing type
+information and doxygen documentation, rename refactoring across files,
+automated documentation search, find symbol through Ctags, spell checking
+depending on file context, runnig shell commands within JuCi++, regex search
+and replace, smart paste, keys and indentation, source minimap, split view,
+full UTF-8 support; just to name a few.
+
+WWW: https://github.com/cppit/jucipp