aboutsummaryrefslogtreecommitdiff
path: root/editors/kak-lsp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-30 10:14:03 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-30 10:14:03 +0000
commit8932f4e4907b11282d1b31aa9a8f103165f9b67b (patch)
tree5d338d2fceaf2bccfffa435b4a2a0d60e1e6913c /editors/kak-lsp
parent90484bdb5bf28ec47641629cca75be85ee21218a (diff)
downloadports-8932f4e4907b11282d1b31aa9a8f103165f9b67b.tar.gz
ports-8932f4e4907b11282d1b31aa9a8f103165f9b67b.zip
Notes
Diffstat (limited to 'editors/kak-lsp')
-rw-r--r--editors/kak-lsp/Makefile2
-rw-r--r--editors/kak-lsp/files/patch-kak-lsp.toml22
2 files changed, 22 insertions, 2 deletions
diff --git a/editors/kak-lsp/Makefile b/editors/kak-lsp/Makefile
index b9b3cdb2b81c..476bd45fe2ce 100644
--- a/editors/kak-lsp/Makefile
+++ b/editors/kak-lsp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kak-lsp
DISTVERSIONPREFIX= v
DISTVERSION= 6.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MAINTAINER= tobik@FreeBSD.org
diff --git a/editors/kak-lsp/files/patch-kak-lsp.toml b/editors/kak-lsp/files/patch-kak-lsp.toml
index 8ea34d082011..6fdf81bd962b 100644
--- a/editors/kak-lsp/files/patch-kak-lsp.toml
+++ b/editors/kak-lsp/files/patch-kak-lsp.toml
@@ -1,4 +1,4 @@
---- kak-lsp.toml.orig 2018-12-18 02:50:14 UTC
+--- kak-lsp.toml.orig 2019-01-14 07:08:28 UTC
+++ kak-lsp.toml
@@ -52,11 +52,16 @@ filetypes = ["python"]
roots = ["requirements.txt", "setup.py", ".git", ".hg"]
@@ -20,3 +20,23 @@
[language.haskell]
filetypes = ["haskell"]
+@@ -64,11 +69,17 @@ roots = ["Setup.hs", "stack.yaml", "*.cabal"]
+ command = "hie"
+ args = ["--lsp"]
+
++#[language.go]
++#filetypes = ["go"]
++#roots = ["Gopkg.toml", "go.mod", ".git", ".hg"]
++#command = "go-langserver"
++#args = ["-mode", "stdio", "-gocodecompletion"]
++
+ [language.go]
+ filetypes = ["go"]
+ roots = ["Gopkg.toml", "go.mod", ".git", ".hg"]
+-command = "go-langserver"
+-args = ["-mode", "stdio", "-gocodecompletion"]
++command = "bingo"
++args = ["-mode", "stdio"]
+
+ [language.bash]
+ filetypes = ["sh"]