aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-04 21:31:39 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-04 21:31:39 +0000
commit0ede3485145175b3b107fbbdf84438dcca3ecff8 (patch)
tree4eb4e8f3d2bcc5756b65c7520ede6360aa622265 /editors/lazarus
parentf32faf219316b6272432ec7f9da0d5540c6543b3 (diff)
downloadports-0ede3485145175b3b107fbbdf84438dcca3ecff8.tar.gz
ports-0ede3485145175b3b107fbbdf84438dcca3ecff8.zip
Notes
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile10
-rw-r--r--editors/lazarus/Makefile.common3
2 files changed, 10 insertions, 3 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 45a97cf1fcd5..67157abb6e43 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -104,21 +104,25 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -e 's|%%DATADIR%%|${DATADIR}|g' \
- -e 's|tools: lcl|tools:|g' -e '2744d' ${WRKSRC}/${MAKEFILE}
+ -e 's|tools: lcl|tools:|g' -e '2744d' -e '2746d' -e '2747d' ${WRKSRC}/${MAKEFILE}
pre-build:
@${LN} -s ${LOCALBASE}/share/${PORTNAME}/lcl/units ${WRKSRC}/lcl/units
+ @${LN} -s ${LOCALBASE}/share/${PORTNAME}/ideintf/units ${WRKSRC}/ideintf/units
+ @${LN} -s ${LOCALBASE}/share/${PORTNAME}/components/synedit/units ${WRKSRC}/components/synedit/units
+ @${LN} -s ${LOCALBASE}/share/${PORTNAME}/components/lazcontrols/lib ${WRKSRC}/components/lazcontrols/lib
do-build:
@cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${GMAKE} registration lazutils codetools ideintf basecomponents ide starter lazbuild LCL_PLATFORM=${LCL_PLATFORM}
+ ${SETENV} ${MAKE_ENV} ${GMAKE} registration lazutils codetools ide starter lazbuild LCL_PLATFORM=${LCL_PLATFORM}
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${GMAKE} tools LCL_PLATFORM=${LCL_PLATFORM}
post-build:
@cd ${WRKSRC} && \
${RM} -Rf COPYING* README* debian localize.bat test *.orig *.bak startlazarus.app \
- ide/Makefile*.orig ide/Makefile*.bak
+ ide/Makefile*.orig ide/Makefile*.bak lcl/units ideintf/units \
+ components/synedit/units components/lazcontrols/lib
pre-install:
@${ECHO} "#!/bin/sh" > ${WRKDIR}/lazarus-wrapper
diff --git a/editors/lazarus/Makefile.common b/editors/lazarus/Makefile.common
index 7ae52cbe2138..b2570232939b 100644
--- a/editors/lazarus/Makefile.common
+++ b/editors/lazarus/Makefile.common
@@ -57,12 +57,15 @@ pre-install:
.if ${PKGNAMESUFFIX} != "-lcl-units"
@${ECHO_CMD} "@dirrm %%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
.endif
+ @${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units/%%BUILDNAME%%" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units/%%BUILDNAME%%" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols" >> ${PLIST}