aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-28 11:46:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-28 11:46:13 +0000
commita5b327770b2d0c142e5d5c4f2cc1a3b1c4f24ccd (patch)
tree4e8950d8b2fd0739345dc71c46f37d0b3c54fdcb /editors/lazarus
parent458b41631f1f49586efe17a3dbb45f2d4e63e0c5 (diff)
downloadports-a5b327770b2d0c142e5d5c4f2cc1a3b1c4f24ccd.tar.gz
ports-a5b327770b2d0c142e5d5c4f2cc1a3b1c4f24ccd.zip
Notes
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile15
-rw-r--r--editors/lazarus/Makefile.common8
2 files changed, 13 insertions, 10 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 27ba1bf3affa..16ef012adaec 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lazarus
PORTVERSION= 1.2.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= editors devel
MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION} \
${MASTER_SITE_LOCAL:S|$|acm/freepascal/|}
@@ -63,7 +63,7 @@ RUN_DEPENDS+= fpcres:${PORTSDIR}/lang/fpc-utils \
USES+= gettext iconv
-MAN1= lazarus-ide.1 lazbuild.1 startlazarus.1
+MAN1S= lazarus-ide.1 lazbuild.1 startlazarus.1
SUB_FILES= pkg-message
SUB_LIST+= PORTSDIR="${PORTSDIR}"
@@ -136,6 +136,9 @@ pre-install:
. for FILE in bin/lazarus bin/lazbuild
@${ECHO_CMD} ${FILE} >> ${PLIST}
. endfor
+. for m in ${MAN1S}
+ @${ECHO_CMD} man/man1/${m}.gz >> ${PLIST}
+. endfor
.if !defined(NOPORTDOCS)
@${ECHO_CMD} "%%DATADIR%%/docs" >> ${PLIST}
@@ -177,23 +180,23 @@ do-install:
@cd ${WRKDIR}/docs && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DOCSDIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DOCSDIR}/{}" \;
- @${LN} -s ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DATADIR}/docs
+ @${LN} -s ${DOCSDIR} ${STAGEDIR}${DATADIR}/docs
.endif
.if !defined(NOPORTEXAMPLES)
@cd ${WRKDIR}/examples && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${EXAMPLESDIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${EXAMPLESDIR}/{}" \;
- @${LN} -s ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${DATADIR}/examples
+ @${LN} -s ${EXAMPLESDIR} ${STAGEDIR}${DATADIR}/examples
.endif
${INSTALL_SCRIPT} ${WRKSRC}/localize.sh ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/lazarus-wrapper ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/Makefile* ${WRKSRC}/fpmake* ${STAGEDIR}${DATADIR}
-.for FILE in ${MAN1}
+.for FILE in ${MAN1S}
${INSTALL_MAN} ${WRKDIR}/man1/${FILE} ${STAGEDIR}${MAN1PREFIX}/man/man1
.endfor
- ${LN} -s ${STAGEDIR}${DATADIR}/lazbuild ${STAGEDIR}${PREFIX}/bin/lazbuild
+ ${LN} -s ${DATADIR}/lazbuild ${STAGEDIR}${PREFIX}/bin/lazbuild
.else
.include "${MASTERDIR}/Makefile.common"
diff --git a/editors/lazarus/Makefile.common b/editors/lazarus/Makefile.common
index 5af195fbd030..9f1e749babde 100644
--- a/editors/lazarus/Makefile.common
+++ b/editors/lazarus/Makefile.common
@@ -49,13 +49,13 @@ pre-install:
@${RM} -f ${PLIST}
@cd ${WRKSRC}/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' >> ${PLIST}
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' -e 's|//|/|' >> ${PLIST}
@cd ${WRKDIR}/${PORTNAME}/components/ideintf/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/ideintf/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' >> ${PLIST}
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/ideintf/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' -e 's|//|/|' >> ${PLIST}
@cd ${WRKDIR}/${PORTNAME}/components/synedit/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/synedit/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' >> ${PLIST}
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/synedit/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' -e 's|//|/|' >> ${PLIST}
@cd ${WRKDIR}/${PORTNAME}/components/lazcontrols/lib/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%/${LCL_INTERFACE}/|' >> ${PLIST}
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%/${LCL_INTERFACE}/|' -e 's|//|/|' >> ${PLIST}
.if ${PKGNAMESUFFIX} != "-lcl-units"
@${ECHO_CMD} "@dirrm %%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}