aboutsummaryrefslogtreecommitdiff
path: root/editors/led/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-11 10:20:12 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-11 10:20:12 +0000
commita7bb3a9999a70c385c9a074269f113100eaac4fb (patch)
tree8b0127ed8997409a7fe3cee7a7a0e78766deac1a /editors/led/Makefile
parent509e917731930fe31d332a25a2d2fbfa28dc2cc4 (diff)
Notes
Diffstat (limited to 'editors/led/Makefile')
-rw-r--r--editors/led/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/editors/led/Makefile b/editors/led/Makefile
index a6a7ecd61685..e4a29d221434 100644
--- a/editors/led/Makefile
+++ b/editors/led/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= led
-PORTVERSION= 0.9.1
-PORTREVISION= 0
+PORTVERSION= 0.9.2
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}-editor
@@ -19,13 +18,19 @@ GNU_CONFIGURE= yes
MAN1= led.1
MANCOMPRESSED= yes
+.if !defined(NOPORTDOCS)
PKGMESSAGE= ${WRKDIR}/pkg-message
+.else
+PKGMESSAGE= /nonexistant
+.endif
post-install:
- ${MKDIR} ${PREFIX}/share/led
- ${INSTALL_DATA} ${WRKSRC}/sample.ledrc ${PREFIX}/share/led/dot.ledrc
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > \
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample.ledrc ${DOCSDIR}
+ @${SED} 's|%%DOCSDIR%%|${DOCSDIR}|g' ${PKGDIR}/pkg-message > \
${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>