aboutsummaryrefslogtreecommitdiff
path: root/editors/leo/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-23 14:05:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-23 14:05:54 +0000
commit485984607bfce9318033735bec98bca4c53f0f9c (patch)
treed7936b334319bc4510d923909c86c647bbd94613 /editors/leo/Makefile
parent553e1aab3207910343dd62c856d0ab7cba5dd2cd (diff)
downloadports-485984607bfce9318033735bec98bca4c53f0f9c.tar.gz
ports-485984607bfce9318033735bec98bca4c53f0f9c.zip
Notes
Diffstat (limited to 'editors/leo/Makefile')
-rw-r--r--editors/leo/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/leo/Makefile b/editors/leo/Makefile
index 7141d2130c8e..b99c16df8ebe 100644
--- a/editors/leo/Makefile
+++ b/editors/leo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= leo
-PORTVERSION= 5.1
-PORTREVISION= 2
+PORTVERSION= 5.2
CATEGORIES= editors python
MASTER_SITES= SF/${PORTNAME}/Leo/${PORTVERSION}-final
DISTNAME= Leo-${PORTVERSION}-final
@@ -30,11 +29,15 @@ USE_PYTHON= autoplist distutils
DESKTOP_ENTRIES="Leo" "Literate Editor with Outlines" \
"${PYTHONPREFIX_SITELIBDIR}/leo/Icons/leoapp32.png" "leo" "" ""
-OPTIONS_DEFINE= DOCS PYENCHANT
+OPTIONS_DEFINE= PYENCHANT
PYENCHANT_DESC= Spell checking support via PyEnchant
PYENCHANT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enchant>0:${PORTSDIR}/textproc/py-enchant
+post-patch:
+ @${LN} -sf leo/dist/leo-install.py ${WRKSRC}/leo-install.py
+ @${LN} -sf leo/dist/setup.py ${WRKSRC}/setup.py
+
post-install:
@${REINPLACE_CMD} -e 's,===,==,' ${STAGEDIR}${PREFIX}/bin/leo \
${STAGEDIR}${PREFIX}/bin/leoc