aboutsummaryrefslogtreecommitdiff
path: root/editors/lfhex/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-16 20:27:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-16 20:27:06 +0000
commit09c23c8eff999c2a0038c26923e9567b0ecc5cde (patch)
tree553be5c648c2a791790eeddfa8fa52185228b451 /editors/lfhex/Makefile
parent7e9c9e9a3b516119ad2093e3331a0b425825c5f0 (diff)
Notes
Diffstat (limited to 'editors/lfhex/Makefile')
-rw-r--r--editors/lfhex/Makefile33
1 files changed, 10 insertions, 23 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index a92b70fbe495..ff027bf65e57 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -7,34 +7,21 @@
#
PORTNAME= lfhex
-PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTVERSION= 0.3.4
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= arved
+MASTER_SITES= http://home.earthlink.net/~eyekode/data/
-MAINTAINER= ports@freebsd.org
-COMMENT= "Large file hex editor"
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Large file hex editor
-USE_GETOPT_LONG=yes
-USE_REINPLACE= yes
USE_QT_VER= 3
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
CONFIGURE_ARGS= --with-qt-moc=${MOC}
-USE_GMAKE= yes
-CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}"
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
- s,%%X11BASE%%,${X11BASE},g" ${WRKSRC}/src/Makefile.in
-post-configure:
- ${REINPLACE_CMD} -e "s,LFLAGS =,LFLAGS = ${PTHREAD_LIBS} ${LDFLAGS}," ${WRKSRC}/src/Makefile
+MAKE_ARGS= EXEC_PREFIX="${PREFIX}/bin" \
+ IFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
+ LFLAGS="${QTCFGLIBS} -lqt-mt ${PTHREAD_LIBS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>