aboutsummaryrefslogtreecommitdiff
path: root/editors/lfhex
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-23 00:06:05 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-23 00:06:05 +0000
commitc1965c8e63915d20c4ca717cc799b0bbf546b484 (patch)
tree91b3e0b7669badb1e0ec0a7c929b1b420b72c04f /editors/lfhex
parent8c349a2568f4842da57066872097114027b0de6d (diff)
downloadports-c1965c8e63915d20c4ca717cc799b0bbf546b484.tar.gz
ports-c1965c8e63915d20c4ca717cc799b0bbf546b484.zip
Notes
Diffstat (limited to 'editors/lfhex')
-rw-r--r--editors/lfhex/Makefile13
-rw-r--r--editors/lfhex/files/patch-hexEditor.cpp11
-rw-r--r--editors/lfhex/files/patch-hexGui.cpp10
-rw-r--r--editors/lfhex/files/patch-src::Makefile.in4
-rw-r--r--editors/lfhex/files/patch-src::reader.cpp17
-rw-r--r--editors/lfhex/pkg-comment1
6 files changed, 46 insertions, 10 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index 40c6d4176943..1261a742b0fa 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -8,21 +8,28 @@
PORTNAME= lfhex
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= editors
-MASTER_SITES= ftp://typedef.dnsalias.org/pub/lfhex/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= arved
-MAINTAINER= kde@freebsd.org
+MAINTAINER= ports@freebsd.org
+COMMENT= "Large file hex editor"
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
-USE_QT_VER= 2
+USE_QT_VER= 3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-qt-moc=${MOC}
USE_GMAKE= yes
+CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}"
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,%%X11BASE%%,${X11BASE},g" ${WRKSRC}/src/Makefile.in
+post-configure:
+ ${REINPLACE_CMD} -e "s,LFLAGS =,LFLAGS = ${PTHREAD_LIBS}," ${WRKSRC}/src/Makefile
+
.include <bsd.port.mk>
diff --git a/editors/lfhex/files/patch-hexEditor.cpp b/editors/lfhex/files/patch-hexEditor.cpp
new file mode 100644
index 000000000000..37e262386879
--- /dev/null
+++ b/editors/lfhex/files/patch-hexEditor.cpp
@@ -0,0 +1,11 @@
+--- src/hexEditor.cpp.orig Sun Feb 23 00:37:11 2003
++++ src/hexEditor.cpp Sun Feb 23 00:38:31 2003
+@@ -22,6 +22,8 @@
+ #include <qfiledialog.h>
+ #include <qapplication.h>
+ #include <qprogressdialog.h>
++#include <qpainter.h>
++#include <qpixmap.h>
+
+ #include "config.h"
+ #include "hexEditor.hpp"
diff --git a/editors/lfhex/files/patch-hexGui.cpp b/editors/lfhex/files/patch-hexGui.cpp
new file mode 100644
index 000000000000..274e649e95ca
--- /dev/null
+++ b/editors/lfhex/files/patch-hexGui.cpp
@@ -0,0 +1,10 @@
+--- src/hexGui.cpp.orig Sat Jul 7 04:16:01 2001
++++ src/hexGui.cpp Sun Feb 23 00:40:32 2003
+@@ -24,6 +24,7 @@
+ #include <qscrollbar.h>
+ #include <qstring.h>
+ #include <qmessagebox.h>
++#include <qlineedit.h>
+ //#include <qprogressbar.h>
+ //#include <qtoolbar.h>
+ //#include <qtoolbutton.h>
diff --git a/editors/lfhex/files/patch-src::Makefile.in b/editors/lfhex/files/patch-src::Makefile.in
index 67e7a37f5a0c..d4a29f691d27 100644
--- a/editors/lfhex/files/patch-src::Makefile.in
+++ b/editors/lfhex/files/patch-src::Makefile.in
@@ -5,11 +5,11 @@
CXXFLAGS = @CXXFLAGS@
-INCLUDE_DIRS = $(QTDIR)/include
-+INCLUDE_DIRS = %%X11BASE%%/include/qt2 %%LOCALBASE%%/include
++INCLUDE_DIRS = %%X11BASE%%/include %%LOCALBASE%%/include
IFLAGS = $(addprefix -I,$(INCLUDE_DIRS))
-LIBRARIES = qt Xext X11 m
-LIB_DIRS = $(QTDIR)/lib /usr/X11R6/lib
-+LIBRARIES = qt2 Xext X11 m gnugetopt
++LIBRARIES = qt-mt Xext X11 m gnugetopt
+LIB_DIRS = $(QTDIR)/lib /usr/X11R6/lib %%LOCALBASE%%/lib
LFLAGS = $(addprefix -L,$(LIB_DIRS)) $(addprefix -l,$(LIBRARIES))
diff --git a/editors/lfhex/files/patch-src::reader.cpp b/editors/lfhex/files/patch-src::reader.cpp
index c33bcdb52238..427ada379c0a 100644
--- a/editors/lfhex/files/patch-src::reader.cpp
+++ b/editors/lfhex/files/patch-src::reader.cpp
@@ -1,7 +1,16 @@
---- src/reader.cpp.orig Fri Jul 6 10:40:46 2001
-+++ src/reader.cpp Fri Jul 6 10:40:58 2001
-@@ -283,7 +283,7 @@
- #ifdef __GNUC__
+--- src/reader.cpp.orig Sat Jul 7 04:16:01 2001
++++ src/reader.cpp Sun Feb 23 00:46:53 2003
+@@ -227,7 +227,7 @@
+ // free the page which is the furthest away from the page we are loading
+
+ // this could be trouble if off_t is unsigned!
+- if( abs(_firstPage - pageIdx) > abs(_lastPage - pageIdx) )
++ if( abs((long int)(_firstPage - pageIdx)) > abs((long int)(_lastPage - pageIdx)) )
+ while(!freePage(_firstPage++));
+ else
+ while(!freePage(_lastPage--));
+@@ -285,7 +285,7 @@
+ #ifdef LFHEX_IOS_BASE_FMTFLAGS
ostream& operator<< (ostream&out, const ReadBuffer& buff)
{
- ios_base::fmtflags old_flags = out.flags();
diff --git a/editors/lfhex/pkg-comment b/editors/lfhex/pkg-comment
deleted file mode 100644
index 74828a5794f1..000000000000
--- a/editors/lfhex/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Large file hex editor