aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-09-09 14:23:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-09-09 14:23:20 +0000
commit64dfd9253a0bbff9db91f730056757303f49d614 (patch)
treec4e726a43515689e4a9c4fa01cb8af944f9172d2 /editors/libreoffice
parent99f4de156e1c96cbaedb30bc7a1c149de2d5fff1 (diff)
downloadports-64dfd9253a0bbff9db91f730056757303f49d614.tar.gz
ports-64dfd9253a0bbff9db91f730056757303f49d614.zip
Notes
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile35
-rw-r--r--editors/libreoffice/files/patch-bin__distro-install-desktop-integration40
2 files changed, 52 insertions, 23 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 021cfff8be50..bb1b1d9ab4b2 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libreoffice
PORTVERSION= 3.4.3
+PORTREVISION= 1
LOVERSION= ${PORTVERSION}.2
CATEGORIES= editors
MASTER_SITES= http://ftp.osuosl.org/pub/tdf/libreoffice/src/${PORTVERSION}/ \
@@ -414,33 +415,29 @@ post-install:
@${RM} -f ${PLISTF} ${PLISTD}
@for dir in ${EMPTYDIRS}; do ${TOUCH} ${LODESTDIR}/${PREFIX}/lib/$$dir/.keep; done
- @cd ${LODESTDIR}/${PREFIX}/lib && ${FIND} -H -s * -type f -o -type l | \
- ${SED} -e 's|^|lib/|' >> ${PLISTF}
- @cd ${LODESTDIR}/${PREFIX}/lib && ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm lib/|' >> ${PLISTD}
-
-.for subdir in share/application-registry share/applications share/icons share/mime share/mime-info share/mimelnk
- @cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -H -s * -type f -o -type l | \
- ${SED} -e 's|^|${subdir}/|' >> ${PLISTF}
- @cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${subdir}/|' >> ${PLISTD}
- @${ECHO_CMD} "@unexec ${RMDIR} %D/${subdir} 2>/dev/null || ${TRUE}" >> ${PLISTD}
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s lib \( -type f -o -type l \) -print >> ${PLISTF}
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -d lib/libreoffice -type d -exec ${ECHO_CMD} "@dirrm {}" \; >> ${PLISTD}
+
+.for subdir in application-registry applications icons mime mime-info mimelnk
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s share/${subdir} \( -type f -o -type l \) -print >> ${PLISTF}
+ @cd ${LODESTDIR}/${PREFIX}/ && ${FIND} -d share/${subdir} -type d \
+ -exec ${ECHO_CMD} "@exec ${RMDIR} %D/{} 2>/dev/null || ${TRUE}" \; >> ${PLISTD}
.endfor
- @cd ${LODESTDIR}/${PREFIX}/bin && ${FIND} -H -s * -type f -o -type l | \
- ${SED} -e 's|^|bin/|' >> ${PLISTF}
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s bin \( -type f -o -type l \) -print >> ${PLISTF}
+
+#Fix .desktop files
+ @${FIND} ${LODESTDIR}/${PREFIX} -name *.desktop -type f -exec ${SED} -i"" -e 's|office34|office|g; s|office3.4|office|g' {} \;
-.if defined(WITHOUT_GTK) && defined(WITHOUT_GNOME)
+.if defined(WITH_GTK) || defined(WITH_GNOME)
@${ECHO_CMD} "@exec ${LOCALBASE}/bin/update-desktop-database > /dev/null || ${TRUE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${LOCALBASE}/bin/update-desktop-database > /dev/null || ${TRUE}" >> ${TMPPLIST}
.endif
.if defined(WITH_SDK)
.for subdir in include share/idl share/libreoffice share/doc
- @cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -H -s * -type f -o -type l | \
- ${SED} -e 's|^|${subdir}/|' >> ${PLISTF}
- @cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${subdir}/|' >> ${PLISTD}
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s ${subdir} \( -type f -o -type l \) -print >> ${PLISTF}
+ @cd ${LODESTDIR}/${PREFIX} && ${FIND} -d ${subdir} -type d -exec echo "@dirrm {}" \; >> ${PLISTD}
.endfor
.endif
@@ -454,7 +451,7 @@ post-install:
.endif
@cd ${LODESTDIR}/${PREFIX} ; ${PAX} -rw . ${PREFIX}
-.if defined(WITHOUT_GTK) && defined(WITHOUT_GNOME)
+.if defined(WITH_GTK) || defined(WITH_GNOME)
@${LOCALBASE}/bin/update-desktop-database 2>/dev/null || ${TRUE}
.endif
diff --git a/editors/libreoffice/files/patch-bin__distro-install-desktop-integration b/editors/libreoffice/files/patch-bin__distro-install-desktop-integration
index 2c9e07420506..362c239844a4 100644
--- a/editors/libreoffice/files/patch-bin__distro-install-desktop-integration
+++ b/editors/libreoffice/files/patch-bin__distro-install-desktop-integration
@@ -1,6 +1,6 @@
--- bin/distro-install-desktop-integration.orig 2011-08-15 19:46:21.000000000 +0200
-+++ bin/distro-install-desktop-integration 2011-09-05 18:37:11.798849176 +0200
-@@ -74,12 +74,12 @@
++++ bin/distro-install-desktop-integration 2011-09-09 16:00:15.645182583 +0200
+@@ -74,21 +74,21 @@
test -n "$oowrapper_name" && create_man_link "$oowrapper_name" "$used_man_page" "$file_list"
# add desktop file to the right file list
@@ -16,6 +16,20 @@
cp -a sysui/desktop/share/create_tree.sh "$sysui_temp"
builddir=`pwd`
cd $sysui_temp
+ # we want non-versioned stuff in the distro packages
+-sed -i \
+- -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION_NODOT/\1/" \
+- -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION/\1/" \
+- -e "s/\($PRODUCTNAME\) $PRODUCTVERSION/\1/" \
+- *
++#sed -i \
++# -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION_NODOT/\1/" \
++# -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION/\1/" \
++# -e "s/\($PRODUCTNAME\) $PRODUCTVERSION/\1/" \
++# *
+ # call in subshell to do not malfrom PRODUCTVERSION, ...
+ (
+ export OFFICE_PREFIX=$LIBDIR
@@ -96,8 +96,8 @@
export ICON_PREFIX=$INSTALLDIRNAME
export ICON_SOURCE_DIR=$builddir/sysui/desktop/icons
@@ -27,7 +41,7 @@
export GNOME_MIME_THEME=hicolor
/bin/bash ./create_tree.sh
)
-@@ -106,8 +106,8 @@
+@@ -106,32 +106,32 @@
# we do not want some stuff from the plain packages
rm -f $DESTDIR/$PREFIXDIR/bin/$INSTALLDIRNAME*
@@ -38,7 +52,25 @@
if test -d $DESTDIR/opt ; then
rm -f $DESTDIR/opt/$INSTALLDIRNAME
rmdir --ignore-fail-on-non-empty $DESTDIR/opt
-@@ -126,12 +126,12 @@
+ fi
+
+ # we want non-versioned desktop files
+-cd $DESTDIR/$INSTALLDIR/share/xdg
++#cd $DESTDIR/$INSTALLDIR/share/xdg
+ # we want non-versioned stuff in the distro packages
+-sed -i \
+- -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION_NODOT/\1/" \
+- -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION/\1/" \
+- -e "s/\($PRODUCTNAME\) $PRODUCTVERSION/\1/" \
+- *.desktop
+-cd -
++#sed -i \
++# -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION_NODOT/\1/" \
++# -e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION/\1/" \
++# -e "s/\($PRODUCTNAME\) $PRODUCTVERSION/\1/" \
++# *.desktop
++#cd -
+
# put the stuff installed by create_tree.sh into the right file lists
# desktop files will be added by the corresponding add_wrapper command
if test -f $DESTDIR/gid_Module_Root_Brand ; then