aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-09-23 21:06:12 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-09-23 21:06:12 +0000
commit75883644e15e5a6ba265912477d6a33afef8a834 (patch)
tree80ccc66b53ed281eb76c78baf1e6705e000c3775 /editors/libreoffice
parent4a6d4da205bbbe14c968f0ec18d9efecbd2a5b74 (diff)
downloadports-75883644e15e5a6ba265912477d6a33afef8a834.tar.gz
ports-75883644e15e5a6ba265912477d6a33afef8a834.zip
Notes
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile122
-rw-r--r--editors/libreoffice/Makefile.common71
-rw-r--r--editors/libreoffice/Makefile.i18n45
-rw-r--r--editors/libreoffice/distinfo20
-rw-r--r--editors/libreoffice/files/patch-desktop_scripts_soffice.sh11
-rw-r--r--editors/libreoffice/files/patch-vcl_inc_opengl_x11_gdiimpl.hxx11
6 files changed, 108 insertions, 172 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index ce171a98b3ac..00c526588d02 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -2,23 +2,33 @@
.include "${.CURDIR}/Makefile.common"
-PORTREVISION= 1
+PORTREVISION= 0
+MASTER_SITES= http://download.documentfoundation.org/libreoffice/src/${PORTVERSION}/ \
+ http://dev-www.libreoffice.org/src/:src \
+ http://dev-www.libreoffice.org/extern/:ext
+DISTFILES= ${PORTNAME}-${LOVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-help-${LOVERSION}${EXTRACT_SUFX}
+DIST_SUBDIR= libreoffice
+EXTRACT_ONLY:= ${DISTFILES}
COMMENT= Full integrated office productivity suite
BUILD_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
zip:${PORTSDIR}/archivers/zip \
+ ${LOCALBASE}/include/sqlext.h:${PORTSDIR}/databases/unixODBC \
cppunit-config:${PORTSDIR}/devel/cppunit \
dmake:${PORTSDIR}/devel/dmake \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
mdds>=0.9.0:${PORTSDIR}/devel/mdds \
gpatch:${PORTSDIR}/devel/patch \
ucpp:${PORTSDIR}/devel/ucpp \
+ ${LOCALBASE}/include/sane/sane.h:${PORTSDIR}/graphics/sane-backends \
vigra-config:${PORTSDIR}/graphics/vigra \
${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm \
bash:${PORTSDIR}/shells/bash \
gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS= libapr-1.so:${PORTSDIR}/devel/apr1 \
+LIB_DEPENDS= libfbembed.so:${PORTSDIR}/databases/firebird25-client \
+ libapr-1.so:${PORTSDIR}/devel/apr1 \
libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libicutu.so:${PORTSDIR}/devel/icu \
liblangtag.so:${PORTSDIR}/devel/liblangtag \
@@ -35,6 +45,7 @@ LIB_DEPENDS= libapr-1.so:${PORTSDIR}/devel/apr1 \
libGeneratedSaxParser.so:${PORTSDIR}/graphics/opencollada \
libpng.so:${PORTSDIR}/graphics/png \
libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libCoinMP.so:${PORTSDIR}/math/coinmp \
liblpsolve55.so:${PORTSDIR}/math/lp_solve \
libcmis-0.5.so:${PORTSDIR}/net/libcmis \
libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
@@ -66,17 +77,15 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/Caladea/Caladea-Bold.ttf:${PORTSDIR}/x11-f
${LOCALBASE}/share/fonts/Liberation/LiberationMono-Bold.ttf:${PORTSDIR}/x11-fonts/liberation-fonts-ttf \
${LOCALBASE}/share/fonts/LinLibertineG/LinLibertine_DR_G.ttf:${PORTSDIR}/x11-fonts/linuxlibertine-g
-DISTFILES+= ${PORTNAME}-${LOVERSION}${EXTRACT_SUFX}
-DISTFILES+= ${PORTNAME}-help-${LOVERSION}${EXTRACT_SUFX}
-
-EXTRACT_ONLY:= ${DISTFILES}
-
DISTFILES+= 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz:src \
4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.bz2:src
+.if defined(PRERELEASE)
+MASTER_SITES+= http://dev-builds.libreoffice.org/pre-releases/src/
+.endif
+
CONFLICTS_INSTALL= libreoffice4-4.*
-DIST_SUBDIR= libreoffice
INSTALL_TARGET= distro-pack-install
WRKSRC= ${WRKDIR}/${PORTNAME}-${LOVERSION}
@@ -126,39 +135,43 @@ GTK3_USE= GNOME=gtk30,${GTK_USE_GNOME}
GTK3_USES= ${GTK_USES}
GTK3_VARS= ${GTK_VARS}
-JAVA_BUILD= yes
JAVA_BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant \
- ${JAVAJARDIR}/junit.jar:${PORTSDIR}/java/junit
+ ${JAVAJARDIR}/commons-codec.jar:${PORTSDIR}/java/jakarta-commons-codec \
+ ${JAVAJARDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
+ ${JAVAJARDIR}/commons-lang.jar:${PORTSDIR}/java/jakarta-commons-lang \
+ ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVAJARDIR}/junit.jar:${PORTSDIR}/java/junit \
+ ${JAVAJARDIR}/bsh.jar:${PORTSDIR}/lang/bsh
JAVA_CATEGORIES= java
-JAVA_CONFIGURE_ENABLE= ext-wiki-publisher report-builder
JAVA_CONFIGURE_ON= --with-ant-home=${LOCALBASE}/share/java/apache-ant \
+ --with-beanshell-jar=${JAVAJARDIR}/bsh.jar \
+ --with-commons-codec-jar=${JAVAJARDIR}/commons-codec.jar \
+ --with-commons-httpclient-jar=${JAVAJARDIR}/commons-httpclient.jar \
+ --with-commons-lang-jar=${JAVAJARDIR}/commons-lang.jar \
+ --with-commons-logging-jar=${JAVAJARDIR}/commons-logging.jar \
--with-jdk-home="${JAVA_HOME}" \
--with-junit=${JAVAJARDIR}/junit.jar \
- --with-hamcrest=${JAVAJARDIR}/hamcrest.jar
+ --with-hamcrest=${JAVAJARDIR}/hamcrest.jar \
+ --without-system-jfreereport
JAVA_CONFIGURE_WITH= java
# XXX jni.h from GNU classpath causes ABI conflicts.
JAVA_CONFLICTS_BUILD= classpath-[0-9]*
-JAVA_DISTFILES= 048751f3271906db5126ab76870444c4-commons-codec-1.9-src.zip:src \
- 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip:src \
- 2c9b0f83ed5890af02c0df1c1776f39b-commons-httpclient-3.1-src.tar.gz:src \
+JAVA_DISTFILES= 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip:src \
3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip:src \
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip:src \
39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip:src \
3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip:src \
798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip:src \
- 8ab049135b2d15313da5d9f0656894a1-commons-lang3-3.3.1-src.tar.gz:src \
8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip:src \
97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip:src \
- a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip:src \
ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip:src \
ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip:src \
- commons-logging-1.2-src.tar.gz:src \
d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip:src \
db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip:src \
- ec1941a74d3ef513c4ce57a9092b74e1-bsh-2.0b5-src.zip:src \
eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip:src \
f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip:src
JAVA_USE= JAVA=yes
+JAVA_VARS= JAVA_BUILD=yes
KDE4_CONFIGURE_ENABLE= kde4
KDE4_CONFIGURE_ENV= KDE4DIR="${KDE4_PREFIX}" \
@@ -190,31 +203,29 @@ WEBDAV_CONFIGURE_ENABLE= neon
WEBDAV_LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon
ACLOCAL_ARGS= -I "${WRKSRC}/m4"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -isystem ${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
COLLADA_MODS= COLLADABaseUtils COLLADAFramework \
COLLADASaxFrameworkLoader GeneratedSaxParser
-COLLADA_CFLAGS= ${COLLADA_MODS:S|^|-I${LOCALBASE}/include/opencollada/|}
+COLLADA_CFLAGS= ${COLLADA_MODS:S|^|-isystem ${LOCALBASE}/include/opencollada/|}
COLLADA_LIBS= -L${LOCALBASE}/lib/opencollada \
${COLLADA_MODS:S|^COLLADA|OpenCOLLADA|:S|^|-l|}
-CONFIGURE_ARGS= --disable-coinmp \
- --disable-dependency-tracking \
+CONFIGURE_ARGS= --disable-dependency-tracking \
--disable-epm \
--disable-fetch-external \
- --disable-firebird-sdbc \
--disable-gnome-vfs \
--disable-kde \
--disable-kdeab \
- --disable-online-update \
--disable-mergelibs \
+ --disable-online-update \
--disable-packagekit \
--enable-cairo-canvas \
--enable-graphite \
+ --enable-python=system \
--enable-release-build \
--exec-prefix=${PREFIX} \
- --enable-python=system \
--with-alloc=system \
--with-build-version="FreeBSD ports ${PKGVERSION}" \
--with-external-dict-dir=${LOCALBASE}/share/hunspell \
@@ -224,68 +235,21 @@ CONFIGURE_ARGS= --disable-coinmp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--with-os-version=${OSVERSION} \
--with-parallelism=${MAKE_JOBS_NUMBER} \
- --with-system-altlinuxhyph \
- --with-system-apr \
- --with-system-boost \
- --with-system-cairo \
- --with-system-clucene \
- --with-system-cppunit \
--with-system-curl \
--with-system-dicts \
- --with-system-expat \
- --with-system-glew \
- --with-system-glm \
- --with-system-graphite \
- --with-system-harfbuzz \
- --with-system-hunspell \
- --with-system-icu \
- --with-system-jpeg \
- --with-system-lcms2 \
- --with-system-libabw \
- --with-system-libcdr \
- --with-system-libcmis \
- --with-system-libebook \
- --with-system-libetonyek \
- --with-system-libexttextcat \
- --with-system-libfreehand \
- --with-system-libgltf \
- --with-system-liblangtag \
- --with-system-libmspub \
- --with-system-libmwaw \
- --with-system-libodfgen \
- --with-system-libpagemaker \
- --with-system-libpng \
- --with-system-librevenge \
- --with-system-libvisio \
- --with-system-libwpd \
- --with-system-libwpg \
- --with-system-libwps \
+ --with-system-libs \
--with-system-libxml \
- --with-system-lpsolve \
- --with-system-mdds \
- --with-system-mesa-headers \
- --with-system-mythes \
- --with-system-neon \
- --with-system-nss \
--with-system-opencollada \
- --with-system-openldap \
- --with-system-openssl \
- --with-system-orcus \
- --with-system-poppler \
- --with-system-postgresql \
- --with-system-redland \
- --with-system-serf \
--with-system-ucpp \
- --with-system-vigra \
--with-system-zlib \
--with-vendor="FreeBSD ports" \
--without-fonts \
--without-myspell-dicts \
--without-system-npapi-headers
-#XXX add: --with-system-libeot or --with-system-libatomic_ops
-
CONFIGURE_ENV= DMAKE=${LOCALBASE}/bin/dmake \
+ FIREBIRD_CFLAGS="-isystem ${LOCALBASE}/include" \
+ FIREBIRD_LIBS="-L${LOCALBASE}/lib -lfbembed" \
GNUTAR="${TAR}" \
GPERF=${LOCALBASE}/bin/gperf \
OPENCOLLADA_CFLAGS="${COLLADA_CFLAGS}" \
@@ -315,11 +279,9 @@ CONFIGURE_ENV+= FLEX=${LOCALBASE}/bin/flex
.endif # FreeBSD
.if ${COMPILER_TYPE} == "clang"
-CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unknown-pragmas \
- -Wno-unused-function -Wno-unused-parameter
+CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unused-parameter
.if${COMPILER_VERSION} >= 36
-CXXFLAGS_WARN+= -Wno-inconsistent-missing-override \
- -Wno-unused-local-typedefs
+CXXFLAGS_WARN+= -Wno-unused-local-typedefs
.endif
.else
CXXFLAGS_WARN= -Wshadow -Woverloaded-virtual
diff --git a/editors/libreoffice/Makefile.common b/editors/libreoffice/Makefile.common
index 235eb8f29ee1..96a8cc81e195 100644
--- a/editors/libreoffice/Makefile.common
+++ b/editors/libreoffice/Makefile.common
@@ -1,72 +1,13 @@
# $FreeBSD$
PORTNAME= libreoffice
-PORTVERSION= 5.0.1
-RCVER= 2
-#PRERELEASE= yes
-LOVERSION= ${PORTVERSION}.${RCVER}
-CATEGORIES?= editors
-MAINTAINER?= office@FreeBSD.org
+PORTVERSION= 5.0.2
+CATEGORIES+= editors
+
+MAINTAINER= office@FreeBSD.org
LICENSE= LGPL3 MPL
LICENSE_COMB= dual
-.if defined(PRERELEASE)
-MASTER_SITES?= http://dev-builds.libreoffice.org/pre-releases/${MASTER_SITE_SUBDIR}/
-.else
-MASTER_SITES?= http://download.documentfoundation.org/libreoffice/${MASTER_SITE_SUBDIR}/
-.endif
-
-ONLY_FOR_ARCHS= i386 amd64
-
-.if defined(LO_I18N)
-NO_ARCH= yes
-NO_BUILD= yes
-
-RUN_DEPENDS= libreoffice:${PORTSDIR}/editors/libreoffice
-
-.if defined(PRERELEASE)
-MASTER_SITE_SUBDIR= deb/x86
-LO_I18N_FILE= LibreOffice_${LOVERSION}_Linux_x86_deb
-.else
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/deb/x86
-LO_I18N_FILE= LibreOffice_${PORTVERSION}_Linux_x86_deb
-.endif
-
-DIST_SUBDIR?= libreoffice/i18n
-
-PKGNAMEPREFIX= ${LO_I18N}-
-
-DISTFILES= ${LO_I18N_FILE}_langpack_${LO_I18N:S/_/-/}${EXTRACT_SUFX}
-.if defined(LO_HAS_HELPPACK)
-DISTFILES+= ${LO_I18N_FILE}_helppack_${LO_I18N:S/_/-/}${EXTRACT_SUFX}
-.endif
-COMMENT?= ${LO_I18N} language pack for ${PORTNAME}
-
-EXTRACT_AFTER_ARGS= --exclude '${PORTNAME}*-dict-*.deb' \
- --strip-components 1
-
-post-extract:
- @${MKDIR} ${WRKSRC}
- for deb in ${WRKDIR}/DEBS/*.deb ; do \
- ${TAR} xfO $${deb} data.tar.gz | ${TAR} -C ${WRKSRC} -xf - ; \
- done
-
-do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
- cd ${WRKSRC}/opt/${PORTNAME}${PORTVERSION:R} ; \
- ${PAX} -rw . ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
-
-post-install:
- @cd ${WRKSRC}/opt/${PORTNAME}${PORTVERSION:R} && \
- ${FIND} -s * -not -type d \
- -exec ${ECHO_CMD} "lib/${PORTNAME}/{} " \; >> ${TMPPLIST}
-.else
-MASTER_SITES+= http://dev-www.libreoffice.org/src/:src \
- http://dev-www.libreoffice.org/extern/:ext
-.if defined(PRERELEASE)
-MASTER_SITE_SUBDIR= src
-.else
-MASTER_SITE_SUBDIR= src/${PORTVERSION}
-.endif
-.endif
+LOVERSION= ${PORTVERSION}.${RCVER}
+RCVER= 2
diff --git a/editors/libreoffice/Makefile.i18n b/editors/libreoffice/Makefile.i18n
new file mode 100644
index 000000000000..04383f301b16
--- /dev/null
+++ b/editors/libreoffice/Makefile.i18n
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+.include "${.CURDIR}/../../editors/libreoffice/Makefile.common"
+
+MASTER_SITES= http://download.documentfoundation.org/libreoffice/${MASTER_SITE_SUBDIR}/
+.if defined(PRERELEASE)
+MASTER_SITES+= http://dev-builds.libreoffice.org/pre-releases/deb/x86/
+MASTER_SITE_SUBDIR= testing/${PORTVERSION}/deb/x86
+LO_I18N_FILE= LibreOffice_${LOVERSION}_Linux_x86_deb
+.else
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/deb/x86
+LO_I18N_FILE= LibreOffice_${PORTVERSION}_Linux_x86_deb
+.endif
+PKGNAMEPREFIX= ${LO_I18N}-
+DISTFILES= ${LO_I18N_FILE}_langpack_${LO_I18N:S/_/-/}${EXTRACT_SUFX}
+.if defined(LO_HAS_HELPPACK)
+DISTFILES+= ${LO_I18N_FILE}_helppack_${LO_I18N:S/_/-/}${EXTRACT_SUFX}
+.endif
+DIST_SUBDIR= libreoffice/i18n
+
+COMMENT?= ${LO_I18N} language pack for ${PORTNAME}
+
+RUN_DEPENDS?= libreoffice:${PORTSDIR}/editors/libreoffice
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+EXTRACT_AFTER_ARGS= --exclude '${PORTNAME}*-dict-*.deb' \
+ --strip-components 1
+
+post-extract:
+ @${MKDIR} ${WRKSRC}
+ for deb in ${WRKDIR}/DEBS/*.deb ; do \
+ ${TAR} xfO $${deb} data.tar.gz | ${TAR} -C ${WRKSRC} -xf - ; \
+ done
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
+ cd ${WRKSRC}/opt/${PORTNAME}${PORTVERSION:R} ; \
+ ${PAX} -rw . ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
+
+post-install:
+ @cd ${WRKSRC}/opt/${PORTNAME}${PORTVERSION:R} && \
+ ${FIND} -s * -not -type d \
+ -exec ${ECHO_CMD} "lib/${PORTNAME}/{} " \; >> ${TMPPLIST}
diff --git a/editors/libreoffice/distinfo b/editors/libreoffice/distinfo
index e2098fa75e48..d54acfecab23 100644
--- a/editors/libreoffice/distinfo
+++ b/editors/libreoffice/distinfo
@@ -1,17 +1,13 @@
-SHA256 (libreoffice/libreoffice-5.0.1.2.tar.xz) = 0751b9caebeb54e2c6702a58aae66a29ac59414088ccd4e7d84625d02d0fd21a
-SIZE (libreoffice/libreoffice-5.0.1.2.tar.xz) = 167364360
-SHA256 (libreoffice/libreoffice-help-5.0.1.2.tar.xz) = c71db94564307f4bcea4d556a37d5ea946c87007fbf03fc7801fbe7bc197e947
-SIZE (libreoffice/libreoffice-help-5.0.1.2.tar.xz) = 1884112
-SHA256 (libreoffice/048751f3271906db5126ab76870444c4-commons-codec-1.9-src.zip) = a751a036a3488e2519bc105dcf80df9c004ab1a982d1dd96bbfbf07802df8831
-SIZE (libreoffice/048751f3271906db5126ab76870444c4-commons-codec-1.9-src.zip) = 525299
+SHA256 (libreoffice/libreoffice-5.0.2.2.tar.xz) = 01f0680709432039762fa608bcb1240786d2b6549099a96095aab92dcebbc176
+SIZE (libreoffice/libreoffice-5.0.2.2.tar.xz) = 166869100
+SHA256 (libreoffice/libreoffice-help-5.0.2.2.tar.xz) = 4342a5593ba8a33b1d63549f256a4127a0b51cc1a53faffdc2708f04fef5f094
+SIZE (libreoffice/libreoffice-help-5.0.2.2.tar.xz) = 1882964
SHA256 (libreoffice/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip) = d30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370
SIZE (libreoffice/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip) = 3519470
SHA256 (libreoffice/185d60944ea767075d27247c3162b3bc-unowinreg.dll) = eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6
SIZE (libreoffice/185d60944ea767075d27247c3162b3bc-unowinreg.dll) = 12288
SHA256 (libreoffice/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz) = 390a5085651828b8fe12aa978b200f59b9155eedbb91a4be89bf7cf39eefdd4a
SIZE (libreoffice/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz) = 1652670
-SHA256 (libreoffice/2c9b0f83ed5890af02c0df1c1776f39b-commons-httpclient-3.1-src.tar.gz) = f9a496d3418b0e15894fb351652cd4fa5ca434ebfc3ce3bb8da40defd8b097f2
-SIZE (libreoffice/2c9b0f83ed5890af02c0df1c1776f39b-commons-httpclient-3.1-src.tar.gz) = 1882664
SHA256 (libreoffice/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip) = 5826d1551bf599b85742545f6e01a0079b93c1b2c8434bf409eddb3a29e4726b
SIZE (libreoffice/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip) = 1180582
SHA256 (libreoffice/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip) = 64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1
@@ -24,26 +20,18 @@ SHA256 (libreoffice/4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d977
SIZE (libreoffice/4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.bz2) = 555291
SHA256 (libreoffice/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip) = 1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753
SIZE (libreoffice/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip) = 1521926
-SHA256 (libreoffice/8ab049135b2d15313da5d9f0656894a1-commons-lang3-3.3.1-src.tar.gz) = 97ca24c80d416f651dcd3513611d5ea855be21a994e3d48563c837a599618908
-SIZE (libreoffice/8ab049135b2d15313da5d9f0656894a1-commons-lang3-3.3.1-src.tar.gz) = 739050
SHA256 (libreoffice/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip) = abe2c57ac12ba45d83563b02e240fa95d973376de2f720aab8fe11f2e621c095
SIZE (libreoffice/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip) = 762419
SHA256 (libreoffice/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip) = 3d853b19b1d94a6efa69e7af90f7f2b09ecf302913bee3da796c15ecfebcfac8
SIZE (libreoffice/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip) = 2938721
-SHA256 (libreoffice/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870
-SIZE (libreoffice/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 23150
SHA256 (libreoffice/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip) = 7d2797fe9f79a77009721e3f14fa4a1dec17a6d706bdc93f85f1f01d124fab66
SIZE (libreoffice/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip) = 2929311
SHA256 (libreoffice/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip) = 233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd
SIZE (libreoffice/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip) = 743031
-SHA256 (libreoffice/commons-logging-1.2-src.tar.gz) = 49665da5a60d033e6dff40fe0a7f9173e886ae859ce6096c1afe34c48b677c81
-SIZE (libreoffice/commons-logging-1.2-src.tar.gz) = 188536
SHA256 (libreoffice/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip) = 1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133
SIZE (libreoffice/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip) = 207563
SHA256 (libreoffice/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip) = e1fb87f3f7b980d33414473279615c4644027e013012d156efa538bc2b031772
SIZE (libreoffice/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip) = 1396007
-SHA256 (libreoffice/ec1941a74d3ef513c4ce57a9092b74e1-bsh-2.0b5-src.zip) = 90993aa17a786996653fc5fcf148e879fb3689b8678f9ba99b376a5a13dff513
-SIZE (libreoffice/ec1941a74d3ef513c4ce57a9092b74e1-bsh-2.0b5-src.zip) = 1982036
SHA256 (libreoffice/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip) = 75c80359c9ce343c20aab8a36a45cb3b9ee7c61cf92c13ae45399d854423a9ba
SIZE (libreoffice/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip) = 427800
SHA256 (libreoffice/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip) = 05640a1f6805b2b2d7e2cb9c50db9a5cb084e3c52ab1a71ce015239b4a1d4343
diff --git a/editors/libreoffice/files/patch-desktop_scripts_soffice.sh b/editors/libreoffice/files/patch-desktop_scripts_soffice.sh
new file mode 100644
index 000000000000..21dcb49b0be1
--- /dev/null
+++ b/editors/libreoffice/files/patch-desktop_scripts_soffice.sh
@@ -0,0 +1,11 @@
+--- desktop/scripts/soffice.sh.orig 2015-09-17 13:33:12 UTC
++++ desktop/scripts/soffice.sh
+@@ -128,7 +128,7 @@ if echo "$checks" | grep -q "cc" ; then
+ fi
+
+ case "`uname -s`" in
+-NetBSD|OpenBSD|FreeBSD|DragonFly)
++NetBSD|OpenBSD|DragonFly)
+ # this is a temporary hack until we can live with the default search paths
+ LD_LIBRARY_PATH="$sd_prog${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+ JAVA_HOME=$(javaPathHelper -h libreoffice-java 2> /dev/null)
diff --git a/editors/libreoffice/files/patch-vcl_inc_opengl_x11_gdiimpl.hxx b/editors/libreoffice/files/patch-vcl_inc_opengl_x11_gdiimpl.hxx
deleted file mode 100644
index 6434e904750f..000000000000
--- a/editors/libreoffice/files/patch-vcl_inc_opengl_x11_gdiimpl.hxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- vcl/inc/opengl/x11/gdiimpl.hxx.orig 2015-08-22 06:41:35 UTC
-+++ vcl/inc/opengl/x11/gdiimpl.hxx
-@@ -16,7 +16,7 @@
- #include "unx/x11/x11gdiimpl.h"
- #include "openglgdiimpl.hxx"
-
--class TextureCombo;
-+struct TextureCombo;
-
- class VCL_PLUGIN_PUBLIC X11OpenGLSalGraphicsImpl : public OpenGLSalGraphicsImpl, public X11GraphicsImpl
- {