aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-04-26 14:55:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-04-26 14:55:09 +0000
commit11cee2e8c90cf7b2564f712b4ceb2ba08f91f761 (patch)
treea8fd9448fe533541847172a404c8cc229acbe427 /editors/libreoffice
parent63000530e371cda19dd2fcf0b0051770994d1bc0 (diff)
downloadports-11cee2e8c90cf7b2564f712b4ceb2ba08f91f761.tar.gz
ports-11cee2e8c90cf7b2564f712b4ceb2ba08f91f761.zip
Notes
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile10
-rw-r--r--editors/libreoffice/files/patch-vbahelper_inc_vbahelper_vbaaccesshelper.hxx11
2 files changed, 19 insertions, 2 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index d42ef9a954b5..e2b5e40d7086 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -7,7 +7,7 @@
.include "${.CURDIR}/Makefile.common"
-PORTREVISION= 1
+PORTREVISION= 2
MASTER_SITE_SUBDIR= src/${PORTVERSION}/
MASTER_SITES+= http://dev-www.libreoffice.org/src/:ext \
@@ -217,7 +217,13 @@ CC= clang
CXX= clang++
CXXCPP= clang-cpp
CPP= clang-cpp
-.if !exists(${DESTDIR}/usr/bin/clang)
+# Work around a bug in pointyhat and tinderbox, prevent it to determine than
+# clang from ports is needed when host is a freebsd 9+
+.if defined(PACKAGE_BUILDING)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
+USE_BINUTILS= yes
+.endif
+.if !exists(/usr/bin/clang)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
USE_BINUTILS= yes
CXXCPP= clang++ -E
diff --git a/editors/libreoffice/files/patch-vbahelper_inc_vbahelper_vbaaccesshelper.hxx b/editors/libreoffice/files/patch-vbahelper_inc_vbahelper_vbaaccesshelper.hxx
new file mode 100644
index 000000000000..a1ceb1636afd
--- /dev/null
+++ b/editors/libreoffice/files/patch-vbahelper_inc_vbahelper_vbaaccesshelper.hxx
@@ -0,0 +1,11 @@
+--- vbahelper/inc/vbahelper/vbaaccesshelper.hxx.orig 2012-04-26 10:20:44.869218717 +0200
++++ vbahelper/inc/vbahelper/vbaaccesshelper.hxx 2012-04-26 14:53:44.559610302 +0200
+@@ -51,7 +51,7 @@
+ return xVBAFactory;
+ }
+
+- VBAHELPER_DLLPRIVATE inline css::uno::Reference< css::uno::XInterface > createVBAUnoAPIServiceWithArgs( SfxObjectShell* pShell, const sal_Char* _pAsciiName, const css::uno::Sequence< css::uno::Any >& aArgs ) throw (css::uno::RuntimeException)
++ VBAHELPER_DLLPRIVATE inline css::uno::Reference< css::uno::XInterface > createVBAUnoAPIServiceWithArgs( SfxObjectShell* pShell, const sal_Char* _pAsciiName, const css::uno::Sequence< css::uno::Any >& aArgs ) throw (css::uno::Exception)
+ {
+ OSL_PRECOND( pShell, "createVBAUnoAPIService: no shell!" );
+ ::rtl::OUString sVarName( ::rtl::OUString::createFromAscii( _pAsciiName ) );