aboutsummaryrefslogtreecommitdiff
path: root/editors/manedit/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-20 08:10:42 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-20 08:10:42 +0000
commite557e7d7cd7f13a34b402483c10164b09a4d76cf (patch)
treea8c9986891a6daa68f559435fe1cedcbdbc421aa /editors/manedit/Makefile
parentae14eabf0e3a27dfbda973a352e6fb46652139ef (diff)
downloadports-e557e7d7cd7f13a34b402483c10164b09a4d76cf.tar.gz
ports-e557e7d7cd7f13a34b402483c10164b09a4d76cf.zip
Notes
Diffstat (limited to 'editors/manedit/Makefile')
-rw-r--r--editors/manedit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/editors/manedit/Makefile b/editors/manedit/Makefile
new file mode 100644
index 000000000000..433e98a2896e
--- /dev/null
+++ b/editors/manedit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: manedit
+# Date created: 9 February 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= manedit
+PORTVERSION= 0.4.h
+CATEGORIES= editors
+MASTER_SITES= ftp://fox.mit.edu/pub/xsw/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.h/h/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sobomax@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+
+MAN1= manedit.1
+
+pre-patch:
+ @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
+ xargs ${PERL} -pi -e 's|malloc\.h|stdlib.h|g'
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/manwrap.sh ${PREFIX}/bin/manwrap
+
+.include <bsd.port.mk>