aboutsummaryrefslogtreecommitdiff
path: root/editors/mined/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-03-30 23:39:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-03-30 23:39:27 +0000
commit0925e2fbfea47d362ba2d71955a94bed7a721a48 (patch)
tree7a3cdbf311a49289a6f891ea321510354d3f4a48 /editors/mined/Makefile
parenta638af812f732b8e9257b29a000d4b9fdc01ce4e (diff)
Notes
Diffstat (limited to 'editors/mined/Makefile')
-rw-r--r--editors/mined/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index 5b4a23abedcc..01679927a453 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mined
-PORTVERSION= 2000.11
+PORTVERSION= 2000.12
CATEGORIES= editors
MASTER_SITES= http://towo.net/mined/
@@ -22,15 +22,15 @@ PORTDOCS= *
.endif
USE_GMAKE= yes
-USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
MAKE_ARGS= GMAKE=${GMAKE} CC=${CC:T} OPT="${CFLAGS}"
INSTALL_TARGET= localinstall
MAN1= mined.1
-PRFX2FIX= src/makefile.bsd src/makefile.gcc usrshare/xinitrc.mined \
- usrshare/mined.desktop src/mined1.c
+PRFX2FIX= src/makefile.bsd usrshare/conf_user/xinitrc.mined \
+ src/makefile.curses src/mined1.c man/mined.1 \
+ usrshare/setup_install/mined.desktop src/makefile.gcc
pre-configure:
.for FILE in ${PRFX2FIX}
@@ -48,10 +48,15 @@ pre-build:
@${ECHO_MSG}
post-install:
- @${RM} ${DATADIR}/LICENSE.GNU ${DATADIR}/*.bat
+ ${INSTALL_DATA} ${WRKSRC}/usrshare/setup_install/mined.desktop \
+ ${DESKTOPDIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${DOCSDIR}
+ cd ${WRKSRC}/usrshare/package_doc && ${INSTALL_DATA} * ${DOCSDIR}
+ @${RM} ${DOCSDIR}/CHANGES ${DOCSDIR}/LICENSE.GNU
.endif
+ @${RM} ${DATADIR}/bin/*.bat
+ @${RM} -rf ${DATADIR}/doc_user ${DATADIR}/package_doc
.include <bsd.port.mk>