aboutsummaryrefslogtreecommitdiff
path: root/editors/mined/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-08-28 12:56:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-08-28 12:56:29 +0000
commitce25734f0601771659ebe921ef53d2745726a3c9 (patch)
tree9ff9e4cab0764b5a4f3b14ba5c2492b481cdfbde /editors/mined/Makefile
parentff514643472eb2beeda70956240afac7d630af45 (diff)
downloadports-ce25734f0601771659ebe921ef53d2745726a3c9.tar.gz
ports-ce25734f0601771659ebe921ef53d2745726a3c9.zip
Notes
Diffstat (limited to 'editors/mined/Makefile')
-rw-r--r--editors/mined/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index 136a2549a12e..ed0839a9c963 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mined
-PORTVERSION= 2000.10
+PORTVERSION= 2000.11
CATEGORIES= editors
MASTER_SITES= http://towo.net/mined/
@@ -18,15 +18,7 @@ MAKEFILE= makefile
.if defined(NOPORTDOCS)
ALL_TARGET= mined manual
.else
-PORTDOCS= cancel.html changes.html combined.png combining.png contact.html \
- design.html dollar.gif donate.html download.html euro1.gif features.html\
- handr.gif haninfo-big5.png haninfo-menu.png haninfo-utf8.png header.html\
- index-dl.html index.html logo.gif menu.png mined-html.png mined-uni.png \
- mined.html mnemodoc.html navigate.html new-rot.gif new.gif overview.html\
- paypal_donate.gif paypal_logo.gif paypal_payments.gif picklist.png \
- script-arabic.gif script-cyrillic.gif script-greek.gif script-han.gif \
- script-hebrew.gif script-highlighting.png script-hiragana.gif \
- script-thai.gif separated.png thankyou.html unicode.html
+PORTDOCS= *
.endif
USE_GMAKE= YES
@@ -36,9 +28,9 @@ INSTALL_TARGET= localinstall
MAN1= mined.1
pre-build:
- @${MV} ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.cc.bak
- @${CP} ${WRKSRC}/src/mkinclud.gcc ${WRKSRC}/src/mkinclud.cc
- @(if [ ! -f ${WRKSRC}/src/mkinclud.${CC:T} ] ; then \
+ ${MV} ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.cc.bak
+ ${CP} ${WRKSRC}/src/mkinclud.gcc ${WRKSRC}/src/mkinclud.cc
+ (if [ ! -f ${WRKSRC}/src/mkinclud.${CC:T} ] ; then \
${LN} -sf ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.${CC:T} ; \
fi)
@${ECHO_MSG}
@@ -46,9 +38,10 @@ pre-build:
@${ECHO_MSG}
post-install:
+ @${RM} ${DATADIR}/LICENSE.GNU ${DATADIR}/*.bat
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${DOCSDIR}
.endif
.include <bsd.port.mk>