aboutsummaryrefslogtreecommitdiff
path: root/editors/mined/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-01 19:55:53 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-01 19:55:53 +0000
commit232b8cf49a79803e4d1e47c27869f04463411d5d (patch)
tree956a248f84e18476f990c773edb70e3f341da583 /editors/mined/Makefile
parent93463c95c808931c67066e8cf0387dd941f5aa44 (diff)
Chase a silent update and make fetchable again.
This is a quite important update, with many changes. Full diff available at: <http://people.freebsd.org/~thierry/ports/mined-2000.12.060329_060401.diff> Reported by: dosirak via Kris
Notes
Notes: svn path=/head/; revision=158588
Diffstat (limited to 'editors/mined/Makefile')
-rw-r--r--editors/mined/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index 01679927a453..cc63fdf90a7f 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -7,13 +7,14 @@
PORTNAME= mined
PORTVERSION= 2000.12
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://towo.net/mined/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Text mode editor with Unicode support
-MAKEFILE= makefile
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.if defined(NOPORTDOCS)
ALL_TARGET= mined manual
@@ -22,6 +23,8 @@ PORTDOCS= *
.endif
USE_GMAKE= yes
+MAKEFILE= makefile
+MAKE_SHELL= ${LOCALBASE}/bin/bash # To avoid "shift: can't shift that many"
REINPLACE_ARGS= -i ""
MAKE_ARGS= GMAKE=${GMAKE} CC=${CC:T} OPT="${CFLAGS}"
INSTALL_TARGET= localinstall
@@ -36,6 +39,7 @@ pre-configure:
.for FILE in ${PRFX2FIX}
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/${FILE}
.endfor
+ ${REINPLACE_CMD} -e 's|#! ${SH}|#! ${MAKE_SHELL}|' ${WRKSRC}/makemined
pre-build:
${MV} ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.cc.bak