aboutsummaryrefslogtreecommitdiff
path: root/editors/mined
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-04-06 20:00:28 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-04-06 20:00:28 +0000
commitd97131927f54fb0641a77ffed832f90ed0a4fe5b (patch)
treedf01b9c5aef55c6089e32a62878fd460c1f12cb6 /editors/mined
parentba4d09242dd0d669b2368476599365e349dbcd89 (diff)
downloadports-d97131927f54fb0641a77ffed832f90ed0a4fe5b.tar.gz
ports-d97131927f54fb0641a77ffed832f90ed0a4fe5b.zip
Finally it seems that the base Gcc is sufficient: only -Wtype-limits is
newer and can be removed. Submitted by: danfe
Notes
Notes: svn path=/head/; revision=383475
Diffstat (limited to 'editors/mined')
-rw-r--r--editors/mined/Makefile8
-rw-r--r--editors/mined/files/patch-src__mkinclud.gcc15
2 files changed, 13 insertions, 10 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index befeff8cd273..13e5c23303b5 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -26,12 +26,6 @@ PRFX2FIX= src/makefile.bsd usrshare/conf_user/xinitrc.mined \
src/minedaux.c man/mined.1 src/mkinclud.mak \
src/makefile.gcc
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000000
-USE_GCC= yes
-.endif
-
pre-configure:
.for FILE in ${PRFX2FIX}
${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/${FILE}
@@ -55,4 +49,4 @@ post-install:
@${RM} -rf ${STAGEDIR}${DOCSDIR}/CHANGES ${STAGEDIR}${DOCSDIR}/LICENCE.GPL
@${RM} -rf ${STAGEDIR}${DATADIR}/doc_user ${STAGEDIR}${DATADIR}/package_doc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/mined/files/patch-src__mkinclud.gcc b/editors/mined/files/patch-src__mkinclud.gcc
index 412568a5e104..313dcc7d2360 100644
--- a/editors/mined/files/patch-src__mkinclud.gcc
+++ b/editors/mined/files/patch-src__mkinclud.gcc
@@ -1,6 +1,15 @@
---- src/mkinclud.gcc.orig 2011-07-20 00:00:00.000000000 +0200
-+++ src/mkinclud.gcc 2011-11-20 18:44:14.000000000 +0100
-@@ -48,7 +48,7 @@
+--- src/mkinclud.gcc.orig 2015-03-08 23:00:00 UTC
++++ src/mkinclud.gcc
+@@ -48,7 +48,7 @@ GFLAGS= -ansi -Waggregate-return -Winlin
+
+ GCC3FLAGS=-Wdeclaration-after-statement -Wno-pragmas
+ # -Wunreachable-code deprecated
+-GCC4FLAGS=$(GCC3FLAGS) -Wno-pointer-sign -Wtype-limits
++GCC4FLAGS=$(GCC3FLAGS) -Wno-pointer-sign
+
+ # Warning options for newer gcc versions:
+ # (additional grep for the sake of MSys sed failing on CRLF from MinGW gcc)
+@@ -71,7 +71,7 @@ PROTOFLAGS= -Wmissing-prototypes -Wretur
# compilation mode options (optimisation and debug)
# Optimization flag/level: