aboutsummaryrefslogtreecommitdiff
path: root/editors/mlview
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-05 11:07:21 +0000
committerSimon Barner <barner@FreeBSD.org>2005-09-05 11:07:21 +0000
commiteea4bff25b1074c6aa883bfba30e3fdd74063999 (patch)
tree41331d9a2a74797bb0f098974e81f01bc2b42848 /editors/mlview
parentf5fb3082d4d2010cbac5430d03e4b609ce785172 (diff)
downloadports-eea4bff25b1074c6aa883bfba30e3fdd74063999.tar.gz
ports-eea4bff25b1074c6aa883bfba30e3fdd74063999.zip
Notes
Diffstat (limited to 'editors/mlview')
-rw-r--r--editors/mlview/Makefile6
-rw-r--r--editors/mlview/files/patch-src_mlview-editor-dbc.c22
-rw-r--r--editors/mlview/files/patch-src_mlview-editor-dbo.c22
-rw-r--r--editors/mlview/files/patch-src_mlview-ping-dbc.c22
-rw-r--r--editors/mlview/files/patch-src_mlview-ping-dbo.c22
-rw-r--r--editors/mlview/files/patch-src_mlview-source-view.c23
-rw-r--r--editors/mlview/files/patch-src_mlview-tree-view.c23
-rw-r--r--editors/mlview/files/patch-src_mlview-view-adapter.c23
8 files changed, 160 insertions, 3 deletions
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index 40c9a35b2bea..585aa89fd5a9 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -41,9 +41,9 @@ CONFIGURE_ARGS+="--enable-dbus=yes"
pre-everything::
.if !defined (WITH_DBUS)
- ${ECHO_CMD}
- ${ECHO_CMD} Re-run with -DWITH_DBUS in order to enable dbus support!
- ${ECHO_CMD}
+ @${ECHO_CMD}
+ @${ECHO_CMD} Re-run with -DWITH_DBUS in order to enable dbus support!
+ @${ECHO_CMD}
.endif
.include <bsd.port.post.mk>
diff --git a/editors/mlview/files/patch-src_mlview-editor-dbc.c b/editors/mlview/files/patch-src_mlview-editor-dbc.c
new file mode 100644
index 000000000000..c95ef6817262
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-editor-dbc.c
@@ -0,0 +1,22 @@
+--- src/mlview-editor-dbc.c.orig Mon Sep 5 12:55:40 2005
++++ src/mlview-editor-dbc.c Mon Sep 5 12:56:44 2005
+@@ -168,13 +168,16 @@
+ 0,
+ (GInstanceInitFunc)mlview_editor_dbc_init
+ } ;
+- type = g_type_register_static (G_TYPE_OBJECT,
+- "MlViewEditorDBC",
+- &type_info, 0) ;
++
+ static const GInterfaceInfo idbc_info = {
+ (GInterfaceInitFunc) mlview_editor_dbc_idbc_init,
+ NULL, NULL
+ } ;
++
++ type = g_type_register_static (G_TYPE_OBJECT,
++ "MlViewEditorDBC",
++ &type_info, 0) ;
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IDBC,
+ &idbc_info) ;
+ }
diff --git a/editors/mlview/files/patch-src_mlview-editor-dbo.c b/editors/mlview/files/patch-src_mlview-editor-dbo.c
new file mode 100644
index 000000000000..853d30d25823
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-editor-dbo.c
@@ -0,0 +1,22 @@
+--- src/mlview-editor-dbo.c.orig Mon Sep 5 12:50:28 2005
++++ src/mlview-editor-dbo.c Mon Sep 5 12:51:41 2005
+@@ -303,14 +303,16 @@
+ 0,
+ (GInstanceInitFunc) mlview_editor_dbo_init
+ } ;
+- type = g_type_register_static (G_TYPE_OBJECT,
+- "MlViewEditorDBO",
+- &type_info, 0) ;
+
+ static const GInterfaceInfo idbo_info = {
+ (GInterfaceInitFunc) mlview_editor_dbo_idbo_init,
+ NULL, NULL
+ } ;
++
++ type = g_type_register_static (G_TYPE_OBJECT,
++ "MlViewEditorDBO",
++ &type_info, 0) ;
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IDBO,
+ &idbo_info) ;
+ }
diff --git a/editors/mlview/files/patch-src_mlview-ping-dbc.c b/editors/mlview/files/patch-src_mlview-ping-dbc.c
new file mode 100644
index 000000000000..8d5b65506dd8
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-ping-dbc.c
@@ -0,0 +1,22 @@
+--- src/mlview-ping-dbc.c.orig Mon Sep 5 12:57:39 2005
++++ src/mlview-ping-dbc.c Mon Sep 5 12:58:35 2005
+@@ -166,14 +166,16 @@
+ 0,
+ (GInstanceInitFunc) mlview_ping_dbc_init
+ } ;
+- type = g_type_register_static (G_TYPE_OBJECT,
+- "MlViewPingDBC",
+- &type_info, 0) ;
+
+ static const GInterfaceInfo idbc_info = {
+ (GInterfaceInitFunc) mlview_ping_dbc_idbc_init,
+ NULL, NULL
+ } ;
++
++ type = g_type_register_static (G_TYPE_OBJECT,
++ "MlViewPingDBC",
++ &type_info, 0) ;
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IDBC,
+ &idbc_info) ;
+ }
diff --git a/editors/mlview/files/patch-src_mlview-ping-dbo.c b/editors/mlview/files/patch-src_mlview-ping-dbo.c
new file mode 100644
index 000000000000..72dd45a7cce3
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-ping-dbo.c
@@ -0,0 +1,22 @@
+--- src/mlview-ping-dbo.c.orig Mon Sep 5 12:52:49 2005
++++ src/mlview-ping-dbo.c Mon Sep 5 12:53:50 2005
+@@ -362,13 +362,16 @@
+ 0,
+ (GInstanceInitFunc) mlview_ping_dbo_init
+ } ;
+- type = g_type_register_static (G_TYPE_OBJECT,
+- "MlViewPingDBO",
+- &type_info, 0) ;
++
+ static const GInterfaceInfo idbo_info = {
+ (GInterfaceInitFunc) mlview_ping_dbo_idbo_init,
+ NULL, NULL
+ } ;
++
++ type = g_type_register_static (G_TYPE_OBJECT,
++ "MlViewPingDBO",
++ &type_info, 0) ;
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IDBO,
+ &idbo_info) ;
+ }
diff --git a/editors/mlview/files/patch-src_mlview-source-view.c b/editors/mlview/files/patch-src_mlview-source-view.c
new file mode 100644
index 000000000000..82cc65126a01
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-source-view.c
@@ -0,0 +1,23 @@
+--- src/mlview-source-view.c.orig Mon Sep 5 12:24:55 2005
++++ src/mlview-source-view.c Mon Sep 5 12:25:47 2005
+@@ -1321,15 +1321,17 @@
+ (GInstanceInitFunc)
+ mlview_source_view_init
+ } ;
+- type = g_type_register_static
+- (MLVIEW_TYPE_VIEW_ADAPTER,
+- "MlViewSourceView", &type_info, 0);
+
+ static const GInterfaceInfo iview_info = {
+ (GInterfaceInitFunc) mlview_source_view_iview_init,
+ NULL,
+ NULL
+ } ;
++
++ type = g_type_register_static
++ (MLVIEW_TYPE_VIEW_ADAPTER,
++ "MlViewSourceView", &type_info, 0);
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IVIEW,
+ &iview_info) ;
+ }
diff --git a/editors/mlview/files/patch-src_mlview-tree-view.c b/editors/mlview/files/patch-src_mlview-tree-view.c
new file mode 100644
index 000000000000..d3811f82cb76
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-tree-view.c
@@ -0,0 +1,23 @@
+--- src/mlview-tree-view.c.orig Mon Sep 5 12:22:34 2005
++++ src/mlview-tree-view.c Mon Sep 5 12:24:10 2005
+@@ -2628,15 +2628,17 @@
+ (GInstanceInitFunc)
+ mlview_tree_view_init
+ };
+- type = g_type_register_static
+- (MLVIEW_TYPE_VIEW_ADAPTER,
+- "MlViewTreeView", &type_info, 0);
+
+ static const GInterfaceInfo iview_info = {
+ (GInterfaceInitFunc) mlview_tree_view_iview_init,
+ NULL,
+ NULL
+ } ;
++
++ type = g_type_register_static
++ (MLVIEW_TYPE_VIEW_ADAPTER,
++ "MlViewTreeView", &type_info, 0);
++
+ g_type_add_interface_static (type, MLVIEW_TYPE_IVIEW, &iview_info) ;
+ }
+ return type;
diff --git a/editors/mlview/files/patch-src_mlview-view-adapter.c b/editors/mlview/files/patch-src_mlview-view-adapter.c
new file mode 100644
index 000000000000..4dac738f4bd7
--- /dev/null
+++ b/editors/mlview/files/patch-src_mlview-view-adapter.c
@@ -0,0 +1,23 @@
+--- src/mlview-view-adapter.c.orig Mon Sep 5 12:19:12 2005
++++ src/mlview-view-adapter.c Mon Sep 5 12:21:26 2005
+@@ -865,14 +865,17 @@
+ (GInstanceInitFunc)
+ mlview_view_adapter_init
+ };
+- type_id = g_type_register_static (GTK_TYPE_VBOX,
+- "MlViewViewAdapter",
+- &type_info, 0);
++
+ static const GInterfaceInfo iview_info = {
+ (GInterfaceInitFunc) mlview_view_adapter_iview_init,
+ NULL,
+ NULL
+ } ;
++
++ type_id = g_type_register_static (GTK_TYPE_VBOX,
++ "MlViewViewAdapter",
++ &type_info, 0);
++
+ g_type_add_interface_static (type_id, MLVIEW_TYPE_IVIEW,
+ &iview_info) ;
+ }