aboutsummaryrefslogtreecommitdiff
path: root/editors/morla
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-10 17:49:08 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-10 17:49:08 +0000
commit16fca6a26a43baaa28be97850f9e30ed37c288cb (patch)
tree6e3d512f9c1a497626f98a0342423060379a579c /editors/morla
parent8493e2ddcd172efa336a44dfee24f1e14d0b7853 (diff)
downloadports-16fca6a26a43baaa28be97850f9e30ed37c288cb.tar.gz
ports-16fca6a26a43baaa28be97850f9e30ed37c288cb.zip
Notes
Diffstat (limited to 'editors/morla')
-rw-r--r--editors/morla/Makefile34
-rw-r--r--editors/morla/distinfo3
-rw-r--r--editors/morla/pkg-descr13
-rw-r--r--editors/morla/pkg-plist13
4 files changed, 63 insertions, 0 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
new file mode 100644
index 000000000000..e3d86e2fc925
--- /dev/null
+++ b/editors/morla/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: morla
+# Date created: 2006-04-09
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= morla
+PORTVERSION= 0.6
+CATEGORIES= editors textproc
+MASTER_SITES= http://www2.autistici.org/bakunin/morla/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A RDF editor
+
+LIB_DEPENDS= nxml.0:${PORTSDIR}/textproc/libnxml \
+ rdf.0:${PORTSDIR}/textproc/redland
+BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I/${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= libgtkhtml libxslt
+
+DESKTOP_ENTRIES="morla" \
+ "Edit RDF documents" \
+ "${DATADIR}/icons/128_color.png" \
+ "morla" \
+ "Application;WebDevelopment;" \
+ true
+
+.include <bsd.port.mk>
diff --git a/editors/morla/distinfo b/editors/morla/distinfo
new file mode 100644
index 000000000000..1da67e6936ab
--- /dev/null
+++ b/editors/morla/distinfo
@@ -0,0 +1,3 @@
+MD5 (morla-0.6.tar.gz) = ea7f328d20555f5f94c675e55ea7bf50
+SHA256 (morla-0.6.tar.gz) = ca60814516c12fc415686e7fc3fe558d728a85c7f9cbe6fdaa3a0d31471b4a55
+SIZE (morla-0.6.tar.gz) = 580633
diff --git a/editors/morla/pkg-descr b/editors/morla/pkg-descr
new file mode 100644
index 000000000000..a16309b4521e
--- /dev/null
+++ b/editors/morla/pkg-descr
@@ -0,0 +1,13 @@
+Morla is a RDF editor written in C. It is based on the libnxml and librdf
+libraries. With Morla you can manage more RDF documents simultaneously,
+visualize graphs and use templates for quick writing.
+
+With Morla you can import RDFS documents and use their contents to write new
+RDF triples. Templates are also RDF documents and they make Morla easily
+personalizable and expandable.
+
+You can also use Morla as a RDF navigator, wandering among the net knots of
+the RDF documents present on Internet exactly as we are used to do with normal
+browsers.
+
+WWW: http://www2.autistici.org/bakunin/morla/index.php
diff --git a/editors/morla/pkg-plist b/editors/morla/pkg-plist
new file mode 100644
index 000000000000..4f422a9ea52f
--- /dev/null
+++ b/editors/morla/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+bin/morla
+share/locale/it/LC_MESSAGES/morla.mo
+%%DATADIR%%/bootsplash.png
+%%DATADIR%%/icons/128_BN.png
+%%DATADIR%%/icons/128_color.png
+%%DATADIR%%/icons/32_BN.png
+%%DATADIR%%/icons/32_color.png
+%%DATADIR%%/icons/64_BN.png
+%%DATADIR%%/icons/64_color.png
+%%DATADIR%%/icons/700_color.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%