aboutsummaryrefslogtreecommitdiff
path: root/editors/mp/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-11-17 08:05:28 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-11-17 08:05:28 +0000
commitd51a0b9c5b05e19477680e41f8ed28618c299606 (patch)
treec75abae1e99e936c148e154d571debd5d4515fe6 /editors/mp/Makefile
parentfa5c489c1ca5126412045001db7a3bfbf99b482a (diff)
downloadports-d51a0b9c5b05e19477680e41f8ed28618c299606.tar.gz
ports-d51a0b9c5b05e19477680e41f8ed28618c299606.zip
Notes
Diffstat (limited to 'editors/mp/Makefile')
-rw-r--r--editors/mp/Makefile76
1 files changed, 58 insertions, 18 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 08cb26a5fbaf..ec11a60b31aa 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -6,28 +6,68 @@
#
PORTNAME= mp
-PORTVERSION= 3.2.9
-PORTREVISION= 1
+PORTVERSION= 3.3.16
CATEGORIES= editors
-MASTER_SITES= http://triptico.dhis.org/download/
+MASTER_SITES= http://www.triptico.com/download/
-MAINTAINER= markp@FreeBSD.org
+MAINTAINER= az@FreeBSD.org
COMMENT= A programming text editor
-USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config.sh
+CONFIGURE_ARGS= --prefix=${PREFIX} --without-win32
USE_REINPLACE= yes
-MAKE_ARGS+= PREFIX="${PREFIX}"
-MAKEFILE= makefile
-
-post-patch:
- ${REINPLACE_CMD} "s/gcc -g -Wall/${CC} ${CFLAGS} -Wall/g; \
- s/mp gmp/mp/g" ${WRKSRC}/makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mp ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+
+OPTIONS= CURSES "Build with ncurses support" on \
+ NLS "Native language support" on \
+ GTK1 "Build with GTK1 support" off \
+ GTK2 "Build with GTK2 support" off \
+ PCRE "Build with PCRE support" on
+
+MAN1= mp.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURSES)
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+.else
+CONFIGURE_ARGS+= --without-curses
+.endif
+
+.if defined(WITH_GTK1) || defined(WITH_GTK2)
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+.if defined(WITH_GTK1) && !defined(WITH_GTK2)
+USE_GNOME+= gtk12
+.else
+CONFIGURE_ARGS+= --without-gtk1
+.endif
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+.else
+CONFIGURE_ARGS+= --without-gtk2
+.endif
+.else
+CONFIGURE_ARGS+= --without-gtk
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --without-gettext
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.else
+CONFIGURE_ARGS+= --without-pcre
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>