aboutsummaryrefslogtreecommitdiff
path: root/editors/mp
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-11-17 08:05:28 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-11-17 08:05:28 +0000
commitd51a0b9c5b05e19477680e41f8ed28618c299606 (patch)
treec75abae1e99e936c148e154d571debd5d4515fe6 /editors/mp
parentfa5c489c1ca5126412045001db7a3bfbf99b482a (diff)
downloadports-d51a0b9c5b05e19477680e41f8ed28618c299606.tar.gz
ports-d51a0b9c5b05e19477680e41f8ed28618c299606.zip
Notes
Diffstat (limited to 'editors/mp')
-rw-r--r--editors/mp/Makefile76
-rw-r--r--editors/mp/distinfo5
-rw-r--r--editors/mp/files/patch-config.sh21
-rw-r--r--editors/mp/pkg-plist22
4 files changed, 102 insertions, 22 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 08cb26a5fbaf..ec11a60b31aa 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -6,28 +6,68 @@
#
PORTNAME= mp
-PORTVERSION= 3.2.9
-PORTREVISION= 1
+PORTVERSION= 3.3.16
CATEGORIES= editors
-MASTER_SITES= http://triptico.dhis.org/download/
+MASTER_SITES= http://www.triptico.com/download/
-MAINTAINER= markp@FreeBSD.org
+MAINTAINER= az@FreeBSD.org
COMMENT= A programming text editor
-USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config.sh
+CONFIGURE_ARGS= --prefix=${PREFIX} --without-win32
USE_REINPLACE= yes
-MAKE_ARGS+= PREFIX="${PREFIX}"
-MAKEFILE= makefile
-
-post-patch:
- ${REINPLACE_CMD} "s/gcc -g -Wall/${CC} ${CFLAGS} -Wall/g; \
- s/mp gmp/mp/g" ${WRKSRC}/makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mp ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+
+OPTIONS= CURSES "Build with ncurses support" on \
+ NLS "Native language support" on \
+ GTK1 "Build with GTK1 support" off \
+ GTK2 "Build with GTK2 support" off \
+ PCRE "Build with PCRE support" on
+
+MAN1= mp.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURSES)
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+.else
+CONFIGURE_ARGS+= --without-curses
+.endif
+
+.if defined(WITH_GTK1) || defined(WITH_GTK2)
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+.if defined(WITH_GTK1) && !defined(WITH_GTK2)
+USE_GNOME+= gtk12
+.else
+CONFIGURE_ARGS+= --without-gtk1
+.endif
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+.else
+CONFIGURE_ARGS+= --without-gtk2
+.endif
+.else
+CONFIGURE_ARGS+= --without-gtk
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --without-gettext
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.else
+CONFIGURE_ARGS+= --without-pcre
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/mp/distinfo b/editors/mp/distinfo
index 1d91517f206c..f3af317c3e85 100644
--- a/editors/mp/distinfo
+++ b/editors/mp/distinfo
@@ -1,2 +1,3 @@
-MD5 (mp-3.2.9.tar.gz) = 49a0a487d10f2fd37c310e1835a7c85f
-SIZE (mp-3.2.9.tar.gz) = 178045
+MD5 (mp-3.3.16.tar.gz) = d806d578fb37e3e69b5c69af7965d49a
+SHA256 (mp-3.3.16.tar.gz) = 374f71d3c21426ee8dc3b5e6b236f7545d54d8f838f2080eb700876ebb3f7b37
+SIZE (mp-3.3.16.tar.gz) = 276885
diff --git a/editors/mp/files/patch-config.sh b/editors/mp/files/patch-config.sh
new file mode 100644
index 000000000000..1b7aa1cd67da
--- /dev/null
+++ b/editors/mp/files/patch-config.sh
@@ -0,0 +1,21 @@
+--- config.sh.orig Wed Feb 23 21:23:18 2005
++++ config.sh Thu Jul 21 18:18:59 2005
+@@ -320,14 +320,16 @@
+ echo "#define CONFOPT_GETTEXT 1" >> config.h
+ else
+ # try now with -lintl
+- TMP_LDFLAGS="-lintl"
++ TMP_LDFLAGS="-L/usr/local/lib -lintl"
++ TMP_CFLAGS="-I/usr/local/include"
+
+- $CC .tmp.c $TMP_LDFLAGS -o .tmp.o 2>> .config.log
++ $CC $TMP_CFLAGS .tmp.c $TMP_LDFLAGS -o .tmp.o 2>> .config.log
+
+ if [ $? = 0 ] ; then
+ echo "OK (libintl needed)"
+ echo "#define CONFOPT_GETTEXT 1" >> config.h
+ echo "$TMP_LDFLAGS" >> config.ldflags
++ echo "$TMP_CFLAGS" >> config.cflags
+ else
+ echo "No"
+ WITHOUT_GETTEXT=1
diff --git a/editors/mp/pkg-plist b/editors/mp/pkg-plist
index d99941ba74f6..e7adb13ffb49 100644
--- a/editors/mp/pkg-plist
+++ b/editors/mp/pkg-plist
@@ -1,3 +1,21 @@
bin/mp
-%%PORTDOCS%%share/doc/mp/README.html
-%%PORTDOCS%%@dirrm share/doc/mp
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/Changelog
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README.IRIX
+%%DOCSDIR%%/README.mingw32
+%%DOCSDIR%%/README.solaris
+%%DOCSDIR%%/README.zaurus
+%%DOCSDIR%%/RELEASE_NOTES
+%%DOCSDIR%%/mprc-win32.sample
+%%DOCSDIR%%/mprc.sample
+%%NLS%%share/locale/de/LC_MESSAGES/minimum-profit.mo
+%%NLS%%share/locale/es/LC_MESSAGES/minimum-profit.mo
+%%NLS%%share/locale/it/LC_MESSAGES/minimum-profit.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/minimum-profit.mo
+%%NLS%%@unexec rmdir %D/share/locale/nl/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+@dirrm %%DOCSDIR%%