aboutsummaryrefslogtreecommitdiff
path: root/editors/nano
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2009-08-30 15:26:48 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2009-08-30 15:26:48 +0000
commit73c5e38ae74e00af4f901940b56b605500c26936 (patch)
treee5b4205bb0ffb2a77f0ebf39771914292517aea9 /editors/nano
parent6ed14832f0c4e36f1026da833dc09fd7b3de2cf7 (diff)
downloadports-73c5e38ae74e00af4f901940b56b605500c26936.tar.gz
ports-73c5e38ae74e00af4f901940b56b605500c26936.zip
Notes
Diffstat (limited to 'editors/nano')
-rw-r--r--editors/nano/Makefile1
-rw-r--r--editors/nano/files/patch-src_rcfile.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 3b7480f93db9..970870e56e2c 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nano
PORTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/v2.0/ \
http://www.ewtoo.org/~astyanax/nano/dist/v2.0/
diff --git a/editors/nano/files/patch-src_rcfile.c b/editors/nano/files/patch-src_rcfile.c
new file mode 100644
index 000000000000..6dbf573c286c
--- /dev/null
+++ b/editors/nano/files/patch-src_rcfile.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/rcfile.c.orig
++++ src/rcfile.c
+@@ -612,7 +612,7 @@
+ {
+ char *buf = NULL;
+ ssize_t len;
+- size_t n;
++ size_t n = 0;
+
+ while ((len = getline(&buf, &n, rcstream)) > 0) {
+ char *ptr, *keyword, *option;