aboutsummaryrefslogtreecommitdiff
path: root/editors/nano
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-09-14 11:20:45 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-09-14 11:20:45 +0000
commit03f6c24e87819fe9a63cff1690308ad5ef1edcbf (patch)
tree1304d566aec01e9f0760b74472e794dd95d28e62 /editors/nano
parent77fcd35ebe1a462d84aea56849a681d3087792dc (diff)
Notes
Diffstat (limited to 'editors/nano')
-rw-r--r--editors/nano/Makefile1
-rw-r--r--editors/nano/files/patch-src_nano.c11
-rw-r--r--editors/nano/files/patch-src_nano.h10
3 files changed, 22 insertions, 0 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index cbc2174e7374..edd56f751613 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nano
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/v${PORTVERSION:R}/ GNU
diff --git a/editors/nano/files/patch-src_nano.c b/editors/nano/files/patch-src_nano.c
new file mode 100644
index 000000000000..83331be9119c
--- /dev/null
+++ b/editors/nano/files/patch-src_nano.c
@@ -0,0 +1,11 @@
+--- src/nano.c.orig 2018-09-14 11:02:24 UTC
++++ src/nano.c
+@@ -2580,7 +2580,7 @@ int main(int argc, char **argv)
+ controlhome = get_keycode("kHOM5", CONTROL_HOME);
+ controlend = get_keycode("kEND5", CONTROL_END);
+ controldelete = get_keycode("kDC5", CONTROL_DELETE);
+- controlshiftdelete = get_keycode("kDC6", KEY_BACKSPACE);
++ controlshiftdelete = get_keycode("kDC6", CONTROL_SHIFT_DELETE);
+ #ifndef NANO_TINY
+ /* Ask for the codes for Shift+Control+Left/Right/Up/Down. */
+ shiftcontrolleft = get_keycode("kLFT6", SHIFT_CONTROL_LEFT);
diff --git a/editors/nano/files/patch-src_nano.h b/editors/nano/files/patch-src_nano.h
new file mode 100644
index 000000000000..fc24ecf0bfe9
--- /dev/null
+++ b/editors/nano/files/patch-src_nano.h
@@ -0,0 +1,10 @@
+--- src/nano.h.orig 2018-09-14 11:02:29 UTC
++++ src/nano.h
+@@ -588,6 +588,7 @@ enum
+ #define SHIFT_CONTROL_DOWN 0x414
+ #define SHIFT_CONTROL_HOME 0x415
+ #define SHIFT_CONTROL_END 0x416
++#define CONTROL_SHIFT_DELETE 0x417
+ #define ALT_LEFT 0x421
+ #define ALT_RIGHT 0x422
+ #define ALT_UP 0x423