aboutsummaryrefslogtreecommitdiff
path: root/editors/nano
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-15 11:55:13 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-15 11:55:13 +0000
commitb56fd34b7f4e676cb1168702cdf689b92123180c (patch)
tree3a92d2c34004d2288d607d5705ebc564603ff3c8 /editors/nano
parentff1a259bb84349e0cc85589732d20b262b2c0c2b (diff)
downloadports-b56fd34b7f4e676cb1168702cdf689b92123180c.tar.gz
ports-b56fd34b7f4e676cb1168702cdf689b92123180c.zip
- Remove groff dependency. The tarball already has the HTML files
- Remove unecessary REINPLACE_CMD - Use post-install-{EXAMPLES,DOCS}-on to install the extra files while here: - Disable groff execution by the configure script PR: 234000 Submitted by: Daniel Eisele <daniel_eisele AT gmx.de>
Notes
Notes: svn path=/head/; revision=487507
Diffstat (limited to 'editors/nano')
-rw-r--r--editors/nano/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 3316bdb49dbf..1f9661951661 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -25,8 +25,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
-DOCS_USES= groff
-
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
@@ -34,17 +32,16 @@ INFO= nano
PORTSCOUT= limitw:1,even
-post-configure:
- ${REINPLACE_CMD} -e 's/update_revision//g' ${WRKSRC}/src/Makefile
-
-post-build:
- cd ${WRKSRC}/doc; ${REINPLACE_CMD} \
- -e 's:SYSCONFDIR:${PREFIX}/etc:g' \
- -e 's:EXAMPLESDIR:${EXAMPLESDIR}:g' \
- nano.1 rnano.1 nanorc.5 ${WRKSRC}/doc/${INFO:=.info}
+post-patch:
+ ${REINPLACE_CMD} -e 's/^groff.*/false/' ${WRKSRC}/configure
-post-install:
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/sample.nanorc ${STAGEDIR}${EXAMPLESDIR}
+post-install-DOCS-on:
+.for doc in nano.1.html rnano.1.html nanorc.5.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
.include <bsd.port.mk>