aboutsummaryrefslogtreecommitdiff
path: root/editors/ne
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-22 11:12:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-22 11:12:24 +0000
commit3ad0a0376fed849fc750b6bf3873a0c5308b8dbb (patch)
tree17dbff897c9d38bb495c27021b8e3e3c52728083 /editors/ne
parentfbf7bc486402b7c31248b5f10cceb9846e04f6e0 (diff)
downloadports-3ad0a0376fed849fc750b6bf3873a0c5308b8dbb.tar.gz
ports-3ad0a0376fed849fc750b6bf3873a0c5308b8dbb.zip
Notes
Diffstat (limited to 'editors/ne')
-rw-r--r--editors/ne/Makefile43
-rw-r--r--editors/ne/distinfo2
-rw-r--r--editors/ne/pkg-descr6
-rw-r--r--editors/ne/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/editors/ne/Makefile b/editors/ne/Makefile
new file mode 100644
index 000000000000..136f6d24c687
--- /dev/null
+++ b/editors/ne/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ne
+# Date created: 2005-07-21
+# Whom: Andrej Zverev <az@inec.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ne
+PORTVERSION= 1.40
+CATEGORIES= editors
+MASTER_SITES= http://ne.dsi.unimi.it/
+
+MAINTAINER= az@inec.ru
+COMMENT= Nice and powerfull editor
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses:${PORTSDIR}/devel/ncurses
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+USE_GMAKE= yes
+USE_PERL5= yes
+MAKEFILE= makefile
+ALL_TARGET= ne
+MAKE_ARGS= CFLAGS="${CFLAGS} -DNOWCHAR" CC="${CC}" \
+ GLOBALDIR="${DATADIR}"
+
+MAN1= ne.1
+
+post-patch:
+ @${PERL5} -pi -e 's|tmpnam\(|mkstemp\(|g' ${WRKSRC}/actions.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ne ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/default.keys ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/../doc/default.menus ${DATADIR}/
+ ${INSTALL_MAN} ${WRKSRC}/../doc/ne.1 ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/editors/ne/distinfo b/editors/ne/distinfo
new file mode 100644
index 000000000000..ee70152bc941
--- /dev/null
+++ b/editors/ne/distinfo
@@ -0,0 +1,2 @@
+MD5 (ne-1.40.tar.gz) = 7fbbc0268dbcadfa6391670166c765f6
+SIZE (ne-1.40.tar.gz) = 1127279
diff --git a/editors/ne/pkg-descr b/editors/ne/pkg-descr
new file mode 100644
index 000000000000..1996f082ca96
--- /dev/null
+++ b/editors/ne/pkg-descr
@@ -0,0 +1,6 @@
+Ne is a free text editor based on the POSIX standard that runs (we
+hope) on almost any UN*X machine. ne is easy to use for the beginner, but
+powerful and fully configurable for the wizard, and most sparing in its
+resource usage
+
+WWW: http://ne.dsi.unimi.it/
diff --git a/editors/ne/pkg-plist b/editors/ne/pkg-plist
new file mode 100644
index 000000000000..20a525216e11
--- /dev/null
+++ b/editors/ne/pkg-plist
@@ -0,0 +1,4 @@
+bin/ne
+%%DATADIR%%/default.keys
+%%DATADIR%%/default.menus
+@dirrm share/ne