aboutsummaryrefslogtreecommitdiff
path: root/editors/nvi-devel
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-03-21 23:25:10 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-03-21 23:25:10 +0000
commit64e0d4cf20855f1b69fd2508fa65219de6f54ff0 (patch)
treee9245e7247489a4c637c251b5c77e1b5447669a0 /editors/nvi-devel
parentd7fd7f1030c60772b39fcff2f7f5656cc3d8f9d2 (diff)
Notes
Diffstat (limited to 'editors/nvi-devel')
-rw-r--r--editors/nvi-devel/Makefile11
-rw-r--r--editors/nvi-devel/files/patch-configure26
2 files changed, 8 insertions, 29 deletions
diff --git a/editors/nvi-devel/Makefile b/editors/nvi-devel/Makefile
index c6dee1dcde67..7ccfa44413f8 100644
--- a/editors/nvi-devel/Makefile
+++ b/editors/nvi-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvi
PORTVERSION= 1.81.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors
MASTER_SITES= http://www.kotnet.org/~skimo/nvi/devel/
@@ -23,10 +23,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_ICONV= yes
-USE_BDB= 3
+USE_BDB= yes
CONFIGURE_ARGS+= --with-db-prefix=${LOCALBASE} \
--program-prefix=n
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_SCRIPT= ../dist/configure
MAN1= nex.1 nvi.1 nview.1
@@ -36,10 +35,14 @@ MAN1= nex.1 nvi.1 nview.1
CONFIGURE_ARGS+= --enable-widechar
.endif
+CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${BDB_LIB_DIR} -L${LOCALBASE}/lib"
+
# configure is 555, so you can't do a "make configure" as non-root.
post-patch:
${REINPLACE_CMD} -e 's,%%LIBTOOL%%,${LIBTOOL},g ; \
- s,%%LTMAIN%%,${LTMAIN},g' ${WRKSRC}/../dist/configure
+ s,%%LTMAIN%%,${LTMAIN},g ; \
+ s,-ldb,-l${BDB_LIB_NAME},g' ${WRKSRC}/../dist/configure
@${CHMOD} 755 ${WRKSRC}/../dist/configure
post-install:
diff --git a/editors/nvi-devel/files/patch-configure b/editors/nvi-devel/files/patch-configure
index 6083d8416579..ad4cbbca685a 100644
--- a/editors/nvi-devel/files/patch-configure
+++ b/editors/nvi-devel/files/patch-configure
@@ -39,34 +39,10 @@
int
main ()
-@@ -28755,18 +28758,19 @@
- SAVELDFLAGS="$LDFLAGS"
- if test "x$with_db_prefix" != "x"; then
- LDFLAGS="-L$with_db_prefix/lib $LDFLAGS"
-- CPPFLAGS="-I$with_db_prefix/include $CPPFLAGS"
-+ CPPFLAGS="-I$with_db_prefix/include/db3 $CPPFLAGS"
- fi
- if test "$with_db_type" != db1; then
- SAVELIBS="$LIBS"
-
-- LIBS="$LIBS -ldb"
-+ LIBS="$LIBS -ldb3"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
+@@ -28755,5 +28758,6 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <sys/stddef.h>
#include <db.h>
int
main ()
-@@ -28958,7 +28962,7 @@
- dl_src=../common/dldb.c
- LIBS="-ldl $LIBS"
- else
-- LIBS="-ldb $LIBS"
-+ LIBS="-ldb3 $LIBS"
- if test "X$with_db_prefix" != "X"; then
- LDFLAGS="`echo $with_db_prefix/lib | sed "$LRscript"` $LDFLAGS"
- fi