aboutsummaryrefslogtreecommitdiff
path: root/editors/nvi-m17n
diff options
context:
space:
mode:
authorIssei Suzuki <issei@FreeBSD.org>2001-01-10 20:36:53 +0000
committerIssei Suzuki <issei@FreeBSD.org>2001-01-10 20:36:53 +0000
commit16d5af4fe081edb72bb61e3e8fb6deff798c663b (patch)
tree6b9879ad348252f4ab18ebd81245d931f87b06a1 /editors/nvi-m17n
parentadebb44765a70e1dace28df0671dfa5589f4cc6c (diff)
downloadports-16d5af4fe081edb72bb61e3e8fb6deff798c663b.tar.gz
ports-16d5af4fe081edb72bb61e3e8fb6deff798c663b.zip
Notes
Diffstat (limited to 'editors/nvi-m17n')
-rw-r--r--editors/nvi-m17n/Makefile6
-rw-r--r--editors/nvi-m17n/files/patch-ac51
2 files changed, 53 insertions, 4 deletions
diff --git a/editors/nvi-m17n/Makefile b/editors/nvi-m17n/Makefile
index 29482bf50b69..166c30ac2869 100644
--- a/editors/nvi-m17n/Makefile
+++ b/editors/nvi-m17n/Makefile
@@ -29,10 +29,8 @@ CONFIGURE_ARGS= --enable-multibyte --program-prefix=n
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 400000
-post-extract:
- ${RM} -f ${WRKSRC}/../include/sys/queue.h
-.endif
+post-patch:
+ ${LN} -s /usr/include/sys/queue.h ${WRKSRC}/../include/sys/queue_dist.h
post-install:
@${CP} ${WRKSRC}/../docs.m17n/README.english \
diff --git a/editors/nvi-m17n/files/patch-ac b/editors/nvi-m17n/files/patch-ac
new file mode 100644
index 000000000000..283366a97955
--- /dev/null
+++ b/editors/nvi-m17n/files/patch-ac
@@ -0,0 +1,51 @@
+--- ../include/sys/queue.h.old Wed Jan 10 07:16:01 2001
++++ ../include/sys/queue.h Wed Jan 10 07:17:02 2001
+@@ -33,8 +33,10 @@
+ * @(#)queue.h 8.5 (Berkeley) 8/20/94
+ */
+
+-#ifndef _SYS_QUEUE_H_
+-#define _SYS_QUEUE_H_
++#ifndef _SYS_QUEUE_HACK_H_
++#define _SYS_QUEUE_HACK_H_
++
++#include <sys/queue_dist.h>
+
+ /*
+ * This file defines three types of data structures: lists, tail queues,
+@@ -65,6 +67,7 @@
+ * For details on the use of these macros, see the queue(3) manual page.
+ */
+
++#ifndef LIST_HEAD
+ /*
+ * List definitions.
+ */
+@@ -114,7 +117,9 @@
+ (elm)->field.le_prev; \
+ *(elm)->field.le_prev = (elm)->field.le_next; \
+ }
++#endif /* LIST_HEAD */
+
++#ifndef TAILQ_HEAD
+ /*
+ * Tail queue definitions.
+ */
+@@ -180,7 +185,9 @@
+ (head)->tqh_last = (elm)->field.tqe_prev; \
+ *(elm)->field.tqe_prev = (elm)->field.tqe_next; \
+ }
++#endif /* TAILQ_HEAD */
+
++#ifndef CIRCLEQ_HEAD
+ /*
+ * Circular queue definitions.
+ */
+@@ -256,4 +263,6 @@
+ (elm)->field.cqe_prev->field.cqe_next = \
+ (elm)->field.cqe_next; \
+ }
+-#endif /* !_SYS_QUEUE_H_ */
++#endif /* CIRCLEQ_HEAD */
++
++#endif /* !_SYS_QUEUE_HACK_H_ */