aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-13 23:50:49 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-13 23:50:49 +0000
commit120acb1c887402ac73450aacbebcfc1bc9682def (patch)
treedd1f64df77b5a1ee2da6958ef94a13b978c933e0 /editors/openoffice-3-devel/Makefile
parent5d4e8b9ffd5ccabb02726572fdb136ff5cfa1fff (diff)
downloadports-120acb1c887402ac73450aacbebcfc1bc9682def.tar.gz
ports-120acb1c887402ac73450aacbebcfc1bc9682def.zip
Notes
Diffstat (limited to 'editors/openoffice-3-devel/Makefile')
-rw-r--r--editors/openoffice-3-devel/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 3618be4c89f1..b048c6ec077d 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -40,6 +40,14 @@ USE_GNOME+= libidl
USE_GNOME= desktopfileutils gtk20
+.if defined(WITH_KDE4) && defined(WITH_KDE)
+.error "Cannot define WITH_KDE and WITH_KDE4 at the same time"
+.endif
+.if defined(WITH_KDE4)
+USE_KDE4= kdelibs
+USE_QT_VER= 4
+.endif
+
.if defined(WITH_KDE)
USE_KDELIBS_VER= 3
.endif
@@ -196,6 +204,9 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+.if defined(WITH_KDE4)
+ @${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
+.endif
do-build:
@cd ${WRKSRC} ; ./bootstrap