aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-01-10 14:37:34 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-01-10 14:37:34 +0000
commitb7cb0599644c39370db7c14ad3e02ac9cd5bfe01 (patch)
tree77ee3c21dbee4d8ee0be9740e868ac4b29f0b395 /editors/openoffice-3-devel/Makefile
parent1a29d3519ad79cde4510f52ad8410ff662db3e3f (diff)
downloadports-b7cb0599644c39370db7c14ad3e02ac9cd5bfe01.tar.gz
ports-b7cb0599644c39370db7c14ad3e02ac9cd5bfe01.zip
Notes
Diffstat (limited to 'editors/openoffice-3-devel/Makefile')
-rw-r--r--editors/openoffice-3-devel/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 831d754f7b51..86a118742ff6 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -67,9 +67,9 @@ JAVA_VERSION= 1.4 1.5 1.6
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
-FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set.sh
.else
-FREEBSD_ENV_SET= FreeBSDX86Env.Set
+FREEBSD_ENV_SET= FreeBSDX86Env.Set.sh
.endif
MILESTONE?= 68
@@ -126,8 +126,8 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
USE_BISON= build
GNU_CONFIGURE= yes
-WRKSRC?= ${WRKDIR}/${OOOTAG}
-TCSH?= /bin/tcsh
+WRKSRC?= ${WRKDIR}/${OOOTAG}
+BASH?= ${PREFIX}/bin/bash
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(DISABLE_MAKE_JOBS)
@@ -146,6 +146,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--enable-pdfimport \
--enable-wiki-publisher \
--enable-report-builder \
+ --with-use-shell=bash \
--with-vendor="FreeBSD ports system"
OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
@@ -205,7 +206,7 @@ pre-build:
do-build:
@cd ${WRKSRC} ; ./bootstrap
- @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; setenv TMPDIR ${WRKSRC} ; cd instsetoo_native ; build.pl --checkmodules ; build.pl -P${MAKE_JOBS_NUMBER} --all --html --dontgraboutput"
+ @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native ; build.pl --checkmodules ; build.pl -P${MAKE_JOBS_NUMBER} --all --html --dontgraboutput"
.if ${LOCALIZED_LANG} == "alllangs"
@${MAKE} languagepack