aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-08-29 03:43:36 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-08-29 03:43:36 +0000
commit4afdafd62ffb97dfd5f685c5fc98033da6098dc6 (patch)
treed5cdab49204e9900ca2924f9a36774533b8e09f4 /editors/openoffice-3-devel
parent55dbc42630fa72911022ff6080a65d1384abb29a (diff)
downloadports-4afdafd62ffb97dfd5f685c5fc98033da6098dc6.tar.gz
ports-4afdafd62ffb97dfd5f685c5fc98033da6098dc6.zip
Notes
Diffstat (limited to 'editors/openoffice-3-devel')
-rw-r--r--editors/openoffice-3-devel/Makefile5
-rw-r--r--editors/openoffice-3-devel/files/patch-i9323588
2 files changed, 89 insertions, 4 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index f044aade171e..7dc42aff116f 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= 3.0.${SNAPDATE}
+PORTREVISION= 1
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
http://openoffice.lunarshells.com/sources/ \
@@ -54,11 +55,7 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
-.if (${OSVERSION} >= 800000)
-JAVA_VENDOR= bsdjava
-.else
JAVA_VENDOR= freebsd bsdjava
-.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5 1.6
.else
diff --git a/editors/openoffice-3-devel/files/patch-i93235 b/editors/openoffice-3-devel/files/patch-i93235
new file mode 100644
index 000000000000..a581a2c34afd
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-i93235
@@ -0,0 +1,88 @@
+Add support for Diablo JDK 1.6.0 and above.
+
+--- /dev/null 2008-08-27 17:05:37.000000000 -0400
++++ jvmfwk/distributions/OpenOfficeorg/javavendors_freebsd.xml 2008-08-27 17:20:55.000000000 -0400
+@@ -0,0 +1,38 @@
++<?xml version="1.0" encoding="UTF-8"?>
++
++<javaSelection xmlns="http://openoffice.org/2004/java/framework/1.0"
++ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
++
++ <updated>2008-08-27</updated>
++
++ <vendorInfos>
++ <vendor name="Sun Microsystems Inc.">
++ <minVersion>1.3.1</minVersion>
++ </vendor>
++ <vendor name="The FreeBSD Foundation">
++ <minVersion>1.6.0</minVersion>
++ </vendor>
++ <vendor name="IBM Corporation">
++ <minVersion>1.3.1</minVersion>
++ <maxVersion>1.4.2</maxVersion>
++ </vendor>
++ <vendor name="Blackdown Java-Linux Team">
++ <minVersion>1.3.1</minVersion>
++ </vendor>
++ <vendor name="Free Software Foundation, Inc.">
++ <minVersion>1.4.2</minVersion>
++ </vendor>
++ <vendor name="BEA Systems, Inc.">
++ <minVersion>1.4.1</minVersion>
++ </vendor>
++ </vendorInfos>
++
++ <plugins>
++ <library vendor="Sun Microsystems Inc.">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ <library vendor="The FreeBSD Foundation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ <library vendor="IBM Corporation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ <library vendor="Blackdown Java-Linux Team">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ <library vendor="Free Software Foundation, Inc.">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ <library vendor="BEA Systems, Inc.">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.so</library>
++ </plugins>
++</javaSelection>
+--- jvmfwk/distributions/OpenOfficeorg/makefile.mk.orig 2008-04-11 06:16:59.000000000 -0400
++++ jvmfwk/distributions/OpenOfficeorg/makefile.mk 2008-08-27 17:09:45.000000000 -0400
+@@ -43,9 +43,11 @@
+ .IF "$(SOLAR_JAVA)"!=""
+ $(BIN)$/javavendors.xml: javavendors_unx.xml javavendors_wnt.xml javavendors_macosx.xml javavendors_linux.xml
+ .IF "$(GUI)"=="UNX"
+-.IF "$(OS)"=="MACOSX"
++.IF "$(OS)"=="FREEBSD"
++ -$(COPY) javavendors_freebsd.xml $(BIN)$/javavendors.xml
++.ELIF "$(OS)"=="MACOSX"
+ -$(COPY) javavendors_macosx.xml $(BIN)$/javavendors.xml
+-.ELIF "$(OS)"=="LINUX" || "$(OS)"=="FREEBSD"
++.ELIF "$(OS)"=="LINUX"
+ -$(COPY) javavendors_linux.xml $(BIN)$/javavendors.xml
+ .ELSE
+ -$(COPY) javavendors_unx.xml $(BIN)$/javavendors.xml
+--- jvmfwk/plugins/sunmajor/javaenvsetup/javaldx.cxx.orig 2008-04-11 06:19:31.000000000 -0400
++++ jvmfwk/plugins/sunmajor/javaenvsetup/javaldx.cxx 2008-08-27 17:19:35.000000000 -0400
+@@ -128,13 +128,15 @@
+ rtl::OUString sVendor5(RTL_CONSTASCII_USTRINGPARAM("Apple Computer, Inc."));
+ rtl::OUString sVendor6(RTL_CONSTASCII_USTRINGPARAM("BEA Systems, Inc."));
+ rtl::OUString sVendor7(RTL_CONSTASCII_USTRINGPARAM("Free Software Foundation, Inc."));
++ rtl::OUString sVendor8(RTL_CONSTASCII_USTRINGPARAM("The FreeBSD Foundation"));
+ if ( ! (sVendor1.equals(pInfo->sVendor) == sal_True
+ || sVendor2.equals(pInfo->sVendor) == sal_True
+ || sVendor3.equals(pInfo->sVendor) == sal_True
+ || sVendor4.equals(pInfo->sVendor) == sal_True
+ || sVendor5.equals(pInfo->sVendor) == sal_True
+ || sVendor6.equals(pInfo->sVendor) == sal_True
+- || sVendor7.equals(pInfo->sVendor) == sal_True))
++ || sVendor7.equals(pInfo->sVendor) == sal_True
++ || sVendor8.equals(pInfo->sVendor) == sal_True))
+ return 0;
+
+ rtl::OString sPaths = getLD_LIBRARY_PATH(pInfo->arVendorData);
+--- jvmfwk/plugins/sunmajor/pluginlib/vendorlist.cxx.orig 2008-04-11 06:24:39.000000000 -0400
++++ jvmfwk/plugins/sunmajor/pluginlib/vendorlist.cxx 2008-08-27 17:13:00.000000000 -0400
+@@ -56,6 +56,7 @@
+ VENDOR_MAP_ENTRY("Apple Computer, Inc.", OtherInfo)
+ VENDOR_MAP_ENTRY("BEA Systems, Inc.", OtherInfo)
+ VENDOR_MAP_ENTRY("Free Software Foundation, Inc.", GnuInfo)
++ VENDOR_MAP_ENTRY("The FreeBSD Foundation", OtherInfo)
+ END_VENDOR_MAP()
+
+