aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-01-19 19:40:46 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-01-19 19:40:46 +0000
commit5d34385aa7a6706fb02132125aef37b22e0d59ff (patch)
treef7a6d64befe72761601c8df294bb6f244299bd0b /editors/openoffice-4/Makefile
parent3b6e10de506d98796ff00e08973f5dd2a084af76 (diff)
downloadports-5d34385aa7a6706fb02132125aef37b22e0d59ff.tar.gz
ports-5d34385aa7a6706fb02132125aef37b22e0d59ff.zip
Notes
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index d39826c281d3..82ed48bc8942 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -138,14 +138,13 @@ WITHOUT_CPU_CFLAGS= true
CPE_PRODUCT= ${PORTNAME:S|apache-||}
CPE_VENDOR= apache
-OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA SDK WIKI_PUBLISHER CCACHE
+OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA SDK WIKI_PUBLISHER
OPTIONS_DEFAULT= CUPS GNOME GNOMEVFS MMEDIA WIKI_PUBLISHER
GNOME_DESC= GConf + screensaver presentation control via DBUS
GNOMEVFS_DESC= GNOME Virtual File System
MMEDIA_DESC= Multimedia backend for impress
SDK_DESC= Build and install software development kit
WIKI_PUBLISHER_DESC= Build and install Wiki Publisher extension
-CCACHE_DESC= Mimimize compile time of C/C++ programs
CUPS_CONFIGURE_ENABLE= cups
CUPS_LIB_DEPENDS= libcups.so:print/cups
@@ -207,18 +206,7 @@ PACKAGE_PREFIX= Apache_OpenOffice
LOCALIZED_LANG?= en-US
-.if ${PORT_OPTIONS:MCCACHE} || defined(WITH_CCACHE)
-BUILD_DEPENDS+= ccache:devel/ccache
-CCACHE_PREFIX= ccache
-AOOCC= ${CCACHE_PREFIX} ${CC}
-AOOCXX= ${CCACHE_PREFIX} ${CXX}
-.else
-AOOCC= ${CC}
-AOOCXX= ${CXX}
-.endif
-
-CONFIGURE_ENV+= CC="${AOOCC}" CXX="${AOOCXX}" \
- PATH=${WRKSRC}/solenv/bin:$$PATH
+AOO_MAKE_ENV= ${MAKE_ENV:NCPPFLAGS=*:NCFLAGS=*:NCXXFLAGS=*}
GNU_CONFIGURE= yes
WRKSUBDIR= ${WRKDIR}/aoo-${AOOVERSION}
@@ -415,10 +403,8 @@ do-build:
fi ; \
fi ; \
cd ${WRKSRC}/instsetoo_native ; \
+ export ${AOO_MAKE_ENV} ; \
. ../${FREEBSD_ENV_SET} ; \
- if [ -n "${HOME}" -a ! -w "${HOME}" ]; then \
- export HOME=/tmp ; \
- fi ; \
build.pl --all -P$${numproc} -- -P$${dmproc}
do-install: