aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-10-15 17:27:41 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-10-15 17:27:41 +0000
commita8a746de0d7a6e16ba7b9b4aa5830ad4ed1405ee (patch)
treeaa8ab938c4d49dc8a094d6a83bf9da0f5206b518 /editors/openoffice-4/Makefile
parenta7924563a6c48f4fa59d7e2205eae3d9e76c9a71 (diff)
downloadports-a8a746de0d7a6e16ba7b9b4aa5830ad4ed1405ee.tar.gz
ports-a8a746de0d7a6e16ba7b9b4aa5830ad4ed1405ee.zip
Notes
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 8d195f698bcf..ee945d0bd067 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/sources \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -96,6 +96,21 @@ RUN_DEPENDS= \
${LOCALBASE}/share/fonts/Carlito/Carlito-Bold.ttf:x11-fonts/crosextrafonts-carlito-ttf \
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:x11-fonts/croscorefonts-fonts-ttf
+USES= autoreconf bison compiler:c++11-lib cpe \
+ desktop-file-utils \
+ gettext-runtime gmake iconv jpeg perl5 pkgconfig python:2.7 \
+ shared-mime-info ssl tar:bzip2
+USE_GL= gl glu
+USE_GNOME= gtk20 libxslt libidl glib20
+USE_JAVA= yes
+JAVA_BUILD= jdk
+JAVA_RUN= jdk
+JAVA_VENDOR= openjdk
+JAVA_VERSION= 1.6+
+USE_PERL5= build
+USE_XORG= ice sm x11 xau xaw xcomposite xcursor xdamage xext xfixes xi \
+ xinerama xrandr xrender xt
+
CONFLICTS_INSTALL= apache-openoffice-devel-*
AOOVERSION1= 4
@@ -119,20 +134,6 @@ XDGDIR= ${OOPATH}/share/xdg
XDGREL= ../../${INSTALLATION_BASEDIR}/openoffice${AOOVERSION1}/share/xdg
EXECBASE?= openoffice-${AOOSUFFIX}
-USES= autoreconf bison compiler:c++11-lib cpe \
- desktop-file-utils \
- gettext-runtime gmake iconv jpeg perl5 pkgconfig python:2.7 \
- shared-mime-info ssl tar:bzip2
-USE_GL= gl glu
-USE_GNOME= gtk20 libxslt libidl glib20
-USE_JAVA= yes
-JAVA_BUILD= jdk
-JAVA_RUN= jdk
-JAVA_VENDOR= openjdk
-JAVA_VERSION= 1.6+
-USE_PERL5= build
-USE_XORG= ice sm x11 xau xaw xcomposite xcursor xdamage xext xfixes xi \
- xinerama xrandr xrender xt
INSTALLS_ICONS= yes
WITHOUT_CPU_CFLAGS= true
CPE_PRODUCT= ${PORTNAME:S|apache-||}