aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2017-07-22 03:50:12 +0000
committerDon Lewis <truckman@FreeBSD.org>2017-07-22 03:50:12 +0000
commit5fa838568e4cc2a04bd02f459b19fff0e091c73a (patch)
tree220f18f86264e9c86c5187af1681e45bee2e48b9 /editors/openoffice-4
parent8c23dd7abdfab993b71b6f34bbb69436415c1707 (diff)
downloadports-5fa838568e4cc2a04bd02f459b19fff0e091c73a.tar.gz
ports-5fa838568e4cc2a04bd02f459b19fff0e091c73a.zip
Include <complex> instead of the obsolete <boost/tr1/complex.hpp>. The
upcoming boost 1.65 upgrade removes support for tr1. Sort ONLY_FOR_ARCHS to pacify portlint. No PORTREVISION bump since the code does not appear to change. PR: 220723
Notes
Notes: svn path=/head/; revision=446366
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile2
-rw-r--r--editors/openoffice-4/files/patch-scaddins_source_analysis_analysishelper.hxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 06f793532f16..23ed26c76105 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -115,7 +115,7 @@ XDGDIR= ${OOPATH}/share/xdg
XDGREL= ../../${INSTALLATION_BASEDIR}/openoffice${AOOVERSION1}/share/xdg
EXECBASE?= openoffice-${AOOSUFFIX}
-ONLY_FOR_ARCHS= i386 amd64 powerpc64
+ONLY_FOR_ARCHS= amd64 i386 powerpc64
USE_GL= gl glu
USE_GNOME= gtk20 libxslt libidl glib20
diff --git a/editors/openoffice-4/files/patch-scaddins_source_analysis_analysishelper.hxx b/editors/openoffice-4/files/patch-scaddins_source_analysis_analysishelper.hxx
new file mode 100644
index 000000000000..adef7313dad3
--- /dev/null
+++ b/editors/openoffice-4/files/patch-scaddins_source_analysis_analysishelper.hxx
@@ -0,0 +1,11 @@
+--- scaddins/source/analysis/analysishelper.hxx.orig 2014-09-19 18:07:44 UTC
++++ scaddins/source/analysis/analysishelper.hxx
+@@ -35,7 +35,7 @@
+
+ #include <math.h>
+
+-#include <boost/tr1/complex.hpp>
++#include <complex>
+ #ifndef double_complex
+ typedef std::complex<double> double_complex;
+ #endif