aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2013-08-27 03:36:50 +0000
committerMaho Nakata <maho@FreeBSD.org>2013-08-27 03:36:50 +0000
commitdbea6b19e01f977c96d1add8a4f27a726c894bdc (patch)
tree8961b578594add3e721501065f8c6bb1268b40cd /editors/openoffice-devel/Makefile
parentf339f50854250c98fe219e1267045c9f571aeecd (diff)
Notes
Diffstat (limited to 'editors/openoffice-devel/Makefile')
-rw-r--r--editors/openoffice-devel/Makefile63
1 files changed, 34 insertions, 29 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 0b23e5a31a78..b48008c7bb06 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,6 @@
PORTNAME= apache-openoffice
PORTVERSION= 4.0.${SVNREVISION}
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= editors java
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -25,39 +24,41 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
USE_GSTREAMER= yes
-#WITH_GCC= yes
-USE_GMAKE= yes
+#USE_GCC= 4.6+
USE_PYTHON= yes
USE_BZIP2= yes
-USES+= bison perl5
+USES+= bison perl5 gmake
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
+MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= GCONF GNOMEVFS
+OPTIONS_DEFINE= GCONF GNOMEVFS CCACHE
OPTIONS_DEFAULT=GCONF GNOMEVFS
GNOMEVFS_DESC= Enable GNOME Virtual File System
+CCACHE_DESC= Mimimize compile time of C/C++ programs
+
+.include "${.CURDIR}/files/Makefile.localized"
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
-.if !defined(WITHOUT_GCONF)
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
.else
CONFIGURE_ARGS+=--disable-gconf
.endif
-.if !defined(WITHOUT_GNOMEVFS)
+.if ${PORT_OPTIONS:MGNOMEVFS}
USE_GNOME+= gnomevfs2
.else
CONFIGURE_ARGS+=--disable-gnome-vfs
.endif
-.include <${FILESDIR}/Makefile.localized>
-
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
@@ -69,7 +70,7 @@ FREEBSD_ENV_SET= FreeBSDX86Env.Set.sh
OOOSRC= ApacheOpenOffice.r${SVNREVISION}${EXTRACT_SUFX}
EXTSRC= ApacheOpenOffice.ext_sources.r${SVNREVISION}${EXTRACT_SUFX}
OOODIR= openoffice4
-SVNREVISION= 1479753
+SVNREVISION= 1517723
INSTALLATION_BASEDIR?= openoffice-r${SVNREVISION}
EXECBASE?= openoffice-r${SVNREVISION}
DIST_SUBDIR= openoffice
@@ -96,7 +97,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hico
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
-.if defined(WITH_CCACHE)
+.if ${PORT_OPTIONS:MCCACHE) || defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
OOOCC= ${CCACHE_PREFIX} ${CC}
@@ -109,20 +110,20 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH \
CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- expat.6:${PORTSDIR}/textproc/expat2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
+ expat:${PORTSDIR}/textproc/expat2 \
+ jpeg:${PORTSDIR}/graphics/jpeg \
curl:${PORTSDIR}/ftp/curl \
- hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
- poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
- rdf.0:${PORTSDIR}/textproc/redland \
- textcat.0:${PORTSDIR}/textproc/libtextcat \
- freetype.9:${PORTSDIR}/print/freetype2 \
- apr-1.4:${PORTSDIR}/devel/apr1 \
- CoinMP.8:${PORTSDIR}/math/coinmp \
- serf-1.0:${PORTSDIR}/www/serf \
- freetype.9:${PORTSDIR}/print/freetype2 \
- textcat.0:${PORTSDIR}/textproc/libtextcat
+ hunspell-1.3:${PORTSDIR}/textproc/hunspell \
+ poppler-glib:${PORTSDIR}/graphics/poppler-glib \
+ rdf:${PORTSDIR}/textproc/redland \
+ textcat:${PORTSDIR}/textproc/libtextcat \
+ freetype:${PORTSDIR}/print/freetype2 \
+ apr-1:${PORTSDIR}/devel/apr1 \
+ CoinMP:${PORTSDIR}/math/coinmp \
+ serf-1:${PORTSDIR}/www/serf \
+ freetype:${PORTSDIR}/print/freetype2 \
+ textcat:${PORTSDIR}/textproc/libtextcat
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
@@ -146,7 +147,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
-WRKSRC?= ${WRKDIR}/ooo/main
+WRKSRC?= ${WRKDIR}/aoo/main
BASH?= ${PREFIX}/bin/bash
SUB_FILES= pkg-message
SUB_LIST= EXECBASE=${EXECBASE} OOOTAG=${OOOTAG} OOODIR=${OOODIR}
@@ -206,6 +207,8 @@ CONFIGURE_ARGS+= --enable-verbose \
--with-system-serf
# --with-system-jpeg
# --enable-pdfimport
+# --without-stlport --disable-mozilla \
+# --with-system-graphite \
#OOOEXTENSIONS+= minimizer/presentation-minimizer.oxt
#OOOEXTENSIONS+= presenter/presenter-screen.oxt
@@ -237,8 +240,10 @@ pre-everything::
post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
# @${MKDIR} ${WRKSRC}/../ext_sources
-# @${MV} ${WRKDIR}/ooo/ext_sources/* ${WRKSRC}/../ext_sources/
+# @${MV} ${WRKDIR}/aoo/ext_sources/* ${WRKSRC}/../ext_sources/
# @${RM} -rf ${WRKSRC}/l10n
+ @${MKDIR} ${WRKSRC}/../ext_sources
+ @${RM} -rf ${WRKSRC}/l10n
post-patch:
.if defined (USE_GCC)
@@ -253,9 +258,9 @@ pre-configure:
@${LN} -sf ${UNZIP_CMD} ${WRKSRC}/solenv/bin/unzip
do-build:
- @cd ${WRKDIR}/ooo ; ${PRINTF} "[repositories]\n" > source_config
- @cd ${WRKDIR}/ooo ; ${PRINTF} "main=active\n" >> source_config
- @cd ${WRKDIR}/ooo ; ${PRINTF} "extras=active\n" >> source_config
+ @cd ${WRKDIR}/aoo ; ${PRINTF} "[repositories]\n" > source_config
+ @cd ${WRKDIR}/aoo ; ${PRINTF} "main=active\n" >> source_config
+ @cd ${WRKDIR}/aoo ; ${PRINTF} "extras=active\n" >> source_config
@cd ${WRKSRC} ; ./bootstrap
@cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native/util ; build.pl --all -P${MAKE_JOBS_NUMBER} -- -P${MAKE_JOBS_NUMBER}"