aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-devel
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-02-25 05:55:10 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-02-25 05:55:10 +0000
commita26ed809b61a9e0c3b564326c522fe9b68c2ce46 (patch)
tree8a47313f8c4833cb656bfdd261d5f416af3cb6e4 /editors/openoffice-devel
parent444381ff12d2e74c94e73d1418ad3b37574045ec (diff)
downloadports-a26ed809b61a9e0c3b564326c522fe9b68c2ce46.tar.gz
ports-a26ed809b61a9e0c3b564326c522fe9b68c2ce46.zip
Notes
Diffstat (limited to 'editors/openoffice-devel')
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--editors/openoffice-devel/files/patch-set_soenv.in79
2 files changed, 80 insertions, 1 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 8a8d5c5017bd..012f472652ec 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -280,7 +280,7 @@ do-build:
cd ${WRKSUBDIR} ; ${PRINTF} "main=active\n" >> source_config
cd ${WRKSUBDIR} ; ${PRINTF} "extras=active\n" >> source_config
cd ${WRKSRC} ; ./bootstrap
- cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native/util ; build.pl --all -P${MAKE_JOBS_NUMBER} -- -P${MAKE_JOBS_NUMBER}"
+ cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C LC_TIME=it_IT.ISO8859-15" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native/util ; build.pl --all -P${MAKE_JOBS_NUMBER} -- -P${MAKE_JOBS_NUMBER}"
do-install:
cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/Apache_OpenOffice/archive/install/${LOCALIZED_LANG}/ ; ${LS} *.tar.?z > ${WRKDIR}/INSTALLFILES
diff --git a/editors/openoffice-devel/files/patch-set_soenv.in b/editors/openoffice-devel/files/patch-set_soenv.in
new file mode 100644
index 000000000000..e03a7829946d
--- /dev/null
+++ b/editors/openoffice-devel/files/patch-set_soenv.in
@@ -0,0 +1,79 @@
+--- set_soenv.in.orig 2015-01-17 23:35:07.000000000 -0800
++++ set_soenv.in 2015-02-23 16:02:44.000000000 -0800
+@@ -359,7 +359,7 @@
+ elsif ( $platform =~ m/freebsd/ )
+ { $BIG_SVX = "TRUE";
+ $COM = "GCC";
+- $COMPATH = '@COMPATH@';
++ $COMPATH = '@COMPATH@' . '/bin';
+ $CVER = "C300";
+ $GUI = "UNX";
+ $GUIBASE = "unx";
+@@ -2617,26 +2617,37 @@
+ my @originalPairs = @_;
+ my @pairs = @originalPairs;
+ my @Path = split /$ps/, $oldPath;
++ my @buildPath;
++ my @sysPath;
++ my $elem;
++
++ for $elem (@Path) {
++ if ($elem eq '.' || $elem =~ m'^$SOLARENV/' ||
++ $elem =~ m'/solenv/') {
++ push @buildPath, $elem;
++ } else {
++ push @sysPath, $elem;
++ }
++ }
+
+ while (@pairs) {
+ my $path = shift @pairs;
+ my $cmd = shift @pairs;
+ my $to_append = 1;
+- my $elem;
+
+ if (! -x "$path/$cmd") {
+ AddWarning ("Missing executable $path/$cmd\n");
+ }
+
+- for $elem (@Path) {
++ for $elem (@sysPath) {
+ if ($elem eq $path) {
+ # print "Hit duplicate path in path; break\n";
+ $to_append = 0;
+ last;
+ }
+- if (-f "$elem/$cmd") {
++ if (-f "$elem/$cmd" && ! -l "$elem/$cmd") {
+ # print "Element already in path ...\n";
+- unshift @Path, $path;
++ unshift @sysPath, $path;
+ $to_append = 0;
+ last;
+ } else {
+@@ -2644,7 +2655,7 @@
+ }
+ }
+ if ($to_append) {
+- push @Path, $path;
++ push @sysPath, $path;
+ }
+ }
+
+@@ -2654,14 +2665,14 @@
+ my $cmd = shift @pairs;
+ my $realpath;
+
+- $realpath = PathLookup ($cmd, @Path);
++ $realpath = PathLookup ($cmd, @sysPath);
+ if (!($realpath eq $path)) {
+ AddWarning ("Path conflict for executables " .
+ "$path/$cmd against $realpath");
+ }
+ }
+
+- return join $ps, CleanupPath (@Path);
++ return join $ps, @buildPath, CleanupPath (@sysPath);
+ }
+
+ #------------------------------------------------------------