aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-1.1-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-12-13 10:35:59 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-12-13 10:35:59 +0000
commitc4cdac2deb22e1a421ecba3986f57df337eef205 (patch)
tree5c75dc1991d8d3404a0c506da300e00ee72ec0d5 /editors/openoffice.org-1.1-devel
parent1a8899473b552d22700f3a6019bace8e5b618472 (diff)
downloadports-c4cdac2deb22e1a421ecba3986f57df337eef205.tar.gz
ports-c4cdac2deb22e1a421ecba3986f57df337eef205.zip
Notes
Diffstat (limited to 'editors/openoffice.org-1.1-devel')
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile32
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-jvmaccess+source+sunversion.cxx11
2 files changed, 31 insertions, 12 deletions
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 8132d6d4eec0..de57965d197b 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -50,10 +50,7 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-
.if ${OSVERSION} >= 700042
-BROKEN= does not compile with GCC 4.2; consider upgrading to editors/openoffice.org-2
-.else
BROKEN= fails to install; consider upgrading to editors/openoffice.org-2
.endif
@@ -101,16 +98,20 @@ PKGNAMEPREFIX= ${LANG_PKGNAME}-
PKGNAMESUFFIX?= -${LANG_SUFFIX}
.endif
-BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
-# FIXME (correctly add ccache before gcc and g++)
+USE_GCC= 3.3 #3.3 is the best
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
-CC= ccache gcc32
-CXX= ccache g++32
+CCACHE_PREFIX= ccache
+OOOCC= ${CCACHE_PREFIX} ${CC}
+OOOCXX= ${CCACHE_PREFIX} ${CXX}
.else
-CC= gcc32
-CXX= g++32
+OOOCC= ${CC}
+OOOCXX= ${CXX}
.endif
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
@@ -128,7 +129,7 @@ TCSH?= /bin/tcsh
PKGMESSAGE= ${WRKDIR}/pkg-message
NUMOFPROCESSES?= 1
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --enable-pasf #--enable-crashdump --enable-symbols=SMALL #gcc3.2.3 is broken with -g1
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --enable-pasf --enable-crashdump --enable-symbols=SMALL #gcc3.2.3 is broken with -g1
.include <${FILESDIR}/Makefile.knobs>
@@ -174,6 +175,13 @@ post-extract:
@cd ${WRKSRC} ; ${MV} moz moz.runtime ; ${MV} moz.old moz
.endif
+pre-configure:
+#Workaround for moz project, it uses gcc directly.
+ @${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/gcc
+ @${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/cc
+ @${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/g++
+ @${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/c++
+
do-build:
@cd ${WRKSRC} ; ./bootstrap
.if !defined(WITHOUT_MOZILLA)
@@ -183,9 +191,9 @@ do-build:
@${CP} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/solver/${CODELINE}/unxfbsd.pro/pck
# PR:84786
.if (${NUMOFPROCESSES}>1)
- @cd ${WRKSRC} ; ${SETENV} "LC_ALL=C" "LANG=C" ${TCSH} -c "source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
+ @cd ${WRKSRC} ; ${SETENV} "LC_ALL=C" "LANG=C" ${TCSH} -c "source FreeBSDEnv.Set ; setenv TMP ${WRKSRC} ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
.else
- @cd ${WRKSRC} ; ${SETENV} "LC_ALL=C" "LANG=C" ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
+ @cd ${WRKSRC} ; ${SETENV} "LC_ALL=C" "LANG=C" ${TCSH} -c "source FreeBSDEnv.Set ; setenv TMP ${WRKSRC} ; dmake"
.endif
do-install:
diff --git a/editors/openoffice.org-1.1-devel/files/patch-jvmaccess+source+sunversion.cxx b/editors/openoffice.org-1.1-devel/files/patch-jvmaccess+source+sunversion.cxx
index b334fb1339a0..bbed543f1021 100644
--- a/editors/openoffice.org-1.1-devel/files/patch-jvmaccess+source+sunversion.cxx
+++ b/editors/openoffice.org-1.1-devel/files/patch-jvmaccess+source+sunversion.cxx
@@ -10,8 +10,19 @@ it is not a good habit. in this patch we eleminate this.
in the system. We add 100 as micro version number, so that we treat FreeBSD's version of
java 1.4.1-p10 for example to 1.4.1_110.
+3. Java version of 1.5.0_13-p7 will be treated as 1.5.0_13. -p part will be ignored.
+
--- jvmaccess/source/sunversion.cxx Thu Jun 16 21:45:26 2005
+++ jvmaccess/source/sunversion.cxx Sat Oct 22 16:42:01 2005
+@@ -193,7 +193,7 @@
+ pCur ++;
+ // nPartPos ++;
+ }
+- else if (nUpdatePart == 0 && (pCur == pEnd || isalpha(*pCur)))
++ else if (nUpdatePart == 0 && (pCur == pEnd || isalpha(*pCur) || (*pCur)=='-' ))
+ {
+ int len = pCur - pLast;
+ if (len >= 127)
@@ -246,30 +247,22 @@
m_preRelease = Rel_RC2;
#if defined FREEBSD || defined NETBSD