aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2-RC
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-11-25 03:19:22 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-11-25 03:19:22 +0000
commit1db390d2575cc4f3e5a3f3491bc4911fe4f33546 (patch)
tree05896a5459fadc1a8f8b2d225aa9144ee9e20b9e /editors/openoffice.org-2-RC
parent1599d57f3cceaa4687eed902f725cf314088c396 (diff)
downloadports-1db390d2575cc4f3e5a3f3491bc4911fe4f33546.tar.gz
ports-1db390d2575cc4f3e5a3f3491bc4911fe4f33546.zip
Notes
Diffstat (limited to 'editors/openoffice.org-2-RC')
-rw-r--r--editors/openoffice.org-2-RC/Makefile22
-rw-r--r--editors/openoffice.org-2-RC/distinfo6
-rw-r--r--editors/openoffice.org-2-RC/files/Makefile.knobs18
-rw-r--r--editors/openoffice.org-2-RC/files/Makefile.localized47
-rw-r--r--editors/openoffice.org-2-RC/files/openoffice.org-wrapper4
-rw-r--r--editors/openoffice.org-2-RC/files/pkg-message.in4
6 files changed, 76 insertions, 25 deletions
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index c52719589d8e..a199d3c50226 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -56,7 +56,7 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
GCC_TARGET= x86_64-portbld-freebsd${OSREL}
@@ -71,11 +71,10 @@ IGNORE= install lang/perl5.8 then try again
.endif
CODELINE= 680
-RELEASE_NR= 2.1
-MILESTONE?= 2
+MILESTONE?= 5
OOOTAG?= OOE680_m${MILESTONE}
OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
-SNAPDATE= 20061107
+SNAPDATE= 20061123
INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
@@ -237,13 +236,12 @@ post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
@${CP} ${FILESDIR}/openoffice.org-wrapper ${WRKDIR}/
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
- -e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
${WRKDIR}/openoffice.org-wrapper
@${INSTALL_SCRIPT} ${WRKDIR}/openoffice.org-wrapper \
${PREFIX}/bin/${EXECBASE}
- @${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/openoffice.org
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-sbase
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-scalc
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-sdraw
@@ -252,11 +250,11 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
- @${PRINTF} "bin/openoffice.org\n" > ${TMPPLIST}
- @${REINPLACE_CMD} -e 's#${RELEASE_NR}#${OOOVERSION}#g' \
- -e '/^Exec/s/printeradmin/spadmin/' \
+.if defined(WITH_MENU)
+ @${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
+ @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
${PREFIX}/share/applications/${EXECBASE}
@${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@@ -264,8 +262,8 @@ post-install:
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
${CP} ${ICONS}/hicolor/$${dir}/apps/$${app}.png \
- ${PREFIX}/share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png ; \
- ${PRINTF} "share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png\n" >> ${TMPPLIST} ; \
+ ${PREFIX}/share/icons/hicolor/$${dir}/apps/openofficeorg-21-$${app}.png ; \
+ ${PRINTF} "share/icons/hicolor/$${dir}/apps/openofficeorg-21-$${app}.png\n" >> ${TMPPLIST} ; \
fi \
done ; \
for file in `cd ${ICONS}/hicolor/$${dir}/mimetypes; ls *.png`; do \
@@ -274,6 +272,7 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
+.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@@ -285,7 +284,6 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
- -e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-2-RC/distinfo b/editors/openoffice.org-2-RC/distinfo
index ba7a423d1b3e..7fb178ec3a29 100644
--- a/editors/openoffice.org-2-RC/distinfo
+++ b/editors/openoffice.org-2-RC/distinfo
@@ -1,6 +1,6 @@
-MD5 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 20b81ec782549c2d21bfeb8b7ec2026f
-SHA256 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = e2b6b520f014e0773dd794d863bcfa04dbf11ed46659c7a28b5f55d32ea02a44
-SIZE (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 270751002
+MD5 (openoffice.org2.0/OOo_OOE680_m5_source.tar.bz2) = cab43fac0156eeb958844b3e2a5c9846
+SHA256 (openoffice.org2.0/OOo_OOE680_m5_source.tar.bz2) = 37779edb6bfd6e1b40f0d77c849e1c2242419603f5d7397966472eb32564dd10
+SIZE (openoffice.org2.0/OOo_OOE680_m5_source.tar.bz2) = 272208053
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
diff --git a/editors/openoffice.org-2-RC/files/Makefile.knobs b/editors/openoffice.org-2-RC/files/Makefile.knobs
index 87843d8a66bc..33fa59095e15 100644
--- a/editors/openoffice.org-2-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-2-RC/files/Makefile.knobs
@@ -99,12 +99,13 @@ pre-fetch:
@${ECHO} "You can select the language for OOo by making it with:"
@${ECHO} "make LOCALIZED_LANG=xx"
@${ECHO} "while xx can be one of the following"
- @${ECHO} "af ar be-BY bg br bn bn-BD bn-IN bs ca cs cy da de el"
- @${ECHO} "en-GB en-US en-ZA eo es et eu fa fi fr ga gl gu-IN he"
- @${ECHO} "hi-IN hr hu it ja km kn-IN ko lo lt lv mk ms ne nb nl"
- @${ECHO} "nn nr ns pa-IN pl pt pt-BR ru rw sk sl sh-YU sr-CS ss"
- @${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
- @${ECHO} "zh-TW zu"
+ @${ECHO} "af ar as-IN be-BY bg br bn bn-BD bn-IN bs ca cs cy da"
+ @${ECHO} "de el en-GB en-US en-ZA eo es et eu fa fi fr ga gl"
+ @${ECHO} "gu-IN he hi-IN hr hu it ja km kn-IN ko ku lo lt lv mk"
+ @${ECHO} "ms ml-IN mr-IN ne nb nl nn nr ns or-IN pa-IN pl pt"
+ @${ECHO} "pt-BR ru rw sk sl sh-YU sr-CS ss st sv sw sw-TZ sx"
+ @${ECHO} "te-IN ti-ER ta-IN th tn tr ts tg ur-IN uk ve vi xh"
+ @${ECHO} "zh-CN zh-TW zu"
@${ECHO} "Default: en-US"
.endif
.if !defined(WITH_GNUGCJ)
@@ -132,6 +133,11 @@ pre-fetch:
@${ECHO} "You can compile OOo with evolution2 support by"
@${ECHO} "make -DWITH_EVOLUTION2"
.endif
+.if !defined(WITH_MENU)
+ @${ECHO}
+ @${ECHO} "You can install OOo with menu items by"
+ @${ECHO} "make -DWITH_MENU"
+.endif
@${ECHO}
@${ECHO} "NOTICE:"
@${ECHO}
diff --git a/editors/openoffice.org-2-RC/files/Makefile.localized b/editors/openoffice.org-2-RC/files/Makefile.localized
index 410647cd4dff..4bcfcf78d781 100644
--- a/editors/openoffice.org-2-RC/files/Makefile.localized
+++ b/editors/openoffice.org-2-RC/files/Makefile.localized
@@ -14,6 +14,11 @@ CATEGORIES+= arabic
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "as-IN"
+LANG_PKGNAME= as
+LANG_SUFFIX= IN
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "be-BY"
LANG_PKGNAME= be
LANG_SUFFIX= BY
@@ -170,6 +175,10 @@ CATEGORIES+= korean
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "ku"
+LANG_PKGNAME= ${LOCALIZED_LANG}
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "lo"
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
@@ -190,6 +199,16 @@ LANG_PKGNAME= ${LOCALIZED_LANG}
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "ml-IN"
+LANG_PKGNAME= ml
+LANG_SUFFIX= IN
+.endif
+################################################################
+.if ${LOCALIZED_LANG} == "mr-IN"
+LANG_PKGNAME= mr
+LANG_SUFFIX= IN
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "ne"
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
@@ -214,6 +233,11 @@ LANG_PKGNAME= ${LOCALIZED_LANG}
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "or-IN"
+LANG_PKGNAME= or
+LANG_SUFFIX= IN
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "pa-IN"
LANG_PKGNAME= pa
LANG_SUFFIX= IN
@@ -295,6 +319,16 @@ LANG_PKGNAME= ta
LANG_SUFFIX= IN
.endif
################################################################
+.if ${LOCALIZED_LANG} == "te-IN"
+LANG_PKGNAME= te
+LANG_SUFFIX= IN
+.endif
+################################################################
+.if ${LOCALIZED_LANG} == "ti-IN"
+LANG_PKGNAME= ti
+LANG_SUFFIX= IN
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "th"
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
@@ -311,6 +345,19 @@ LANG_PKGNAME= ${LOCALIZED_LANG}
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "tg"
+LANG_PKGNAME= ${LOCALIZED_LANG}
+.endif
+################################################################
+.if ${LOCALIZED_LANG} == "ur-IN"
+LANG_PKGNAME= ur
+LANG_SUFFIX= IN
+.endif
+################################################################
+.if ${LOCALIZED_LANG} == "uk"
+LANG_PKGNAME= ${LOCALIZED_LANG}
+.endif
+################################################################
.if ${LOCALIZED_LANG} == "ve"
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
diff --git a/editors/openoffice.org-2-RC/files/openoffice.org-wrapper b/editors/openoffice.org-2-RC/files/openoffice.org-wrapper
index 16f9d27ced5b..b1b50502943e 100644
--- a/editors/openoffice.org-2-RC/files/openoffice.org-wrapper
+++ b/editors/openoffice.org-2-RC/files/openoffice.org-wrapper
@@ -1,9 +1,9 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/editors/openoffice.org-2-RC/files/Attic/openoffice.org-wrapper,v 1.3 2006-04-20 21:56:12 maho Exp $
+# $FreeBSD: /tmp/pcvs/ports/editors/openoffice.org-2-RC/files/Attic/openoffice.org-wrapper,v 1.4 2006-11-25 03:19:22 maho Exp $
oopath=%%PREFIX%%/%%INSTALLATION_BASEDIR%%/program/
-program=`echo $0 | sed -e 's|.*-%%OOOVERSION%%-||'`
+program=`echo $0 | sed -e 's|.*-%%OOOTAG%%-||'`
case $program in
$0)
diff --git a/editors/openoffice.org-2-RC/files/pkg-message.in b/editors/openoffice.org-2-RC/files/pkg-message.in
index 48e87f301db7..03a7ca76151e 100644
--- a/editors/openoffice.org-2-RC/files/pkg-message.in
+++ b/editors/openoffice.org-2-RC/files/pkg-message.in
@@ -1,9 +1,9 @@
-OpenOffice.org Build %%RELEASE_NR%% Personal Install How-To
+OpenOffice.org Build %%OOOTAG%% Personal Install How-To
Written by: Martin Blapp <mbr@freebsd.org>
and Maho Nakata <maho@FreeBSD.org>
-OpenOffice.org %%RELEASE_NR%% will soon been installed in
+OpenOffice.org %%OOOTAG%% will soon been installed in
%%PREFIX%%/%%EXECBASE%%
1. User installation