aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-05-26 23:48:23 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-05-26 23:48:23 +0000
commit633ddb06d1ee93faa7ac62a5ddade3714e38206e (patch)
tree0785cd617740ab7142af65f1be1c651b788ac3b3 /editors/openoffice.org-2-devel/Makefile
parentb5ec6accf047581723bdb4602470ea79ba3758a9 (diff)
WITH_CCACHE works again.
Notes
Notes: svn path=/head/; revision=191947
Diffstat (limited to 'editors/openoffice.org-2-devel/Makefile')
-rw-r--r--editors/openoffice.org-2-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 72f808b2d022..eb6a57ce7964 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -99,9 +99,13 @@ USE_GCC= 4.2
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
-CC:= ${CCACHE_PREFIX} ${CC}
-CXX:= ${CCACHE_PREFIX} ${CXX}
+OOOCC= ${CCACHE_PREFIX} ${CC}
+OOOCXX= ${CCACHE_PREFIX} ${CXX}
+.else
+OOOCC= ${CC}
+OOOCXX= ${CXX}
.endif
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
@@ -126,7 +130,6 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--enable-crashdump=yes \
--enable-symbols=SMALL
-
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
.endif