aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2.0-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-06-03 11:39:21 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-06-03 11:39:21 +0000
commit9cb79afc33e141dca520eb05b3d24b4fb8269ba8 (patch)
tree72647b094beee71c40a5b7eb9095f199b2fd50c7 /editors/openoffice.org-2.0-devel
parent7ebe8d6d9cb4ab697d3c74172558151fdcb6c122 (diff)
downloadports-9cb79afc33e141dca520eb05b3d24b4fb8269ba8.tar.gz
ports-9cb79afc33e141dca520eb05b3d24b4fb8269ba8.zip
Notes
Diffstat (limited to 'editors/openoffice.org-2.0-devel')
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile78
-rw-r--r--editors/openoffice.org-2.0-devel/files/patch-i6606416
-rw-r--r--editors/openoffice.org-2.0-devel/files/patch-i6606529
3 files changed, 86 insertions, 37 deletions
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index b72fe2475fef..d1f73d9853f9 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -47,17 +47,11 @@ USE_PERL5= yes
USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= amd64 i386
-
-.if ${MACHINE_ARCH} == amd64
-BROKEN= "Work in progress"
-.endif
-
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
-.if ${MACHINE_ARCH} == amd64
+.if ${MACHINE_ARCH} == amd64 # cannot use ARCH
JAVA_VENDOR= bsdjava
.else
JAVA_VENDOR= freebsd bsdjava
@@ -67,11 +61,17 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-.if ${MACHINE_ARCH} == amd64
+ONLY_FOR_ARCHS= amd64 i386
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
+
+.if ${ARCH} == amd64
GCC_TARGET= x86_64-portbld-freebsd${OSREL}
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
.else
-GCC_TARGET= ${MACHINE_ARCH}-portbld-freebsd${OSREL}
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
.endif
@@ -88,7 +88,7 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
-.if ${MACHINE_ARCH} == amd64
+.if ${ARCH} == amd64
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
@@ -105,34 +105,36 @@ PKGNAMESUFFIX?= -${LANG_SUFFIX}
.if defined(WITH_GNUGCJ)
#this wired part must be rewritten
-GCCVER=4.1.1
-BUILD_DEPENDS+= ${PREFIX}/lib/gcc/${MACHINE_ARCH}-portbld-freebsd${OSREL}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
-BUILD_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
-RUN_DEPENDS+= ${PREFIX}/lib/gcc/${MACHINE_ARCH}-portbld-freebsd${OSREL}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
+GCCVER=4.1.2
+BUILD_DEPENDS+= ${PREFIX}/lib/gcc/${GCC_TARGET}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
+BUILD_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
+RUN_DEPENDS+= ${PREFIX}/lib/gcc/${GCC_TARGET}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
+.else
+.if ${ARCH} == amd64
+GCCVER=4.1.2
+BUILD_DEPENDS+= gcc41:${PORTSDIR}/lang/gcc41
.else
-BUILD_DEPENDS+= gcc-ooo:${PORTSDIR}/lang/gcc-ooo
+GCCVER=3.4.1
+BUILD_DEPENDS+= gcc-ooo:${PORTSDIR}/lang/gcc-ooo
+.endif
.endif
-# FIXME (correctly add ccache before gcc and g++)
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
-.if defined(WITH_GNUGCJ)
-CC= ccache gcc41
-CXX= ccache g++41
-.else
-CC= ccache gcc-ooo
-CXX= ccache g++-ooo
-.endif #WITH_GNUGCJ
-.endif #WITH_CCACHE
-.if !defined(WITH_CCACHE)
-.if defined(WITH_GNUGCJ)
-CC= gcc41
-CXX= g++41
+CCACHE_PREFIX= ccache
.else
-CC= gcc-ooo
-CXX= g++-ooo
-.endif #WITH_GNUGCJ
-.endif #!WITH_CCACHE
+CCACHE_PREFIX=
+.endif
+.if (${GCCVER} == 4.1.2)
+CC= gcc41
+CXX= g++41
+.endif
+.if (${GCCVER} == 3.4.1)
+CC= gcc-ooo
+CXX= g++-ooo
+.endif
+CC:= ${CCACHE_PREFIX} ${CC}
+CXX:= ${CCACHE_PREFIX} ${CXX}
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
@@ -141,15 +143,13 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITH_GNUGCJ)
-BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
-.else
+.if defined(WITH_GNUGCJ)
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
-.endif
-.if defined(WITH_GNUGCJ)
ANT_DISTFILE= apache-ant-${ANT_VERSION}-bin.tar.bz2
ANT_VERSION= 1.6.5
+.else
+BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
@@ -170,6 +170,10 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
#workarounds
CONFIGURE_ARGS+= --with-system-xrender-headers=yes #i62713#
CONFIGURE_ARGS+= --with-system-freetype #link error with internal one
+.if (${GCCVER} == 4.1.1)
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
+.endif
.if (${OSVERSION} <= 492000)
EXTRA_PATCHES+= ${FILESDIR}/fbsd4-workaroundpatch
.endif
diff --git a/editors/openoffice.org-2.0-devel/files/patch-i66064 b/editors/openoffice.org-2.0-devel/files/patch-i66064
new file mode 100644
index 000000000000..10607d33c6df
--- /dev/null
+++ b/editors/openoffice.org-2.0-devel/files/patch-i66064
@@ -0,0 +1,16 @@
+Index: unx/source/gdi/salprnpsp.cxx
+===================================================================
+RCS file: /cvs/gsl/vcl/unx/source/gdi/salprnpsp.cxx,v
+retrieving revision 1.40
+diff -u -r1.40 salprnpsp.cxx
+--- vcl/unx/source/gdi/salprnpsp.cxx 22 Mar 2006 09:46:43 -0000 1.40
++++ vcl/unx/source/gdi/salprnpsp.cxx 27 May 2006 00:31:26 -0000
+@@ -101,6 +101,8 @@
+ // NETBSD has no RTLD_GLOBAL
+ #ifndef RTLD_GLOBAL
+ #define DLOPEN_MODE (RTLD_LAZY)
++#elif defined(FREEBSD)
++#define DLOPEN_MODE (RTLD_NOW | RTLD_GLOBAL)
+ #else
+ #define DLOPEN_MODE (RTLD_GLOBAL | RTLD_LAZY)
+ #endif
diff --git a/editors/openoffice.org-2.0-devel/files/patch-i66065 b/editors/openoffice.org-2.0-devel/files/patch-i66065
new file mode 100644
index 000000000000..9d97beea1ca3
--- /dev/null
+++ b/editors/openoffice.org-2.0-devel/files/patch-i66065
@@ -0,0 +1,29 @@
+--- tools/inc/inetdef.hxx.orig Fri Sep 9 09:42:51 2005
++++ tools/inc/inetdef.hxx Thu May 25 18:31:02 2006
+@@ -65,7 +65,9 @@
+ #elif defined LINUX && defined X86
+ #define TOOLS_INETDEF_OS "Linux"
+ #elif defined FREEBSD && defined X86
+-#define TOOLS_INETDEF_OS "FreeBSD"
++#define TOOLS_INETDEF_OS "FreeBSD/i386"
++#elif defined FREEBSD && defined X86_64
++#define TOOLS_INETDEF_OS "FreeBSD/amd64"
+ #elif defined SINIX
+ #define TOOLS_INETDEF_OS "SINIX"
+ #elif defined IRIX
+--- tools/inc/solar.h.orig Wed Apr 26 16:42:59 2006
++++ tools/inc/solar.h Thu May 25 18:37:19 2006
+@@ -397,9 +397,12 @@
+ #elif defined LINUX && defined __x86_64__
+ #define __DLLEXTENSION "lx.so"
+ #define SYSTEM_ID SYSTEM_UNXLNXX
+-#elif defined FREEBSD
++#elif defined FREEBSD && defined X86
+ #define __DLLEXTENSION "fi.so"
+ #define SYSTEM_ID SYSTEM_UNXFBSDI
++#elif defined FREEBSD && defined X86_64
++ #define __DLLEXTENSION "fx.so"
++ #define SYSTEM_ID SYSTEM_UNXFBSDX
+ #elif defined IRIX
+ #define __DLLEXTENSION "im.so"
+ #define SYSTEM_ID SYSTEM_UNXIRXM