aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-04-01 00:48:45 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-04-01 00:48:45 +0000
commit947b41afd95be7e8a3f272b443a66a41797ea215 (patch)
treea902586069b6f359ba7466527ba7189fd056b648 /editors/openoffice.org-2/Makefile
parent796d26c5517bb4343ed2751067585edd75404633 (diff)
downloadports-947b41afd95be7e8a3f272b443a66a41797ea215.tar.gz
ports-947b41afd95be7e8a3f272b443a66a41797ea215.zip
Notes
Diffstat (limited to 'editors/openoffice.org-2/Makefile')
-rw-r--r--editors/openoffice.org-2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 4170cdc6ffa5..412f3748cb4a 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -107,12 +107,13 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bash:${PORTSDIR}/shells/bash \
imake:${PORTSDIR}/devel/imake \
+ ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
ant:${PORTSDIR}/devel/apache-ant
.if !defined(WITH_GPC)
@@ -177,6 +178,11 @@ post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${MOZILLA_SOURCE} ${WRKSRC}/moz/download
.endif
+pre-configure:
+#Workaround for gperf. #i85469#
+ @${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
+
do-build:
@cd ${WRKSRC} ; ./bootstrap
# PR:84786 #i53289#