aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-01-07 21:48:32 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-01-07 21:48:32 +0000
commitf7e3937eb86df083f2fe72e5d3623dba73130ee4 (patch)
tree1f79fdbdfc9337fbd63730a2693336b93800b420 /editors/openoffice.org-2
parent4a40127f270c1a63efffa47bcfda860fb221a3ac (diff)
downloadports-f7e3937eb86df083f2fe72e5d3623dba73130ee4.tar.gz
ports-f7e3937eb86df083f2fe72e5d3623dba73130ee4.zip
Notes
Diffstat (limited to 'editors/openoffice.org-2')
-rw-r--r--editors/openoffice.org-2/Makefile11
-rw-r--r--editors/openoffice.org-2/files/patch-i8502769
2 files changed, 77 insertions, 3 deletions
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 9d9340e1c0ee..14b568ac456b 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= ${OOOVERSION}
+PORTREVISION?= 1
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
http://openoffice.lunarshells.com/sources/ \
@@ -52,9 +53,9 @@ WITHOUT_CPU_CFLAGS= true
.include <bsd.port.pre.mk>
+USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
-USE_JAVA= yes
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
@@ -101,6 +102,10 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_GCC= 4.2
+#following part should sync with ports/Mk/bsd.gcc.mk
+.if (${OSVERSION} >= 700042)
+CONFIGURE_ARGS+= --with-system-stdlibs
+.endif
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@@ -190,9 +195,9 @@ do-build:
@cd ${WRKSRC} ; ./bootstrap
# PR:84786 #i53289#
.if (${NUMOFPROCESSES}>1)
- @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native ; build.pl -P${NUMOFPROCESSES} --all"
+ @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; setenv TMP ${WRKSRC} ; cd instsetoo_native ; build.pl -P${NUMOFPROCESSES} --all"
.else
- @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; dmake"
+ @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; setenv TMP ${WRKSRC} ; dmake"
.endif
.if ${LOCALIZED_LANG} == "all"
@${MAKE} languagepack
diff --git a/editors/openoffice.org-2/files/patch-i85027 b/editors/openoffice.org-2/files/patch-i85027
new file mode 100644
index 000000000000..7afbd7d17349
--- /dev/null
+++ b/editors/openoffice.org-2/files/patch-i85027
@@ -0,0 +1,69 @@
+Index: scp2/source/ooo/file_library_ooo.scp
+===================================================================
+RCS file: /cvs/installation/scp2/source/ooo/file_library_ooo.scp,v
+retrieving revision 1.269
+diff -u -r1.269 file_library_ooo.scp
+--- scp2/source/ooo/file_library_ooo.scp 12 Dec 2007 13:29:11 -0000 1.269
++++ scp2/source/ooo/file_library_ooo.scp 6 Jan 2008 04:19:50 -0000
+@@ -979,7 +979,7 @@
+
+ STD_UNO_LIB_FILE_PATCH( gid_File_Lib_Fwm , fwm)
+
+-#if ! (defined (FREEBSD) || defined (NETBSD) || defined(MACOSX) || defined(SYSTEM_STDLIBS) || defined(WNT))
++#if ! (defined (NETBSD) || defined(MACOSX) || defined(SYSTEM_STDLIBS) || defined(WNT))
+ #if defined( _gcc3 )
+
+ File gid_File_Lib_Gcc
+@@ -993,7 +993,7 @@
+
+ #endif
+
+-#if ! (defined (FREEBSD) || defined (NETBSD) || defined(MACOSX) || defined(SYSTEM_STDLIBS) || defined(WNT))
++#if ! (defined (NETBSD) || defined(MACOSX) || defined(SYSTEM_STDLIBS) || defined(WNT))
+ #if defined( _gcc3 )
+
+ File gid_File_Lib_Stdc
+
+
+-----------------
+Strange behaviour of stock gcc of FreeBSD 7.
+
+# gcc -print-file-name=libgcc_s.so
+/usr/lib/libgcc_s.so
+# gcc -print-file-name=libgcc_s.so.1
+libgcc_s.so.1
+. This sould be
+# gcc -print-file-name=libgcc_s.so.1
+/lib/libgcc_s.so.1
+
+However gcc42 from ports behaves correctly;
+and
+# gcc42 -print-file-name=libgcc_s.so.1
+/usr/local/lib/gcc-4.2.3/gcc/i386-portbld-freebsd7.0/4.2.3/../../../libgcc_s.so.1
+# gcc42 -print-file-name=libgcc_s.so
+/usr/local/lib/gcc-4.2.3/gcc/i386-portbld-freebsd7.0/4.2.3/../../../libgcc_s.so
+.
+
+Index: work/OOH680_m1/external/gcc3_specific/makefile.mk
+===================================================================
+RCS file: /cvs/util/external/gcc3_specific/makefile.mk,v
+retrieving revision 1.5
+diff -u -r1.5 makefile.mk
+--- external/gcc3_specific/makefile.mk 30 Aug 2006 12:39:00 -0000 1.5
++++ external/gcc3_specific/makefile.mk 6 Jan 2008 08:10:19 -0000
+@@ -12,7 +12,6 @@
+
+ .IF "$(OS)"!="MACOSX"
+ .IF "$(OS)"!="IRIX"
+-.IF "$(OS)"!="FREEBSD"
+
+ .EXPORT : CC
+
+@@ -25,7 +24,6 @@
+ $(LB)$/libgcc_s.so.1 :
+ $(GCCINSTLIB) libgcc_s.so.1 $(LB)
+
+-.ENDIF
+ .ENDIF
+ .ENDIF
+