aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3-RC/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-11-25 03:19:22 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-11-25 03:19:22 +0000
commit1db390d2575cc4f3e5a3f3491bc4911fe4f33546 (patch)
tree05896a5459fadc1a8f8b2d225aa9144ee9e20b9e /editors/openoffice.org-3-RC/Makefile
parent1599d57f3cceaa4687eed902f725cf314088c396 (diff)
downloadports-1db390d2575cc4f3e5a3f3491bc4911fe4f33546.tar.gz
ports-1db390d2575cc4f3e5a3f3491bc4911fe4f33546.zip
Notes
Diffstat (limited to 'editors/openoffice.org-3-RC/Makefile')
-rw-r--r--editors/openoffice.org-3-RC/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index c52719589d8e..a199d3c50226 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -56,7 +56,7 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
GCC_TARGET= x86_64-portbld-freebsd${OSREL}
@@ -71,11 +71,10 @@ IGNORE= install lang/perl5.8 then try again
.endif
CODELINE= 680
-RELEASE_NR= 2.1
-MILESTONE?= 2
+MILESTONE?= 5
OOOTAG?= OOE680_m${MILESTONE}
OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
-SNAPDATE= 20061107
+SNAPDATE= 20061123
INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
@@ -237,13 +236,12 @@ post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
@${CP} ${FILESDIR}/openoffice.org-wrapper ${WRKDIR}/
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
- -e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
${WRKDIR}/openoffice.org-wrapper
@${INSTALL_SCRIPT} ${WRKDIR}/openoffice.org-wrapper \
${PREFIX}/bin/${EXECBASE}
- @${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/openoffice.org
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-sbase
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-scalc
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-sdraw
@@ -252,11 +250,11 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
- @${PRINTF} "bin/openoffice.org\n" > ${TMPPLIST}
- @${REINPLACE_CMD} -e 's#${RELEASE_NR}#${OOOVERSION}#g' \
- -e '/^Exec/s/printeradmin/spadmin/' \
+.if defined(WITH_MENU)
+ @${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
+ @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
${PREFIX}/share/applications/${EXECBASE}
@${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@@ -264,8 +262,8 @@ post-install:
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
${CP} ${ICONS}/hicolor/$${dir}/apps/$${app}.png \
- ${PREFIX}/share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png ; \
- ${PRINTF} "share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png\n" >> ${TMPPLIST} ; \
+ ${PREFIX}/share/icons/hicolor/$${dir}/apps/openofficeorg-21-$${app}.png ; \
+ ${PRINTF} "share/icons/hicolor/$${dir}/apps/openofficeorg-21-$${app}.png\n" >> ${TMPPLIST} ; \
fi \
done ; \
for file in `cd ${ICONS}/hicolor/$${dir}/mimetypes; ls *.png`; do \
@@ -274,6 +272,7 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
+.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@@ -285,7 +284,6 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
- -e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}