aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-17 03:15:55 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-17 03:15:55 +0000
commit870c5d1cf2f57519db65e670c78e691d8c4cea6f (patch)
tree599c0de3aed3a3eea3a29d7c253304ff447da225 /editors/openoffice.org-3
parente02465851840c15841672a5315dfe4b5fabca21c (diff)
downloadports-870c5d1cf2f57519db65e670c78e691d8c4cea6f.tar.gz
ports-870c5d1cf2f57519db65e670c78e691d8c4cea6f.zip
Notes
Diffstat (limited to 'editors/openoffice.org-3')
-rw-r--r--editors/openoffice.org-3/Makefile2
-rw-r--r--editors/openoffice.org-3/files/patch-i666678
2 files changed, 5 insertions, 5 deletions
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index a2f006a1eef8..dba23424bff1 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -182,7 +182,7 @@ WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
-.if (${OSVERSION} <= 700021)
+.if (${OSVERSION} <= 602102)
EXTRA_PATCHES+= ${FILESDIR}/rtld-workaround-i66667
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice.org-3/files/patch-i66667 b/editors/openoffice.org-3/files/patch-i66667
index a93aaea26176..c1d8cd362e9b 100644
--- a/editors/openoffice.org-3/files/patch-i66667
+++ b/editors/openoffice.org-3/files/patch-i66667
@@ -33,7 +33,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-+#if __FreeBSD_version < 700022
++#if __FreeBSD_version < 602103
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+#else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -57,7 +57,7 @@
OString symName( buf.makeStringAndClear() );
-//#iZ 22253
-+#if __FreeBSD_version < 700022 /* #i22253# */
++#if __FreeBSD_version < 602103 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+#else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
@@ -117,7 +117,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-+#if __FreeBSD_version < 700022
++#if __FreeBSD_version < 602103
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+#else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -129,7 +129,7 @@
buf.append( 'E' );
OString symName( buf.makeStringAndClear() );
-+#if __FreeBSD_version < 700022 /* #i22253# */
++#if __FreeBSD_version < 602103 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+#else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );