aboutsummaryrefslogtreecommitdiff
path: root/editors/poedit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-20 03:29:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-20 03:29:38 +0000
commitffb2ab569dbec2264b32db9181cfbf2aea6372a1 (patch)
tree62867d51cf742ead75ee0391b144d2dcfc0017b4 /editors/poedit
parent0143486cb424724b3b24e366ff24396e462b9af9 (diff)
downloadports-ffb2ab569dbec2264b32db9181cfbf2aea6372a1.tar.gz
ports-ffb2ab569dbec2264b32db9181cfbf2aea6372a1.zip
Notes
Diffstat (limited to 'editors/poedit')
-rw-r--r--editors/poedit/Makefile49
-rw-r--r--editors/poedit/distinfo6
-rw-r--r--editors/poedit/pkg-plist106
3 files changed, 112 insertions, 49 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index efdaa4b04c3f..e56695575408 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= poedit
-PORTVERSION= 1.3.4
-PORTREVISION= 1
+PORTVERSION= 1.3.5
+PORTREVISION= 0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,51 +18,30 @@ COMMENT= Gettext catalogs (.po files) editor
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell \
- db${LIB_SUFFIX}:${PORTSDIR}/databases/db${WITH_BDB_VER}
+ wx_gtk2u_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26-unicode
USE_X_PREFIX= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget
+USE_GNOME= gnometarget pkgconfig
+USE_BDB= yes
+WITH_BDB_HIGHEST= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ WXRC="${X11BASE}/bin/wxrc-gtk2u-2.6"
+CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2u-2.6-config
-CPPFLAGS= -I${LOCALBASE}/include/db${WITH_BDB_VER} \
+CPPFLAGS= -I${BDB_INCLUDE_DIR} \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS= -L${BDB_LIB_DIR} ${PTHREAD_LIBS}
MAN1= poedit.1
-.if defined(WITH_BDB2) || defined(WITH_DB2)
-WITH_BDB_VER= 2
-.elif defined(WITH_BDB3) || defined(WITH_DB3)
-WITH_BDB_VER= 3
-.elif defined(WITH_BDB4) || defined(WITH_DB4)
-WITH_BDB_VER= 4
-.elif defined(WITH_BDB41) || defined(WITH_DB41)
-WITH_BDB_VER= 41
-.elif defined(WITH_BDB42) || defined(WITH_DB42)
-WITH_BDB_VER= 42
-LIB_SUFFIX= -4.2
-.elif defined(WITH_BDB43) || defined(WITH_DB43)
-WITH_BDB_VER= 43
-LIB_SUFFIX= -4.3
-.endif
-WITH_BDB_VER?= 4
-LIB_SUFFIX?= ${WITH_BDB_VER}
-
-.if defined(WITH_WXGTK24)
-LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-CONFIGURE_ARGS+= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
-.else
-LIB_DEPENDS+= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
-CONFIGURE_ARGS+= --with-wx-config=${X11BASE}/bin/wxgtk2-2.6-config
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
- 's/for version in .*;/for version in ${WITH_BDB_VER};/ ; \
- s/-ldb-$$version/-ldb${LIB_SUFFIX}/' ${WRKSRC}/configure
+ 's/for version in .*;/for version in ${BDB_VER};/ ; \
+ s/-ldb-$$version/-l${BDB_LIB_NAME}/' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s/ install / /' ${WRKSRC}/Makefile.in
diff --git a/editors/poedit/distinfo b/editors/poedit/distinfo
index f150fe1ed5f3..baf2cdb21d37 100644
--- a/editors/poedit/distinfo
+++ b/editors/poedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (poedit-1.3.4.tar.gz) = e76a84ae4be4ad9d9a176fd8a1a2effb
-SHA256 (poedit-1.3.4.tar.gz) = 569b36317339af95d2efea41935620d9e759addd4cb9247d9e9a769998203625
-SIZE (poedit-1.3.4.tar.gz) = 2092161
+MD5 (poedit-1.3.5.tar.gz) = e91337ceeeb652b1d8e6b76566f31090
+SHA256 (poedit-1.3.5.tar.gz) = dacdecbbc0e92598426fb4803f5afa5ead17d5334f8909f2540866f32da03c3e
+SIZE (poedit-1.3.5.tar.gz) = 2604906
diff --git a/editors/poedit/pkg-plist b/editors/poedit/pkg-plist
index d8aaa4856e60..6e09cae593cc 100644
--- a/editors/poedit/pkg-plist
+++ b/editors/poedit/pkg-plist
@@ -1,6 +1,12 @@
bin/poedit
+share/pixmaps/poedit.png
+share/icons/hicolor/16x16/apps/poedit.png
+share/icons/hicolor/32x32/apps/poedit.png
+share/icons/hicolor/48x48/apps/poedit.png
+share/icons/hicolor/scalable/apps/poedit.svg
share/locale/af_ZA/LC_MESSAGES/poedit.mo
-share/locale/am_ET/LC_MESSAGES/poedit.mo
+share/locale/am/LC_MESSAGES/poedit.mo
+share/locale/ar/LC_MESSAGES/poedit.mo
share/locale/ast/LC_MESSAGES/poedit.mo
share/locale/be/LC_MESSAGES/poedit.mo
share/locale/bg/LC_MESSAGES/poedit.mo
@@ -35,7 +41,9 @@ share/locale/ku/LC_MESSAGES/poedit.mo
share/locale/ky/LC_MESSAGES/poedit.mo
share/locale/lt/LC_MESSAGES/poedit.mo
share/locale/lv/LC_MESSAGES/poedit.mo
+share/locale/mk/LC_MESSAGES/poedit.mo
share/locale/mn/LC_MESSAGES/poedit.mo
+share/locale/ms/LC_MESSAGES/poedit.mo
share/locale/nb/LC_MESSAGES/poedit.mo
share/locale/nl/LC_MESSAGES/poedit.mo
share/locale/nn/LC_MESSAGES/poedit.mo
@@ -49,25 +57,27 @@ share/locale/sk/LC_MESSAGES/poedit.mo
share/locale/sl/LC_MESSAGES/poedit.mo
share/locale/sq_AL/LC_MESSAGES/poedit.mo
share/locale/sr/LC_MESSAGES/poedit.mo
-share/locale/sv_SE/LC_MESSAGES/poedit.mo
+share/locale/sv/LC_MESSAGES/poedit.mo
share/locale/ta/LC_MESSAGES/poedit.mo
+share/locale/th/LC_MESSAGES/poedit.mo
share/locale/tr/LC_MESSAGES/poedit.mo
share/locale/tt/LC_MESSAGES/poedit.mo
share/locale/uk/LC_MESSAGES/poedit.mo
share/locale/wa/LC_MESSAGES/poedit.mo
share/locale/zh_CN/LC_MESSAGES/poedit.mo
share/locale/zh_TW/LC_MESSAGES/poedit.mo
-%%DATADIR%%/help-gettext.zip
-%%DATADIR%%/help-hr.zip
-%%DATADIR%%/help.zip
-%%DATADIR%%/resources.zip
-@dirrm %%DATADIR%%
@dirrmtry share/locale/tt/LC_MESSAGES
@dirrmtry share/locale/tt
-@dirrmtry share/locale/sv_SE/LC_MESSAGES
-@dirrmtry share/locale/sv_SE
+@dirrmtry share/locale/th/LC_MESSAGES
+@dirrmtry share/locale/th
+@dirrmtry share/locale/sv/LC_MESSAGES
+@dirrmtry share/locale/sv
@dirrmtry share/locale/sq_AL/LC_MESSAGES
@dirrmtry share/locale/sq_AL
+@dirrmtry share/locale/ms/LC_MESSAGES
+@dirrmtry share/locale/ms
+@dirrmtry share/locale/mk/LC_MESSAGES
+@dirrmtry share/locale/mk
@dirrmtry share/locale/ky/LC_MESSAGES
@dirrmtry share/locale/ky
@dirrmtry share/locale/ku/LC_MESSAGES
@@ -76,11 +86,85 @@ share/locale/zh_TW/LC_MESSAGES/poedit.mo
@dirrmtry share/locale/fur
@dirrmtry share/locale/es_PR/LC_MESSAGES
@dirrmtry share/locale/es_PR
+@dirrmtry share/locale/ar/LC_MESSAGES
+@dirrmtry share/locale/ar
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
-@dirrmtry share/locale/am_ET/LC_MESSAGES
-@dirrmtry share/locale/am_ET
+@dirrmtry share/locale/am/LC_MESSAGES
+@dirrmtry share/locale/am
@dirrmtry share/locale/af_ZA/LC_MESSAGES
@dirrmtry share/locale/af_ZA
@dirrmtry share/locale/br/LC_MESSAGES
@dirrmtry share/locale/br
+%%DATADIR%%/help/common/comment.gif
+%%DATADIR%%/help/common/fileopen.gif
+%%DATADIR%%/help/common/filesave.gif
+%%DATADIR%%/help/common/fullscreen.gif
+%%DATADIR%%/help/common/fuzzy.gif
+%%DATADIR%%/help/common/poedit.css
+%%DATADIR%%/help/common/quotes.gif
+%%DATADIR%%/help/common/update.gif
+%%DATADIR%%/help/en/basics.html
+%%DATADIR%%/help/en/gettext/gettext.hhc
+%%DATADIR%%/help/en/gettext/gettext.hhp
+%%DATADIR%%/help/en/gettext/gettext_1.html
+%%DATADIR%%/help/en/gettext/gettext_10.html
+%%DATADIR%%/help/en/gettext/gettext_11.html
+%%DATADIR%%/help/en/gettext/gettext_12.html
+%%DATADIR%%/help/en/gettext/gettext_2.html
+%%DATADIR%%/help/en/gettext/gettext_3.html
+%%DATADIR%%/help/en/gettext/gettext_4.html
+%%DATADIR%%/help/en/gettext/gettext_5.html
+%%DATADIR%%/help/en/gettext/gettext_6.html
+%%DATADIR%%/help/en/gettext/gettext_7.html
+%%DATADIR%%/help/en/gettext/gettext_8.html
+%%DATADIR%%/help/en/gettext/gettext_9.html
+%%DATADIR%%/help/en/gettext/gettext_foot.html
+%%DATADIR%%/help/en/gettext/gettext_toc.html
+%%DATADIR%%/help/en/gettext/index.html
+%%DATADIR%%/help/en/index.html
+%%DATADIR%%/help/en/manager.html
+%%DATADIR%%/help/en/menu.html
+%%DATADIR%%/help/en/poedit.hhc
+%%DATADIR%%/help/en/poedit.hhp
+%%DATADIR%%/help/en/settings.html
+%%DATADIR%%/help/en/tm.html
+%%DATADIR%%/help/en/ui.html
+%%DATADIR%%/help/en/update.html
+%%DATADIR%%/help/hr/basics.html
+%%DATADIR%%/help/hr/index.html
+%%DATADIR%%/help/hr/manager.html
+%%DATADIR%%/help/hr/menu.html
+%%DATADIR%%/help/hr/poedit.hhc
+%%DATADIR%%/help/hr/poedit.hhp
+%%DATADIR%%/help/hr/settings.html
+%%DATADIR%%/help/hr/tm.html
+%%DATADIR%%/help/hr/ui.html
+%%DATADIR%%/help/hr/update.html
+%%DATADIR%%/icons/README
+%%DATADIR%%/icons/document-new.png
+%%DATADIR%%/icons/document-open.png
+%%DATADIR%%/icons/document-properties.png
+%%DATADIR%%/icons/document-save.png
+%%DATADIR%%/icons/edit-delete.png
+%%DATADIR%%/icons/help-browser.png
+%%DATADIR%%/icons/poedit-comment.png
+%%DATADIR%%/icons/poedit-fuzzy.png
+%%DATADIR%%/icons/poedit-quotes.png
+%%DATADIR%%/icons/poedit-status-automatic.png
+%%DATADIR%%/icons/poedit-status-cat-mid.png
+%%DATADIR%%/icons/poedit-status-cat-no.png
+%%DATADIR%%/icons/poedit-status-cat-ok.png
+%%DATADIR%%/icons/poedit-status-comment-modif.png
+%%DATADIR%%/icons/poedit-status-comment.png
+%%DATADIR%%/icons/poedit-status-modified.png
+%%DATADIR%%/icons/poedit-status-nothing.png
+%%DATADIR%%/icons/poedit-update.png
+%%DATADIR%%/icons/view-fullscreen.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/help/hr
+@dirrm %%DATADIR%%/help/en/gettext
+@dirrm %%DATADIR%%/help/en
+@dirrm %%DATADIR%%/help/common
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%