aboutsummaryrefslogtreecommitdiff
path: root/editors/poedit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-21 15:52:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-21 15:52:35 +0000
commit4fcd623a911ebff1fb406f959932040af7ed40b2 (patch)
tree3179f0030b56361bd63473d24ab0af7ddce20dbf /editors/poedit
parent15b35ffaea08acdf8c14ea61767dbb931ac1b83f (diff)
downloadports-4fcd623a911ebff1fb406f959932040af7ed40b2.tar.gz
ports-4fcd623a911ebff1fb406f959932040af7ed40b2.zip
Notes
Diffstat (limited to 'editors/poedit')
-rw-r--r--editors/poedit/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index a941d5a74639..cbb8d2d5322d 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext \
db3:${PORTSDIR}/databases/db3
PATCH_DIST_ARGS= -d ${PATCH_WRKSRC} -E ${PATCH_DIST_STRIP} -p1
+USE_REINPLACE= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -42,10 +43,10 @@ CONFIGURE_ARGS+= --without-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$$(datadir)/gnome/|\$$(datadir)/|g ; \
+ s|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
.include <bsd.port.post.mk>