aboutsummaryrefslogtreecommitdiff
path: root/editors/poedit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-26 07:45:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-26 07:45:17 +0000
commit03ac65467161438ed76e0344d9b4e9ba0f7835f8 (patch)
treefe88db54d25213016b19d45c7eed3fcab566885a /editors/poedit
parent143ba8d562018eeadae7645c1aa48fbe66251574 (diff)
downloadports-03ac65467161438ed76e0344d9b4e9ba0f7835f8.tar.gz
ports-03ac65467161438ed76e0344d9b4e9ba0f7835f8.zip
Notes
Diffstat (limited to 'editors/poedit')
-rw-r--r--editors/poedit/Makefile17
-rw-r--r--editors/poedit/distinfo3
-rw-r--r--editors/poedit/files/patch-configure11
-rw-r--r--editors/poedit/files/patch-src::manager.cpp11
-rw-r--r--editors/poedit/pkg-plist3
5 files changed, 24 insertions, 21 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index d50cc5e170ad..ae55a97d4688 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -7,28 +7,31 @@
#
PORTNAME= poedit
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.6
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= poedit-1.1.5-wxwin-2.3.1.patch
+#PATCH_SITES= ${MASTER_SITES}
+#PATCHFILES= poedit-1.1.5-wxwin-2.3.1.patch
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
- wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk \
- db3:${PORTSDIR}/databases/db3
+ wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel \
+ db3:${PORTSDIR}/databases/db3 \
+ giconv:${PORTSDIR}/converters/libiconv
PATCH_DIST_ARGS= -d ${PATCH_WRKSRC} -E ${PATCH_DIST_STRIP} -p1
USE_X_PREFIX= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -liconv"
+ LIBS="-L${LOCALBASE}/lib -lgiconv"
USE_GMAKE= yes
+MAN1= poedit.1
+
.include <bsd.port.pre.mk>
.if defined(HAVE_GNOME)
diff --git a/editors/poedit/distinfo b/editors/poedit/distinfo
index bc6771de755d..36dcb9b8a24d 100644
--- a/editors/poedit/distinfo
+++ b/editors/poedit/distinfo
@@ -1,2 +1 @@
-MD5 (poedit-1.1.5.tar.gz) = b0fea841ee24f9f4cdcc3673138a6a05
-MD5 (poedit-1.1.5-wxwin-2.3.1.patch) = 840912cd70e8182adab34d8cdbaa1e60
+MD5 (poedit-1.1.6.tar.gz) = 52f0361d04b35e99e2064f10f3586d04
diff --git a/editors/poedit/files/patch-configure b/editors/poedit/files/patch-configure
new file mode 100644
index 000000000000..8f1514cbf005
--- /dev/null
+++ b/editors/poedit/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Feb 26 15:09:09 2002
++++ configure Tue Feb 26 15:09:22 2002
+@@ -1996,7 +1996,7 @@
+ cat conftest.$ac_ext >&5
+ fi
+ rm -f conftest*
+-test "$ac_cv_search_db_create" = "no" && for i in db-3.6 db-3.5 db-3.4 db-3.3 db-3.2 db-3.1 db; do
++test "$ac_cv_search_db_create" = "no" && for i in db-3.6 db-3.5 db-3.4 db-3.3 db-3.2 db-3.1 db3; do
+ LIBS="-l$i $ac_func_search_save_LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2003 "configure"
diff --git a/editors/poedit/files/patch-src::manager.cpp b/editors/poedit/files/patch-src::manager.cpp
deleted file mode 100644
index 0a7c6d8f1f4e..000000000000
--- a/editors/poedit/files/patch-src::manager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/manager.cpp.orig Thu Nov 29 04:30:28 2001
-+++ src/manager.cpp Thu Nov 29 04:30:40 2001
-@@ -171,7 +171,7 @@
- cat.GetStatistics(&all, &fuzzy, &untranslated);
- modtime = wxFileModificationTime(file);
- lastmodified = cat.Header().RevisionDate;
-- cfg->Write(key + _T("timestamp"), modtime);
-+ cfg->Write(key + _T("timestamp"), (long)modtime);
- cfg->Write(key + _T("all"), (long)all);
- cfg->Write(key + _T("fuzzy"), (long)fuzzy);
- cfg->Write(key + _T("untranslated"), (long)untranslated);
diff --git a/editors/poedit/pkg-plist b/editors/poedit/pkg-plist
index e54e216b1b44..f5c17756d612 100644
--- a/editors/poedit/pkg-plist
+++ b/editors/poedit/pkg-plist
@@ -5,4 +5,5 @@ bin/poedit
%%GNOME:%%share/gnome/pixmaps/poedit.xpm
%%GNOME:%%share/gnome/poedit/help.zip
%%GNOME:%%share/gnome/poedit/resources.zip
-@dirrm share/gnome/poedit
+%%GNOME:%%share/gnome/locale/cs/LC_MESSAGES/poedit.mo
+%%GNOME:%%@dirrm share/gnome/poedit